Outlook for iOS または Android が Exchange Server に接続するときのエラー: 安全でない接続またはセキュリティで保護された接続が使用できない

元の KB 番号: 4056392

現象

Microsoft Outlook for iOS または Outlook for Android を使用して、セキュリティで保護された接続に SSL 証明書を使用するExchange Serverのインスタンスにサインインすると、次のいずれかのエラー メッセージが表示されます。

安全でない接続。 とにかくログインしますか?

セキュリティで保護された接続が使用できません。 とにかくログインしますか?

原因

この問題は、次のいずれかの理由で SSL 証明書がサポートされていないと見なされるために発生します。

  • SSL 証明書が無効であるか、有効期限が切れています。
  • SSL 証明書は信頼されていません。

注:

Outlook for iOS および Outlook for Android では、標準の Java 信頼された証明機関 (CA) が使用されます。 organizationの証明書が、標準の Java 信頼された証明機関の一部である証明機関によって署名されていない場合、このエラーが発生します。

解決方法

このエラー メッセージは無視して、Exchange Serverにサインインしても問題ありません。 このエラー メッセージは 1 回だけ表示する必要があります。

Java CA 証明書ストアで正式にサポートされている SSL 証明書を使用することをお勧めします。

証明書が Java CA によって信頼されていることを確認する方法

  1. 証明書の CA を取得します。

  2. 最新の Java SE 開発キット (JDK) をダウンロードします。 このキットには、Java の信頼された CA が含まれています。

  3. Windows ベースのコンピューターでコマンド プロンプト ウィンドウを開くか、macOS ベースのコンピューターでターミナル ウィンドウを開きます。

  4. keytool ユーティリティを使用して、次のコマンドを実行して信頼できる CA を一覧表示します。

     keytool -keystore "<keystore location>" -storepass changeit -list -v
    

    注:

    macOS ベースのコンピューターでは、キーストアの <場所> パラメーターに "$JAVA_HOME/jre/lib/security/cacerts" を指定できます。

  5. 証明書の CA が一覧にあることを確認します。

keytool ユーティリティの詳細については、次の記事を参照してください。