MiracastView パッケージ Windows 10 バージョン 1709 にコンピューターをアップグレードした後 sysprep エラーが発生します。

適用対象: Windows 10, version 1709

現象


次のような状況を考えます。

  • Windows 10 バージョンの 1703 ベースのコンピューターでは、MiracastView 組み込みアプリケーションは、既定でインストールされています。
  • 10 バージョン 1709 の Windows にコンピューターをアップグレードするとします。
  • 管理者権限を持つコマンド プロンプト ウィンドウを開くし、次のコマンドを実行します。
    cd %windir%\System32\Sysprepsysprep.exe /generalize /oobe /reboot

このシナリオでは、sysprep コマンドが失敗します。次のようなエラー メッセージが表示されます。

sysprep のエラー

さらに、Setupact のログには、以下のようなエラー メッセージが含まれています。

削除 AppxPackage の PowerShell コマンドを使用して MiracastView を削除して、コマンドが機能しない場合は、次のエラー メッセージが表示されます。

エラー メッセージ

原因


この問題は、セットアップがアップグレード中にWindows.MiracastView_6.3.0.0_neutral_neutral_cw5n1h2txyewyパッケージを移行する方法のバグにより発生します。このパッケージは、一般化されたイメージでは正しく機能しません。

回避策


この問題を回避するには、次の方法のいずれかを使用します。

方法 1

10 バージョン 1709 の Windows コンピューターで、 Windows.MiracastView_6.3.0.0_neutral_neutral_cw5n1h2txyewy.xml C:\Windows.old\ProgramData\Microsoft\Windows\AppRepository\ からにコピー C:\ProgramData\Microsoft\Windows\AppRepository

方法 2

10 バージョン 1703 の Windows コンピューターから Windows 10 バージョン 1709 コンピューターにC:\Windows\MiracastViewフォルダーをコピーします。次に、コンピューターを再起動して windows の MiracastView のアンインストールを完了します。