Azure portalでの VM ブート診断のエラー: ログの内容を取得できませんでした

この記事では、Azure portalの [ブート診断] ブレードで仮想マシンのスクリーン ショットを表示するときに "ログの内容を取得できませんでした" エラーが発生する問題の解決策について説明します。

元の製品バージョン: Windows を実行している仮想マシン、Linux を実行している仮想マシン
元の KB 番号: 4094480

現象

Azure portalの [ブート診断] ブレードで仮想マシンのスクリーン ショットを表示しようとすると、エラーが発生し、通知領域に次のエントリが記録されます。

仮想マシン '/subscriptions/SUBID>/resourceGroups/RGNAME>/providers</<Microsoft.Compute/virtualMachines</VMNAME>' のログ '<log url>' の内容を取得できませんでした。 エラー メッセージ: 'description: 'getExtendedInfoBlob' メッセージの RPC 呼び出しを完了できませんでした: 'getExtendedInfoBlob' スタックの RPC 呼び出しを完了できませんでした: ###RPC_Exception### FROM RPC: Microsoft_Azure_Compute -> Microsoft_Azure_Storage (getExtendedInfoBlob) (呼び出し履歴キャプチャが有効になっていません)。?trace=診断 を使用して有効にします)。'

原因

この問題は、次のいずれかの理由で発生する可能性があります。

  • Windows Server 2008 R2 以前のバージョンで実行されるVirtual Machinesは、VM 正常性レポートを生成しません。 そのため、ブート診断ストレージ アカウントにSerialConsole.log ファイルが生成されていないことが予想され、「現象」セクションに記載されているエラー メッセージが表示されます。 オペレーティング システムのバージョンを確認するには、コマンド プロンプト ウィンドウを開き、「 winver」と入力し、Enter キーを押します。 (回避策 1 を参照)

  • 古い VM ゲスト エージェント バージョン (2.7.1198.806 より前) がインストールされている仮想マシンは、VM 正常性レポートを生成する必要はありません。 そのため、ブート診断ストレージ アカウントにSerialConsole.log ファイルが生成されていないことが予想され、「現象」セクションに記載されているエラー メッセージが表示されます。 VM ゲスト エージェントのバージョンを確認するには、フォルダーを C:\WindowsAzure\logs\WaAppAgent.log 開き、次を検索します。

    WindowsAzureGuestAgent の開始。 バージョン 2.7.1198.802 (回避策 2 を参照)

  • VM ゲスト エージェントによる VM 正常性レポートの自動生成が失敗する可能性があります。 この場合、SerialConsole.log ファイルは作成されません。 これにより、「現象」セクションに記載されているエラー メッセージがトリガーされます。 たとえば、未解決の SID が仮想マシンのローカル管理者グループのメンバーとして報告されている場合、このレポートは生成されません。 このような問題を検索するには、ファイルを C:\WindowsAzure\logs\TransparentInstaller.log 調べます。 (回避策 3 を参照)

回避策

この問題を回避するには、次の方法を試してください。

回避策 1

オペレーティング システムを新しいバージョンにアップグレードします。

回避策 2

バージョン 2.7.1198.822 をインストールして、VM ゲスト エージェントを更新します。

回避策 3

関連付けられているユーザーがドメインから削除されたかどうかを確認します。

また、未解決の SID (S-1-5-21-XYZ-XYZ など) をローカル管理者グループから削除することもできます。

また、ローカル管理者グループをロックダウンしているドメイン ポリシーがあるかどうか、または組み込みの管理者アカウントが削除されたかどうかをチェックします (Transparent Installer ログの "0x80005004" で示されます)。

回避策 4

問題がホスト上のシリアル ポートに影響すると思われる場合は、VM を再デプロイして別のホストに移動できます。

警告

このアクションにより、VM の再起動がトリガーされます。

状態

この問題の解決に取り組んでいます。 私たちの目標は、SerialConsole.logファイルが生成されないケースの検出を改善し、このエラーが侵入しすぎないようにすることです。

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