Windows で外字エディタを使用して外字を作成する方法

適用対象: Windows 7 EnterpriseMicrosoft Windows XP ProfessionalMicrosoft Windows XP Home Edition

概要


この資料は、外字エディタを使用して外字を作成する方法について説明したものです。この資料では、次の 6 つセクションに分けて説明します。
  • 外字フォントの種類
  • 外字ファイル
  • 外字の作成
  • 外字の編集
  • 外字の入力
  • 文字セット

詳細


外字フォントの種類

外字エディタを使用して外字を作成する場合、作成した外字をフォントライブラリに含まれるすべてのフォントに関連付ける方法と指定したフォントに関連付ける方法を選択することができます。 すべてのフォントに関連付ける場合には、共通の外字として登録され、どのフォントを選択しても外字を表示できます。指定したフォントに関連付ける場合には、特定のフォントでのみ外字を表示できます。


注意 : 指定したフォントに関連付けて作成された外字は特定のフォントのみ使用できますが、特定のフォントに関連付けることによって、その書体らしいデザインに変更されるわけではありません。

外字ファイル

作成した外字は登録するフォントごとに *.TTE、 *.EUF ファイルに格納されます。
外字作成時に [すべてのフォントにリンクする] を選択した場合には、EUDC.TTE、 および EUDC.EUF という名前のファイルに格納されます。
外字作成時に [指定したフォントにリンクする] を選択した場合には、任意のファイル 名で拡張子が .TTE、.EUF の各ファイルに格納されます。
拡張子が .TTE のファイルは外字フォントのデータが格納され、.EUF のファイル は外字 フォントの管理に使用されます。

注意 : 作成した外字を他のマシンで使用することは動作保証外となっております。同一マシン内でのみご使用ください。

外字の作成

外字を作成する方法を以下に示します。
ここではコード F040 に登録する手順を例に説明します。
  1. 外字エディタを起動します。
  2. [コードの選択] ウィンドウが開きます。
  3. 登録先のコードを選択します。 一番左上 (F040 と記述されている隣) のマス目をクリックします。[コード] ボッ スクに [F040] と表示されていることを確認し、[OK] をクリックします。 各マス目に ・ が表示されている場合には、そのコードに文字が定義されていない ことを表しています。 それ以外の文字が表示されている場合に、そのコードを選択して外字を作成すると 、新しい外字が上書きされますので、ご注意ください。 以前に外字ファイルの作成と特定のフォントの選択でフォントへの関連付けを行って いる場合は、一度 [コードの選択] ウィンドウを [キャンセル] で閉じ、メニュ ーバーの [ファイル] - [フォントのリンク] - [指定したフォントにリンクする] から再度関連付けられたフォントを選択します。
  4. [編集] ウィンドウが開きます。 ウィンドウ左側に表示されているツールバーのオプションを使用して、外字を作成 します。ツールバーの目的の描画ボタンをクリックし、[編集] ウィンドウでドラッ グします。塗りつぶした領域を消すには、描画ボタンをクリックし、右ボタンで ドラッグします。
  5. 既存の文字を参照して新しい外字を作成する場合には、メニューバーの [ウィンドウ]- [参照] をクリックします。[参照] ダイアログ ボックスが表示されま す。 [フォント] ボタンをクリックし、参照する文字が登録されているフォントを選択しま す。 コード番号一覧で参照する文字をクリックし、[OK] をクリックします。文字を選 択する場合には、[コード] ボックスや [形] ボックスに参照する文字のコードや文 字を直接入力しても選択できます。 なお、Windows 2000 、Windows XP では、文字のコードは Unicode でのみ指定が可能です。
    注意 : [参照] ダイアログ ボックスを表示した時に、MS UI ゴシック等の True
    Type フォントが設定されていることを確認して下さい。設定されていない場合に
    は、必ず [フォント] ボタンをクリックして、True Type フォントを一覧から選択
    し直すことをお勧めします。フォントに非 True Type フォントを設定していると、
    あとから参照すると参照する文字のデザインが小さくなる場合があります。
  6. 作成した外字を保存します。 手順 3. で選択したコードにそのまま保存する場合には、メニューバーの [編集] - [同じコードで保存] をクリックします。別のコードで保存する場合には、メニュ ーバーの [編集] - [コードを変更して保存] をクリックし、保存先のコードを選択 します。

    外字ファイルの作成と特定のフォントの選択

    フォントを選択して外字を作成する場合には、外字ファイルを作成した後で、 フォントとその外字ファイルを関連付ける必要があります。以下にその手順を 示します。
    1. 外字エディタを起動します。
    2. [コードの選択] ウィンドウが開きますので、登録先のコードを選択し、[OK] を クリックします。
    3. メニューバーの [ファイル] - [フォントのリンク] をクリックします。
    4. [外字フォントの種類] ボックスの [指定したフォントにリンクする] オプション ボタンをクリックします。
    5. [フォントの選択] 一覧で、外字ファイルを関連付けるフォントをクリックし、 [名前をつけて保存] ボタンをクリックします。 [フォントの選択] 一覧には、左側にフォント名、右側に関連付けられている ファイル名が表示されます。ファイル名に [未選択] と表示されている場合に は、外字ファイルが関連付けられていません。
    6. [保存する場所] ボックスで、外字ファイルを保存する場所を指定します。
    7. [ファイル名] ボックスで、外字ファイル名を指定します。ファイル名は任意で つけることができます。 たとえば、MS UI ゴシックに関連付ける外字ファイルを作成する場合に GOTHIC.TTE というように入力します。拡張子の .TTE は入力してもしなくて も、自動的に付加されます。
    8. [保存] をクリックします。
    9. [フォントのリンク] 画面に戻りますので、[OK] をクリックします。

    フォントと外字ファイルの関連付けの変更と解除

    フォントと外字ファイルの関連付けは、解除、変更することができます。したがっ て、複数の外字ファイルを作成して、外字ファイルを切り替えることができます。
    以下にその手順を示します。
    1. 外字エディタを起動します。
    2. メニューバーの [ファイル] - [フォントのリンク] をクリックします。
    3. [外字フォントの種類] ボックスの [指定したフォントにリンクする] オプションボタンをクリックします。
    4. [フォントの選択] ボックスで、リンクを変更する場合には、[名前をつけて保存] で変更する外字ファイルを選択し、[保存] ボタンをクリックします。
      リンクを解除する場合には [削除] ボタンをクリックします。

外字の編集

既存の外字を修正する方法を以下に示します。
  1. 外字エディタを起動します。
  2. [コードの選択] ウィンドウが開きます。
  3. コード番号一覧で、編集する外字をクリックし、[OK] をクリックします。
  4. 外字を修正します。
  5. メニューバーの [編集] - [同じコードで保存] をクリックし、外字の変更を保存し ます。

    既存の外字を参照して新しい外字を作成する

    既存の外字を参照して新しい外字を作成するには、一度既存のファイルを読み込んで 編集し、別のコードで保存します。
    上記「外字の編集」の 手順 1.~ 5. に従って、既存の外字を読み出し、編集します。最後に、作成した外字を新しいコードで保存するために、メニューバーの [編集]-[コードを変更して保存] をクリックし、コード番号一覧で文字が登録されていないコード (・が表示されているコード) を選択して保存します。

外字の入力

MS-IME98 および MS-IME2000 や MS-IME2002 で外字を入力するには、がいじ と入力し、<F5> キーまた は <Ctrl> + <Y> キーを押します。 起動してきた IME パッドで、入力したい外字を選択して入力します。

文字セット

外字エディタは、Unicode 文字セットと互換性があります。日本語、中国語、韓国語など極東地域の言語設定でシステムが稼動している場合には、外字エディタで Windows 文字セットを扱うことができます。