ActiveSync クライアントが接続できないか、Exchange Server 環境での同期が遅延

適用対象: Exchange Server 2016 Enterprise EditionExchange Server 2013 Enterprise

現象


、2016 の Microsoft Exchange Server または Microsoft Exchange Server 2013 環境では、ActiveSync クライアントが接続できないか、ユーザーがモバイル デバイスを同期するときに遅延が発生しました。 この問題は、数週間の通常のしばらくの間では、ActiveSync アプリケーション プールが実行された後に発生します。 さらに、次の現象が発生する可能性があります。

  • ActiveSync アプリケーション プールは、大量のメモリを消費します。
  • ActiveSync アプリケーション プールに対応している w3wp インスタンスの.NET CLR Memory/% Time in GCカウンターは、異常に高い。
  • TCP ポートの消費は、ActiveSync での要求の数が多いために発生します。
  • MSExchangeSyncAppPoolインスタンスのW3SVC_W3WP とアクティブな要求のカウンターは、いくつかの日数または週数を着実に増加値を示しています。
  • Netstat anobコマンドは、 CLOSE_WAIT状態で多くの接続を表示する可能性があります。

原因


これは、ActiveSync の Ping コマンドが、アプリケーション プール内で孤立しているときに発生する既知の問題です。

回避策


この問題を回避するには、孤立したコマンドを解放するのには ActiveSync アプリケーション プールを定期的にサイクルです。

一定の間隔で自動的にリサイクルするアプリケーション プールを構成する方法の詳細については、Microsoft のドキュメントの web サイトで [< リサイクル > アプリケーション プールのリサイクルの設定] のトピックを参照してください。