非アクティブなメールボックスがオンプレミスの Active Directory アカウントに自動的に再接続されない

元の KB 番号: 4337973

現象

オンプレミスの Active Directory アカウントが Microsoft Entra Connect のスコープに戻されると、非アクティブなメールボックスはExchange Onlineで自動的に再接続されません。 さらに、新しくプロビジョニングされたメールボックスがExchange Onlineに作成されます。

注:

専用/ITAR のお客様Office 365、Microsoft Managed Services Service Provisioning Provider (MMSSPP) は、共存フェーズ中に、 属性と ExchangeGUID 属性を専用環境から顧客のオンプレミスの Active Directoryに書き戻msExchMailboxGUIDします。 Exchange Onlineで新しくプロビジョニングされたメールボックスの代わりに、メールが有効なユーザーが作成されます。

原因

メールボックス オブジェクトは、Microsoft Entra Connect のスコープから削除された後、30 日間Microsoft Entra IDごみ箱に残ります。 アカウントがごみ箱から消去されたときに、オンプレミスの AD アカウントを非アクティブなメールボックスに再接続する追加の手順を実行する必要があります。

解決方法

この問題を解決するには、次のプロセスを使用します。

元のメールボックスからコンテンツを転送する

New-MailboxRestoreRequest コマンドレットを使用して、非アクティブなメールボックスから新しくプロビジョニングされたメールボックスにコンテンツを復元します。 これにより、引き続き新しいメールボックスを使用し、元のコンテンツをコピーできます。

元の非アクティブなメールボックスを再接続する

注:

このプロセスは、論理的に削除されたメールボックスが新しいオンプレミス AD アカウントに接続されている場合にも機能します。 パラメーターを SoftDeletedMailbox 使用してパラメーターを InactiveMailboxOnly 置き換える必要があります。

  1. 次のコマンドを実行して、Exchange Online PowerShell から非アクティブなメールボックス属性を取得します。

    $InactiveMailbox = Get-Mailbox -InactiveMailboxOnly -Identity <identity of inactive mailbox>
    
  2. 次のコマンドを実行して、非アクティブなメールボックスをクラウド アカウントに一時的に関連付けます。

    New-Mailbox -InactiveMailbox $InactiveMailbox.DistinguishedName -Name "<name of inactive mailbox>" -DisplayName "<DisplayName of inactive mailbox>" -MicrosoftOnlineServicesID <alias@*.onmicrosoft.com> -Password (ConvertTo-SecureString -String <PasswordString> -AsPlainText -Force) -ResetPasswordOnNextLogon $true
    
  3. Azure Active Directory PowerShell モジュールに接続し、次のコマンドを実行して属性を ObjectGUID 取得します。

     Get-ADUser -Identity <ADUser> -Properties "ObjectGUID"
    
  4. 既定で ImmutableID オンプレミス属性であるパラメーター値を ObjectGUID 取得します。 にImmutableID変換ObjectGUIDするには、Windows PowerShellで次のコマンドを使用します。

    [system.convert]::ToBase64String(([GUID]"<ObjectGUID>").tobytearray())
    
  5. ImmutableID Microsoft Entra IDでパラメーターを設定します。

    Set-MsolUser -UserPrincipalName <UPN> -ImmutableId <ImmutableId>
    

    注:

    Azure AD および MSOnline PowerShell モジュールは、2024 年 3 月 30 日の時点で非推奨となりました。 詳細については、 非推奨の更新プログラムに関するページを参照してください。 この日付以降、これらのモジュールのサポートは、Microsoft Graph PowerShell SDK への移行支援とセキュリティ修正に限定されます。 非推奨のモジュールは、2025 年 3 月 30 日まで引き続き機能します。

    Microsoft Entra ID (旧称 Azure AD) と対話するには、Microsoft Graph PowerShell に移行することをお勧めします。 移行に関する一般的な質問については、移行に関する FAQ を参照してください。 メモ: バージョン 1.0.x の MSOnline では、2024 年 6 月 30 日以降に中断が発生する可能性があります。

  6. Microsoft Entra Connect 差分同期を実行します。これにより、元のMicrosoft Entra アカウントが Microsoft Entra Connect のスコープに取り込まれます。

  7. メールボックス オブジェクトを確認し、プライマリ SMTP アドレスが一時ユーザー プリンシパル名 (UPN) の値から正しいプライマリ アドレスに更新されていることを確認します。

    注:

    新しいメールボックスが訴訟ホールドに対して有効になっていません。 さらに、次の警告メッセージが表示されます。
    警告: 非アクティブなメールボックスが復旧されました。 有効なライセンスを取得するまでデータを保持するために、単一アイテムの回復を 30 日間有効にしました。 さらに、保持ホールドを 30 日間有効にしました。 このメールボックスに有効なライセンスが割り当てられたら、これらの設定を無効にし、代わりに訴訟または In-Place 保留を使用してデータを保持できます。

  8. Exchange Server ライセンスと適切な保留設定を新しいメールボックスに適用します。

詳細

「解決」セクションの手順は、「 Microsoft 365 で非アクティブなメールボックスを復元する」のクラウド メールボックスの手順に従って調整されています。

さらにヘルプが必要ですか? Microsoft コミュニティを参照してください。