Microsoft Dynamics 365でソリューションパッチをインポートしようとすると、エラー コード80048539が発生します
この記事では、Microsoft Dynamics 365でソリューションパッチをインポートしようとしたときに発生する可能性があるエラー コード80048539の解決策について説明します。
適用対象:Microsoft Dynamics 365
元の KB 番号: 4471087
現象
Microsoft Dynamics 365でソリューションパッチをインポートしようとすると、次のエラーが発生します。
ソリューションのインポート: [ソリューション パッチ名] が失敗しました。
エラー コードの80048539。
ログ ファイルをダウンロードして Excel で開くと、次のような詳細が表示されます。
症状 1 詳細:
エラー 0x80048539
ソリューション マニフェストのインポート: エラー: パッチ バージョン 1.0.1.0 は親バージョン 1.1.0.0 では無効です
症状 2 詳細:
エラー 0x80048539
ソリューション マニフェストのインポート: FAILURE: ソリューションMyPatchTesting_Upgrade保持は既に存在します。
原因
注:
make.powerapps.com を使用してアンマネージド ソリューションの更新プログラムをインポートし、このエラーを受け取る場合、Microsoft はこの問題を認識しており、修正に取り組んでいます。 問題を回避するには、[ 詳細設定 ] を開き、[ 更新 (推奨されません)] オプションを選択します。
エラー コード 80048539 は、無効なパッチがインポートされていることを示します。 次のようないくつかの潜在的な原因があります。
原因 1
上記の「現象 1 の詳細」セクションに記載されているエラーの詳細が表示される場合:
ソリューションパッチのバージョンは、既にインストールされているソリューションのバージョンよりも低くなっています。 たとえば、SolutionA という名前のソリューションはバージョン 1.1.0.0 で既にインストールされており、バージョン 1.0.1.0 のパッチをインポートしようとしています。
原因 2
上記の「現象 2 の詳細」セクションに記載されているエラーの詳細が表示される場合:
これは、そのソリューションに対して既にインポートされているアップグレードがあるが、まだ適用されていない場合に発生する可能性があります。 既存のソリューションのアップグレードであるソリューションをインポートすると、ソリューションのインポートの最後に、ソリューションのアップグレードを適用するためのボタンが表示されます。 このソリューションのソリューションアップグレードの前のインポート中にそのボタンを選択しなかった場合は、ソリューションの一覧でソリューションを見つけて、[ソリューションのアップグレードの 適用 ] ボタンを選択する必要があります。
解決方法
解決方法 1
上記の「現象 1 の詳細」セクションに記載されているエラーの詳細が表示される場合:
インポートしようとしているソリューションパッチのバージョンが、既にインストールされているソリューションよりも高いバージョンであることを確認します。
解決方法 2
上記の「現象 2 の詳細」セクションに記載されているエラーの詳細が表示される場合:
[設定]、[カスタマイズ] の順に移動し、[ソリューション] を選択します。 アップグレードしようとしている既存のインストール済みソリューションを選択し、[ソリューションのアップグレードの 適用] を選択します。
フィードバック
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