現象
Dynamics 365 でソリューションの更新プログラムをインポートしようとすると、次のエラーが発生します。
"ソリューションのインポート: [ソリューションの更新プログラムの名前] に失敗しました。エラー コード 80048539。
ログ ファイルをダウンロードして Excel で開き、次のように追加の詳細が表示されます。
現象 1 の詳細:
"エラー 0x80048539ソリューション マニフェストのインポート: エラー: 修正プログラムのバージョン 1.0.1.0 が親バージョン 1.1.0.0 に対して有効ではありません」
現象 2 の詳細:
"エラー 0x80048539ソリューション マニフェストのインポート: エラー: MyPatchTesting_Upgrade のソリューションを既に保持しているが存在する」。
原因
エラー コード 80048539 は、無効な更新プログラムがインポートされていることを示します。次のよう、いくつかの潜在的な原因があります。
原因 1:上記 1 の詳細セクションの現象で説明したエラーの詳細が表示されます。 場合、
ソリューションの修正プログラムのバージョンは、既にインストールされているソリューションのバージョンよりも安価です。例: バージョン 1.1.0.0 とされており、ソリューションが既にインストールされて、バージョン 1.0.1.0 パッチをインポートしようとしています。
原因 2:表示する場合は、エラーの詳細に記載されている現象の上に記載されている 2 つの詳細セクション。
これは、そのソリューションのインポート、アップグレードが既にあるが、まだ適用されていない場合に発生します。アップグレードは、既存のソリューションのソリューションをインポートすると、ソリューションのインポートの最後には、ソリューションのアップグレードを適用するためのボタンが用意されています。このソリューションのソリューションのアップグレードの前のインポート中にそのボタンをクリックしてしなければ、ソリューションのアップグレードの適用] をクリックして、[ソリューション] ボックスの一覧で、ソリューションを見つける必要があります。
解決方法
解決方法 1:上記 1 の詳細セクションの現象で説明したエラーの詳細が表示されます。 場合、
インポートしようとしているソリューションの修正プログラムのバージョンが既にインストールされているソリューションよりも高いバージョンであることを確認します。
解決方法 2:表示する場合は、エラーの詳細に記載されている現象の上に記載されている 2 つの詳細セクション。
設定、カスタマイズに移動し、し、[ソリューション] をクリックします。アップグレードし、[ソリューションのアップグレードの適用] をクリックしてしようとしている既存のインストールされているソリューションを選択します。