UnknownIncomingEmailIntegrationError -2147220956 例外は、Microsoft Dynamics 365 の同期アラート Server-Side に表示されます

この記事では、Microsoft Dynamics 365 メールボックス レコード内で発生するエラーの解決策について説明します。

適用対象:Microsoft Dynamics 365
元の KB 番号: 4471762

現象

次のような警告レベルのアラートは、Dynamics 365メールボックス レコード内に表示されます。

"メールボックス "[メールボックス名] を介して電子メールを受信中に不明なエラーが発生しました。 関連付けられている電子メール サーバー プロファイルの所有者 [プロファイル名] が通知されました。 システムは後で電子メールを受信しようとします。

Email サーバー エラー コード: Exchange サーバーから UnknownIncomingEmailIntegrationError -2147220956 例外が返されました。

原因

エラー コード -2147220956 は、IsvUnexpected エラーを示します。 これは通常、カスタム プラグインまたはワークフローがエラーをスローし、アイテムの作成が失敗したことを示します。

解決方法

次の手順では、作成に失敗している電子メール レコードの例を使用します。 予定、連絡先、タスクなどの別の種類のアイテムに対してこのエラーが記録されている場合は、メールへの参照をトラブルシューティングするレコードの種類に置き換えることで、同じ種類の手順を適用できます。

電子メールの作成時に同期的に実行されるカスタム プラグインまたはワークフローがあるかどうかを確認します。 プラグインまたはワークフローでエラーが発生している場合、Server-Side 同期では電子メールは作成されません。 次の手順は、電子メールの作成時に実行されるワークフローまたはプラグインがorganizationに存在するかどうかを識別するのに役立ちます。

ワークフロー

  1. Dynamics 365 Web アプリケーション内で、[設定] に移動し、[プロセス] を選択します

  2. ビューを [アクティブ化されたプロセス] に変更します。

  3. [プライマリ エンティティ] 列を並べ替え、Emailがプライマリ エンティティとして、ワークフローがカテゴリである行を探します。

    代わりに、グリッドのフィルターオプションを使用して、Category = Workflow と Primary Entity = Emailでフィルター処理できます。

  4. 上記の条件を満たすワークフロー (存在する場合) を開きます。

  5. [Start when options have the Record is created]\(レコードが作成 された時点で開始\) オプションが選択されていて、[ バックグラウンドでこのワークフローを実行する (推奨)] オプションが選択されていない場合、このワークフローが原因である可能性があります。

    注:

    予定、連絡先、またはタスクでこの種類のエラーをトラブルシューティングする場合は、その種類のレコードの更新中にワークフローが実行されるように構成されているかどうかもチェック。

  6. ページの左側にある [ プロセス セッション] セクションを選択し、正常に作成されなかったメールに関連するエラーを探します。

プラグイン

  1. Dynamics 365 Web アプリケーション内で、[設定]、[カスタマイズ] の順に移動し、[システムのカスタマイズ] を選択します。
  2. [ Sdk メッセージ処理ステップ] を選択します
  3. [プライマリ オブジェクトの種類コード (SdkMessage フィルター)] 列で並べ替え、Email エンティティの行を探します。
  4. 行が見つかると、実行モードが同期である場合、電子メールの作成に干渉する可能性があります。

問題が一貫して再現され、ワークフローまたはプラグインをテストとして一時的に無効にできる場合は、ワークフローまたはプラグインが原因であるかどうかを判断できます。