ログにイベント 1098 を含む移行後に Outlook プロファイルMicrosoft Entra ID作成できない

元の KB 番号: 4499299

現象

ドメイン移行後に Microsoft Outlook プロファイルを作成しようとすると、Outlook を起動できないか、問題が発生したことを示すエラー メッセージが表示されます。 サインイン プロンプトも表示されます。

Outlook エラー メッセージのスクリーンショット。

さらに、次のエラーのようなイベント 1098 Microsoft Entra操作ログに表示される場合があります。

エラー: 2147943712

ErrorMessage: 指定されたログオン セッションが存在しません。 既に終了している可能性があります。 指定されたログオン セッションが存在しません。 既に終了している可能性があります。

AdditionalInformation: webaccountprocessor.cpp の型 'class WinRTException' の例外、行: 190、メソッド:
Microsoft Entra ID::Core::WebAccountProcessor::P rocessBrokerRequest::<lambda_>::operator ()。 ログ: トークン ブローカー操作0xcaa5001c失敗しました。 操作名: RequestToken webaccountprocessor.cpp でログに記録されます。行: 520、メソッド: Microsoft Entra ID::Core::WebAccountProcessor::ReportException。

イベント ビューアーでMicrosoft Entra運用ログを見つけるには、アプリケーションとサービス ログ>Microsoft>Windows>Microsoft Entra ID>Operational を見つけます。

イベント ビューアーのMicrosoft Entra場所を示すスクリーンショット。

原因

ユーザーを新しいドメインに移行するなど、ユーザー セキュリティ識別子 (SID) が変更される可能性がある複数のシナリオがあります。 ただし、ユーザー プロファイルは変更されておらず、古い SID を持つデータ ファイルは古いプロファイルにキャッシュされるようになりました。 この場合、このエラーが発生する Office 接続の問題または認証ループが発生する可能性があります。

解決方法

この問題を解決するには、次の手順を実行します。

  1. 次の場所にある Accounts フォルダーからすべてのファイルを削除します。

    %LOCALAPPDATA%\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\AC\TokenBroker\Accounts

    注:

    [Windows 検索] ボックスに上記の場所をコピーして貼り付けて、フォルダーを見つけます。

  2. Outlook プロファイルを再起動して再作成します。