システム ファイル チェッカー (SFC) が、PowerShell モジュール ファイルWindows Defender破損として正しくフラグを設定しない

この記事では、システム ファイル チェッカーが PowerShell モジュール ファイルWindows Defender誤って破損としてフラグを設定する問題について説明します。

適用対象: Windows クライアント
元の KB 番号: 4513240

現象

システム ファイル チェッカー (SFC) ツールは、 %windir%\System32\WindowsPowerShell\v1.0\Modules\Defender フォルダーにあるファイルに、破損または破損としてフラグを設定します。 この問題が発生すると、次のようなエラー エントリが表示されます。

ファイル メンバーのハッシュが一致しません。

原因

これは、Windows 10、バージョン 1607 以降のバージョン、およびバージョン 4.18.1906.3 以降のバージョン 4.8.1908 以降のWindows Defender既知の問題です。

%windir%\System32\WindowsPowerShell\v1.0\Modules\Defender にある Windows Defender PowerShell モジュールのファイルは、Windows イメージの一部として出荷されます。 これらのファイルはカタログ署名されています。 ただし、Windows Defenderの管理容易性コンポーネントには、新しい帯域外 (OOB) 更新チャネルがあります。 このチャネルは、元のファイルを、Windows オペレーティング システムが信頼する Microsoft 証明書を使用して署名された更新されたバージョンに置き換えます。 この変更により、SFC は更新されたファイルに "ファイル メンバーのハッシュが一致しません" としてフラグを設定します。

Windows の今後のリリースでは、Windows イメージ内の更新されたファイルが使用されます。 この変更が実装されると、SFC はファイルにフラグを設定しなくなります。

解決方法

この問題は、バージョン 4.8.1908 更新プログラムのWindows Defenderで修正されています。 この更新プログラムが適用されると、Windows イメージの一部である PowerShell ファイルは変更されず、SFC ツールによってこれらのファイルにフラグが設定されなくなります。 Windows Update チャネルをサブスクライブするインターネットに接続されたコンピューターは、この更新プログラムを自動的にダウンロードしてインストールします。

この問題の影響を受けたコンピューター上の Windows イメージ ファイルを修復するには、DISM ツールを使用します。 これを行うには、影響を受けるコンピューターでコマンド プロンプト ウィンドウを開き、次のコマンドを実行します。

dism /online /cleanup-image /restorehealth
sfc /scannow

これらのコマンドが失敗し、"ファイルが見つかりません" のようなエラー メッセージが生成された場合は、Install.wim ファイルにアクセスできることを確認してから、次のコマンドを実行します。

DISM /Online /Cleanup-Image /RestoreHealth /Source:WIM:c:\install.wim:1 /LimitAccess
sfc /scannow

修復コマンドの詳細については、「 Windows イメージを修復する」を参照してください。

データ収集

Microsoft サポートの支援が必要な場合は、「展開関連の問題について TSS を使用して情報を収集する」に記載している手順に従って情報を収集することをお勧めします。