別のデバイスが切断された後、アプリケーションが新しいスキャン デバイスを検出しない

適用対象: Windows 10Windows 8.1

現象


次のような状況で問題が発生します。

  1. Web Services on Devices (WSD) スキャン デバイスを Windows ベースのコンピューターに接続します。
  2. WSD スキャナーを切断します。
  3. USB スキャナーなどの異なるスキャン デバイスをコンピューターに接続します。
  4. 新しいスキャナーを使用するアプリケーションを起動します。

このシナリオでは、アプリケーションが正しく動作しない場合があります。 たとえば、アプリケーションが新しいスキャナーを検出しない場合があります。

この問題が発生すると、スキャナー ドライバーが IStiDevice::LockDevice メソッドを呼び出すときに、WIA_ERROR_OFFLINE エラーが発生する可能性があります。

原因


この問題は、サービスが WSD スキャナーを初期化するときに「Windows Image Acquisition (WIA)」サービスでエラーが発生した場合に発生します。 初期化プロセスがエラーなしで成功した場合、この問題は発生しません。

回避策


この問題を回避するには、次のいずれかの方法を試してください。

  • 接続されているスキャナー デバイスを (たとえば、デバイス マネージャーを使用して) アンインストールし、スキャナーを再接続します。
  • 「Windows Image Acquisition (WIA)」サービスを停止し、再開します。
  • スキャナーが接続されている間にコンピューターを再起動します。

詳細


WIA スキャナー アプリケーションまたはドライバーで発生する可能性のあるエラーの詳細については、エラー コードを参照してください。

状態


マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。