ルーティングとリモート アクセス インターフェイスを再追加した後、既定のゲートウェイ ルートがルーティング テーブルに表示されない

この記事では、既定のゲートウェイ ルートがルーティング テーブルに表示されない問題の解決策について説明します。

適用対象: Windows Server - すべてのエディション
元の KB 番号: 816905

現象

ルーティングおよびリモート アクセス ユーティリティでリモート アクセス サーバーにネットワーク インターフェイスを追加すると、そのインターフェイスの既定のルートがルーティング テーブルに表示されないことがあります。

原因

この問題は、次の両方の条件に該当する場合に発生する可能性があります。

  • リモート アクセス サーバーからネットワーク インターフェイスを削除します。
  • そのネットワーク インターフェイスをリモート アクセス サーバーに再追加します。

この問題を回避するには、以下のいずれかの方法を使用します。

回避策 1: インターフェイスの既定のルートを手動で追加する

Route Add コマンドを使用して、追加したネットワーク インターフェイスの既定のルートを手動で追加します。

  1. [スタート] をクリックし、[実行] をクリックし、[開く] ボックスに「cmd」と入力し、[OK] をクリックします

  2. 「route print」と入力し、Enter キーを押してルーティング テーブルを表示します。 再追加したネットワーク インターフェイスのインターフェイス番号をメモします。

  3. 次のコマンドを入力し、Enter route add 0.0.0.0 mask 0.0.0.0 ゲートウェイ IP メトリック 30 (インターフェイス番号の場合) を押します
    ここで、 ゲートウェイ IP はこのインターフェイスの既定のゲートウェイの IP アドレスで、 インターフェイス番号 は追加したネットワーク インターフェイスに対応する番号です (例: 2)。 たとえば、既定のゲートウェイ IP アドレスが 192.168.1.1 で、インターフェイス番号が 2 の場合は、次のコマンドを入力して Enter キーを押します。

    route add 0.0.0.0 mask 0.0.0.0 192.168.1.1 metric 30 if 2
    
  4. ルーティング テーブルに新しい既定のルートが表示されることを確認するには、「route print」と入力します。

  5. コマンド プロンプトを閉じます。

回避策 2: リモート アクセス サービスを再起動する

リモート アクセス サービスを再起動します。 再追加されたネットワーク インターフェイスの既定のルートが Windows ルーティング テーブルに追加されます。

  1. ルーティングとリモート アクセス ユーティリティを起動します。
  2. [ ルーティングとリモート アクセス] で、ネットワーク インターフェイスを再追加したサーバーを右クリックし、[ すべてのタスク] をポイントし、[ 再起動] をクリックします。

回避策 3: サーバーを再起動する

リモート アクセス サーバーを再起動します。 再追加されたネットワーク インターフェイスの既定のルートが Windows ルーティング テーブルに追加されます。