Microsoft Dynamics GP の総勘定元帳で期末処理を実行しようとするとエラー: 利益勘定が見つかりません

この記事では、Microsoft Dynamics GP の General Ledger で年末終了プロセスを実行するときに発生するエラーの解決策について説明します。

適用対象: Microsoft Dynamics GP
元の KB 番号: 850741

現象

Microsoft Dynamics GP で総勘定元帳で年末の終了プロセスを実行しようとすると、次のエラー メッセージが表示されます。

利益剰余金勘定が見つかりません。

利益剰余金勘定が見つかりませんでした。

原因

この問題は、[総勘定元帳の設定] ウィンドウで [部門別勘定セグメントに閉じる] チェックボックスをクリックすると発生します。

さらに、次のいずれかの原因により、エラー メッセージが発生する可能性があります。

原因 1

設定されている利益留保勘定は 1 つだけです。 ただし、[総勘定元帳の設定] ウィンドウで[分割勘定セグメントチェックに近い] ボックスが選択されています。 「解決策 1」を参照してください。

原因 2

利益剰余金勘定は、近い共通セグメントなしで設定されます。 「解決策 2」を参照してください。

原因 3

[区分勘定セグメントに近い] チェック ボックスが選択されています。 ただし、利益剰余金勘定はセグメント部門ごとに設定されません。 「解決策 3」を参照してください。

原因 4

利益剰余金勘定には空白スペースがあります。 「解決策 4」を参照してください。

原因 5

GL00105アカウント インデックス テーブルにレコードが破損しています。 「解決策 5」を参照してください。

原因 6

除算 RE アカウントに対して決算を使用する場合は、単体アカウントを探しています。 「解決策 6」を参照してください。

解決方法

これらの解決策を実行する前に、他のすべてのユーザーが Microsoft Dynamics GP または Microsoft Business Solutions - Great Plains からログアウトしていることを確認してください。 また、会社のデータベースの復元可能なバックアップを作成してください。

解決方法 1

この問題を解決するには、[総勘定元帳の設定] ウィンドウの [分割勘定セグメントチェックに近い] ボックスをオフにします。 これを行うには、次の手順を実行します。

  1. [総勘定元帳のセットアップ] ウィンドウを開き、[ Microsoft Dynamics GP ] メニューの [ツール] をクリックし、[ セットアップ] をポイントし、[ 財務] をポイントして、[ 総勘定元帳] をクリックします。
  2. [総勘定元帳の設定] ウィンドウで、[分割勘定セグメントに閉じる] チェックボックスをオフにします。
  3. [OK] をクリックして変更を保存します。

解決方法 2

この問題を解決するには、異なる利益保持勘定番号のセグメントが 1 つだけに近くなります。 アカウント番号の複数のセグメントに近づけることはできません。

この例では、次の利益保持勘定番号が存在します。

  • A-000-3030-00
  • B-100-3030-00
  • C-200-3030-00

この例では、勘定番号の 2 番目のセグメントを使用して終了することはできません。 2 番目のセグメントは 000、100、および 200 です。 閉じるセグメントを決定した後、残りのセグメントは同じである必要があります。 したがって、この例では、次のオプションがあります。

  • 2 番目のセグメントを使用して終了する場合は、最初のセグメント (文字) を変更して、すべてのアカウントで同じになるようにする必要があります。 たとえば、2 番目のセグメントを使用して終了し、部門利益剰余金を使用して終了するには、最初のセグメントを次のように変更します。
    • A-000-3030-00
    • A-100-3030-00
    • A-200-3030-00
  • 最初のセグメントを使用して終了する場合は、すべてのアカウントで同じになるように 2 番目のセグメントを変更する必要があります。 次のいずれかのオプションを使用して、2 番目のセグメントを変更できます。
    • A-000-3030-00, B-000-3030-00, C-000-3030-00
    • A-100-3030-00、B-100-3030-00、C-100-3030-00
    • A-200-3030-00、B-200-3030-00、C-200-3030-00

解決策 3

セグメント部門に対して作成された利益保持勘定がないことを確認します。 これを行うには、次の手順を実行します。

  1. [アカウント セグメントのセットアップ] ウィンドウを開き、Microsoft Dynamics GP メニューの [ツール] をクリックし、[セットアップ] をポイントし、[財務] をポイントして、[セグメント] をクリックします。

  2. [ セグメント ] フィールドの横にある参照ボタンをクリックし、[ 総勘定元帳の設定 ] ウィンドウで割り当てられている勘定セグメントをメモします。

  3. [数値] フィールドの横にある参照ボタンを使用します。

  4. セグメント参照ボタンを使用して表示できるセグメント番号をメモします。

  5. [アカウントのメンテナンス] ウィンドウを開きます。 これを行うには、[ カード] をクリックし、[ 財務] をポイントし、[ アカウント] をクリックします。

  6. 手順 4 でメモしたすべてのセグメントに、対応する利益保持勘定が設定されていることを確認します。

    例:

    次の条件が当てはまります。

    • 利益剰余金勘定番号は 000-3030-00 です。
    • 勘定番号の最初のセグメントは、分割勘定セグメントとして設定されます。
    • 最初のセグメントには、000、100、200、300、400 という番号が設定されていることにご説明しました。

    この例では、次の利益保持勘定番号も設定されていることを確認する必要があります。

    • 100-3030-00
    • 200-3030-00
    • 300-3030-00
    • 400-3030-00
  7. すべてのセグメントが設定されていない場合は、[ アカウントメンテナンス ] ウィンドウで設定します。 これを行うには、[ カード] をクリックし、[ 財務] をポイントし、[ アカウント] をクリックします。

解決策 4

この問題を解決するには、利益保持勘定番号に空白文字が含まれているかどうかを判断します。 これを行うには、次の手順を実行します。

  1. [アカウントのメンテナンス] ウィンドウを開きます。 これを行うには、[ カード] をクリックし、[ 財務] をポイントし、[ アカウント] をクリックします。

  2. 利益剰余金勘定の 1 つを選択し、アカウント番号を調べて、スペースがないことを確認します。

    例:

    • 利益剰余金勘定番号は 000-3030-00 です。
    • 勘定番号の最初のセグメントは、分割勘定セグメントとして設定されます。
    • 最初のセグメントには、000、100、200、300、400 という番号が設定されていることにご説明しました。

    この例では、次の利益保持勘定番号も設定されていることを確認する必要があります。

    • 100-3030-10
    • 200-3030-20
    • 300-3030-30
    • 400-3030-40

    ただし、最初のセグメントのセグメント長を意図せずに 4 文字に増やした可能性があり、Microsoft Dynamics GP は、最初に作成した利益保持アカウントを認識しません。 最初のセグメントを増やすと、アカウント番号は次のようになります。

    • 100X-3030-10
    • 200X-3030-20
    • 300X-3030-30
    • 400X-3030-40

    注:

    これらの数値では、X は空白を表します。

    アカウント番号にスペースがある場合は、次の手順に進みます。

  3. [調整] ウィンドウを開きます。 これを行うには、 Microsoft Dynamics GP メニューの [ツール] をクリックし、[ ユーティリティ] をポイントし、[ システム] をポイントして、[ 調整] をクリックします。

    注:

    [リコンサイル] コマンドは、アカウント セグメントの形式を元のセグメント長に戻します。 調整は、スペースを除く 4 文字の実際の最初のセグメント長を持つアカウントがない場合にのみ機能します。 つまり、例のように 1000 のような最初のセグメントを持つアカウントはありません。1000-1100-00。 この場合、セグメントの長さは 3 文字に戻ります。

  4. [ アカウント形式のセットアップ] を選択し、[ 挿入] をクリックします。

  5. [ 調整] をクリックし、エラー ログを画面に出力します。

    注:

    アカウント インデックス マスター (GL00105) テーブルには、アカウントの長さが 4 文字のアカウントが含まれている可能性があります。 そのため、SQL メンテナンスを使用してテーブルを再構築する必要があります。

  6. [SQL メンテナンス] ウィンドウを開きます。 これを行うには、 Microsoft Dynamics GP メニューの [ メンテナンス] をポイントし、[ SQL] をクリックします。

  7. 会社のデータベースを選択し、[製品] で [Microsoft Dynamics GP] を選択します。

  8. [ 財務系列] の [勘定インデックス マスター] テーブルを選択します。

  9. クリックしてすべてのチェックボックスを選択し、[プロセス] をクリックします。

    注:

    GL00105 テーブルが再作成されたら、リンクの確認を使用してデータを復元する必要があります。

  10. [リンクの確認] ウィンドウを開きます。 これを行うには、 Microsoft Dynamics GP メニューの [ メンテナンス] をポイントし、[リンクの 確認] をクリックします。

  11. 系列として [財務] を選択し、アカウント マスター論理テーブルを挿入します。

  12. [ OK] を クリックしてプロセスを開始します。

    注:

    アカウント マスター (GL00100) テーブルにある情報が、GL00105 テーブルに設定されます。

解決策 5

  1. SQL Server Management Studio を開きます。

  2. クエリ ウィンドウで、会社のデータベースに対して次のスクリプトを実行します。

    Delete GL00105
    
  3. Microsoft Dynamics GP を開きます。 [Microsoft Dynamics GP] メニューの [メンテナンス] をポイントし、[リンクの確認] をクリックします。

  4. [ 財務系列] を選択します。

  5. [ 論理テーブル ] の一覧で、[ アカウント マスター] をクリックして選択します。 [ 挿入] をクリックします。

  6. 次に、[OK] をクリックしてチェックリンクを実行します。 エラー ログを画面に出力します。

  7. もう一度テストします。

解決策 6

"ユニット アカウント" を正常に閉じることができるように、空白のセグメントを持つ追加の部門 RE アカウントを設定する必要がある場合があります。 (部門 RE アカウントの外観と、閉じているセグメントと比較して、ユニット アカウントの構造を表示します)。RE プロセス中にシステムがユニット アカウントを確認しないようにするために、品質の問題がログに記録されています。