FIX: You receive an "An exception occurred" error message when you use a .NET class in the Business Rule Composer

Symptoms

In Microsoft BizTalk Server 2004, when you test a policy that calls a method in a .NET class in the Business Rule Composer or in BizTalk Orchestration Designer, you may receive an error message that is similar to the following error message:
An exception occurred when invoking class member
MyNamespace.MyClass.MyMethod in assembly MyNamespace, Version=1.0.0.0, Culture=neutral, PublicKeyToken=060d33ae94d9c706. Object type cannot be converted to target type

Cause

This problem occurs when the method that you are calling contains a parameter that is an enumeration.

The following is an example of an Add method of a .NET class that produces this error message when the method is called from inside the Business Rule Composer or from inside the BizTalk Orchestration Designer.
using System;
using System.Collections;
using System.IO;
using System.Xml;
using Microsoft.RuleEngine;
namespace MyNamespace
{
/// <summary>
/// Summary description for MyClass.
/// </summary>
[Serializable]
public class MyClass
{
public enum MyEnum
{
first,
second
};
ArrayList myAL;

public MyClass()
{
myAL = new ArrayList();
}

public int Add(string myString, MyEnum myEnum)
{
myAL.Add(myString);
return 1;
}

public int Add(string myString)
{
myAL.Add(myString);
return 1;
}
}
.....
}

Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft BizTalk Server 2004. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
888751 How to obtain the latest BizTalk Server 2004 service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date Time Version Size File name
--------------------------------------------------------------
17-Sep-2004 16:46 3.0.5343.0 708,608 Microsoft.ruleengine.dll

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was corrected in BizTalk Server 2004 Service Pack 1.

More Information

For more information about developing business rules in BizTalk Server 2004, visit the following Microsoft Developer Network (MSDN) Web site: For additional information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

プロパティ

文書番号:885448 - 最終更新日: 2008/06/04 - リビジョン: 1

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