新しい Windows Vista または Windows 7 ベースのクライアント コンピューターをネットワークに追加しても、KMS の現在の数は増加しません

この記事では、新しい Windows Vista ベースのクライアント コンピューターをネットワークに追加するときに、Key Management Server (KMS) コンピューター内のクライアントの数が増えない問題を解決するためのヘルプを提供します。

適用対象: Windows 7 Service Pack 1
元の KB 番号: 929829

現象

キー管理サーバー (KMS) コンピューターで Slmgr.vbs スクリプトを実行すると、新しい Windows ベースのクライアント コンピューターをネットワークに追加するときに、クライアント コンピューターの数が増えないことを確認します。 さらに、ネットワークに追加する新しい Windows ベースのクライアント コンピューターごとに、Key Management Service イベント ログに次のイベントが表示される場合があります。

引数と共に Slmgr.vbs スクリプトを -dli 実行しても、クライアント コンピューターのカウント情報は期待どおりに増加しません。 Key Management Service イベント ログに記録される次のイベントでは、現在の数は変わりません。

原因

この問題は、ネットワークに追加する Windows ベースのクライアント コンピューターに同じ KMS クライアント マシン ID (SSD) がある場合に発生する可能性があります。 クライアント コンピューターの ID が異なる場合、KMS コンピューターでは現在のカウント数が増えます。 次のいずれかのシナリオでは、2 台以上のコンピューターで同じ ID を使用できます。

  • /generalize オプションと共にシステム準備ツール (Sysprep.exe) を実行しない場合でも、クライアント コンピューターのインストールに使用するカスタム Windows イメージが生成されます。
  • カスタム Windows イメージは、/generalize オプションと共に生成されます。 ただし、Unattended.xml ファイルで SkipRearm> 設定を指定<します。

クライアント コンピューターに同じ ID があることを確認するには、次の手順に従います。

  1. Windows ベースのクライアント コンピューターの 1 つで、[ スタート] をクリックし、[ プログラム] をポイントし、[ アクセサリ] をポイントし、[ コマンド プロンプト ] を右クリックし、[ 管理者として実行] をクリックします。 管理者のパスワードを要求するダイアログ ボックスが表示された場合はパスワードを入力して [OK] をクリックし、確認を要求するダイアログ ボックスが表示された場合は [許可] をクリックします。

  2. コマンド プロンプトで、次のコマンドを入力し、Enter キーを押します。 cscript c:\windows\system32\slmgr.vbs -dli

  3. 次の結果を確認し、CMID を書き留めます。

  4. 2 台目の Windows ベースのクライアント コンピューターで手順 1 ~ 4 を繰り返します。 2 番目のクライアント コンピューターの CMID が、最初のコンピューターの CMID と同じであることを確認します。

解決方法

影響を受けるコンピューターが同一の GUID を持っているかどうかを判断したらすぐに、展開に使用される基本イメージを再構築することをお勧めします。

回避策

この回避策は、Windows ベースのクライアントのインストールに使用されたイメージで /generalize オプションが使用された場合にのみ有効です。 このオプションは、複数のイメージをデプロイする場合に必要です。 イメージで /generalize オプションが使用されたかどうかを判断するには、次の手順に従います。

  1. 影響を受けるコンピューターの 1 つで、[ スタート] をクリックし、「C:\Windows\System32\sysprep\Panther\setupact.log」と入力します。

  2. 次のサンプル ログ ファイルに示すように、"SYSPRP ParseCommands: Found" 行を調べます。

    情報 [0x0f004e] SYSPRP 初期化 SysPrep ログ (C:\Windows\System32\sysprep\Panther)

    情報 [0x0f0054] SYSPRP ValidateUser:ユーザーは sysprep マシンに必要な特権を持っています
    情報 [0x0f0056] SYSPRP ValidateVersion:OS バージョンは問題ありません
    情報 [0x0f005c] SYSPRP ScreenSaver:sysprep のスクリーン セーバーが正常に無効になりました
    情報 [0x0f007e] SYSPRP FCreateTagFile:Tag ファイル C:\Windows\System32\sysprep\Sysprep_succeeded.tag がまだ存在せず、何も削除する必要はありません
    情報 [0x0f005f] SYSPRP ParseCommands:サポートされているコマンド ライン オプション 'UNATTEND' が見つかりました
    情報 [0x0f005f] SYSPRP ParseCommands:サポートされているコマンド ライン オプション 'OOBE' が見つかりました
    情報 [0x0f005f] SYSPRP ParseCommands:サポートされているコマンド ライン オプション 'SHUTDOWN' が見つかりました
    情報 [0x0f005f] SYSPRP ParseCommands:サポートされているコマンド ライン オプション 'GENERALIZE' が見つかりました

  3. /generalize オプションが存在する場合は、基本イメージを作成したコンピューターでこのオプションが使用されたことを確認します。

  4. /generalize オプションが使用されていて、同じ CMID を持つコンピューターがある場合は、次の手順に従って、影響を受けるコンピューターを再ビルドし、基本イメージを再構築します。 SkipRearm> 設定が使用されていないことを<確認します。

    1. Windows ベースのクライアント コンピューターの 1 つで、[ スタート] をクリックし、[ プログラム] をポイントし、[ アクセサリ] をポイントし、[ コマンド プロンプト] を右クリックして、[ 管理者として実行] をクリックします。

      管理者パスワードの入力または確認を求められたら、パスワードを入力するか、[ 許可] をクリックします。

    2. コマンド プロンプトで、次のコマンドを入力し、Enter キーを押します。 cscript c:\windows\system32\slmgr.vbs -rearm

    3. コンピューターを再起動します。

/generalize オプションを指定して Sysprep を使用して基本イメージが生成されなかった場合は、基本イメージを再構築してから、クライアントに Windows を再インストールする必要があります。 基本イメージをリビルドするときに Unattended.xml ファイルを使用する場合は、SkipRearm> 設定が使用されていないことを<確認します。 SkipRearm> 設定の<詳細については、Windows 自動インストール キット (Windows AIK) のドキュメントを参照してください。

詳細

アクティブ化タイマーをリセットし、一意の CMID を設定するには、リアーム プロセスを対象のコンピューターで実行する必要があります。 このプロセスは、アクティブ化状態をリセットするために使用されます。 Windows では、次の 2 つの方法のいずれかを使用して、リアーム プロセスを実行できます。

  • カスタム Windows イメージのビルドに使用するコンピューターで、Sysprep を /generalize オプションと共に実行します。
  • 管理者特権のコマンド プロンプト ウィンドウで Slmgr.vbs スクリプトを実行して、リアーム プロセスを強制的に実行します。 たとえば、次のように入力します。 cscript c:\windows\system32\slmgr.vbs -rearm

Sysprep が /generalize オプションと共に実行されたか、または Unattended.xml ファイルで SkipRearm>1</SkipRearm> 設定を使用<したために、Rearm プロセスが実行されなかった場合、クライアント コンピューターに同じ CMID が含まれている可能性があります。 したがって、コンピューター数の情報は予想どおりに増加しません。 /generalize オプションは、複数のイメージをデプロイするときに必要です。 <運用環境にコンピューターを展開する場合は、SkipRearm> 設定を無人ファイルで使用しないでください。 そのため、どちらの場合も、基本イメージを再構築することをお勧めします。

データ収集

Microsoft サポートの支援が必要な場合は、「展開関連の問題について TSS を使用して情報を収集する」に記載している手順に従って情報を収集することをお勧めします。