Microsoft Dynamics CRM 3.0 を実行しているクライアント コンピューターに修正プログラムまたは更新プログラムをインストールしようとするときにエラー メッセージ:「Windows XP を更新する権限がありません」


現象


クライアント コンピューターに修正プログラムまたは更新プログラムをインストールしようとすると、Microsoft Dynamics CRM 3.0 では、修正プログラムを実行しているか、更新プログラムがインストールされていません。さらに、次のエラー メッセージが表示されます。
Windows XP を更新する権限がありません。システム管理者に問い合わせてください。

原因


この問題が発生するのは、次の条件のいずれかに該当する場合です。
  • ログオンしていないクライアント コンピューターにローカル管理者のアクセス許可を持つユーザーとしてします。
  • クライアント コンピューターにグループ ポリシーが適用されるドメインは、修正プログラムまたは更新プログラムをインストールするのにはドメイン ユーザーの制限がありすぎます。

解決策


手動でこの問題を解決するには、以下の手順を実行します。
  1. 修正プログラムまたは更新プログラムをインストールしようとしたユーザーがローカル管理者のアクセス許可を持っていることを確認します。これを行うには、以下の手順を実行します。
    1. [スタート] ボタンを実行[名前] ボックスにファイル名を指定を入力、し、[ OK] をクリックします。
    2. システム ツールを展開します。
    3. ローカル ユーザーとグループを展開します。
    4. [グループ] をクリックします。
    5. 管理者を右クリックし、[プロパティ] をクリックします。
    6. ユーザーが Administrators グループのメンバーであることを確認し、[ OK] をクリックします。


      注: ユーザーが Administrators グループのメンバーでない場合は、Microsoft Dynamics CRM ユーザーをログオフして、Administrators グループのメンバーであるユーザーとしてログオンします。管理者のアクセス許可を持つユーザーとしてログオンしている後は、ローカルの Administrators グループに Microsoft Dynamics CRM ユーザーを追加します。
  2. ドメイン グループ ポリシーが修正プログラムまたは更新プログラムをインストールするのには制限が多すぎていないことを確認します。これを行うには、以下の手順を実行します。
    1. [スタート] ボタンすべてのプログラム] をポイントし、 [管理ツール] をポイントし、し、[ Active Directory ユーザーとコンピューター] をクリックします。
    2. ドメインを右クリックし、[プロパティ] をクリックします。
    3. グループ ポリシー ] タブをクリックします。
    4. 既定のドメイン ポリシーをクリックし、[編集] をクリックします。
    5. コンピューターの構成を展開します。
    6. Windows の設定を展開します。
    7. セキュリティ設定を展開します。
    8. ローカル ポリシーを展開します。
    9. ユーザー権利の割り当てをダブルクリックします。
    10. 次のポリシーを見つけて、ポリシーごとに、 Administratorsグループを追加します。
      • バックアップ ファイルとディレクトリ
      • ファイルとディレクトリを復元します。
      • 監査とセキュリティ ログを管理します。
      • ファイルまたはその他のオブジェクトの所有権を取得します。
      • プログラムをデバッグします。
    11. [グループ ポリシー ] ダイアログ ボックスと、[ Active Directory ユーザーとコンピューター ] ダイアログ ボックスを閉じます。
  3. [スタート] ボタン、[実行] をクリックして、 [名前] ボックスにcmdと入力し、し、[ OK] をクリックします。
  4. コマンド プロンプトでは、次のコマンドを入力し、コマンドごとに ENTER キーを押します。
    gpupdate /force

    exit
  5. コンピューターの再起動を求めるメッセージが表示されたら、[はい] をクリックします。