TCP Chimney 機能を持つ Windows Server 2003 ベースのコンピューターが予期せず再起動を有効に:"Stop 0x000000D1"

適用対象: Microsoft Windows Server 2003 Datacenter Edition (32-bit x86)Microsoft Windows Server 2003 Datacenter Edition for Itanium-Based SystemsMicrosoft Windows Server 2003 Datacenter x64 Edition

これが適切な修正かどうかわからないことがあります。この問題を確認できるメモリ ダンプの診断を追加しました。

エラー メッセージの説明


TCP Chimney 機能が有効になっている Windows Server 2003 ベースのコンピューターが予期せず再起動します。、それを再起動した後、次の Stop エラー メッセージを受信しました。
Stop 0x000000D1 (パラメーター 1パラメーター 2パラメーター 3 ,パラメーター 4 )
DRIVER_IRQL_NOT_LESS_OR_EQUAL
注:
  • この停止エラー メッセージ内のパラメーターは、コンピューターの構成によって異なります。
  • すべての"0x000000D1"Stop エラー メッセージは、この問題が原因です。

原因


この問題は、TCP/IP モジュールでタイミングの問題が原因で発生します。このタイミングの問題は、 IPInitiateOffloadComplete関数とIPDelayedInvalidateWorker関数の間で競合状態が原因で発生します。

解決策


修正プログラムは、この問題を解決するのには使用できます。

修正プログラムの情報

サポートされている修正プログラムは、マイクロソフトから入手可能です。ただし、この修正プログラムは、ここで説明する問題のみを修正することを目的としたものです。この問題が発生しているシステムにのみ適用してください。この修正プログラムは、今後さらにテストを行う場合があります。したがって、この問題の影響が深刻でない場合は、この修正プログラムが含まれる次のソフトウェア更新プログラムがリリースされるまで待つことをお勧めします。

修正プログラムをダウンロードできる場合は、このサポート技術情報の資料の上部に「修正プログラムのダウンロード」セクションがあります。このセクションが表示されていない場合は、マイクロソフト カスタマー サービス サポートにお問い合わせのうえ、修正プログラムを入手してください。

注: さらなる問題が発生した場合、またはトラブルシューティングが必要な場合には、別のサービス リクエストの作成が必要な場合があります。この修正プログラムの対象外の追加の質問および問題については、通常のサポート料金が適用されます。一覧マイクロソフト カスタマー サービス & サポートの電話番号または別のサービス リクエストを作成する、次のマイクロソフト Web サイトを参照してください。注: [修正プログラムのダウンロード] フォームには、修正プログラムが提供されている言語が表示されます。お使いの言語が表示されない場合は、その言語の修正プログラムが利用できないためです。

必要条件

この修正プログラムを適用するにはインストールされている次のサービス パックのいずれかのコンピューター必要があります。
  • Windows Server 2003 Service Pack 1
  • Windows Server 2003 Service Pack 2

再起動の必要性

この修正プログラムを適用した後、コンピューターを再起動する必要があります。

修正プログラムの置き換えに関する情報


この修正プログラムを適用しても、他の修正プログラムが置き換えられることはありません。

レジストリ情報


この修正プログラムを使用するために、レジストリを変更する必要はありません。

ファイル情報

修正プログラム (英語版) のファイル属性は次表のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。各ファイルの日付および時刻は、世界協定時刻 (UTC) で示されています。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時刻との時差を確認するには、コントロール パネルの [日付と時刻] の [タイム ゾーン] タブを使用してください。
Windows Server 2003 SP 1 では、x86 ベースのバージョン
ファイル名ファイル バージョンファイル サイズ日付時刻プラットフォーム
Tcpip.sys5.2.3790.3097393,72803-Mar-200811:07x86
SP 2 で x86 ベースのバージョンの Windows Server 2003
ファイル名ファイル バージョンファイル サイズ日付時刻プラットフォーム
Tcpip.sys5.2.3790.4245390,14403-Mar-200810:47x86
Windows Server 2003 SP1 では、Itanium ベースのバージョン
ファイル名ファイル バージョンファイル サイズ日付時刻プラットフォーム
Tcpip.sys5.2.3790.30971,305,60003-Mar-200811:49IA-64
Windows Server 2003 SP2 では、Itanium ベースのバージョン
ファイル名ファイル バージョンファイル サイズ日付時刻プラットフォーム
Tcpip.sys5.2.3790.42451,307,13603-Mar-200812:03IA-64
Windows Server 2003 と Windows XP では、x64 ベースのバージョン
ファイル名ファイル バージョンファイル サイズ日付時刻プラットフォーム
Tcpip.sys5.2.3790.3097826,88003-Mar-200811:48x64
Windows Server 2003 SP2 および Windows XP SP2 では、x64 ベースのバージョン
ファイル名ファイル バージョンファイル サイズ日付時刻プラットフォーム
Tcpip.sys5.2.3790.4245781,82403-Mar-200812:03x64

回避策


この問題を回避するには、TCP Chimney 機能を無効にします。

Netsh.exe ツールを使用して TCP Chimney 機能を無効にします。

TCP Chimney 機能を無効にするには、Netsh.exe ツールを使用、次の手順を実行します。
  1. [スタート] をクリックし、[ファイル名を指定して実行] をクリックして、 cmd と入力し、[OK] をクリックします。
  2. コマンド プロンプトでNetsh int ip chimney を無効に設定すると、入力し、し、ENTER キーを押します。

レジストリを使用して TCP Chimney 機能を無効にします。

重要 このセクション、方法、またはタスクには、レジストリの変更方法が記載されています。レジストリを誤って変更すると、深刻な問題が発生することがあります。そのため、レジストリを変更する際には十分に注意してください。万一に備えて、編集の前にレジストリをバックアップしてください。そうすることで、問題が発生した場合にレジストリを復元することができます。レジストリのバックアップ方法および復元方法の詳細を参照するには、以下のサポート技術情報番号をクリックしてください。
322756の方法をバックアップし、Windows のレジストリを復元するには

この問題を修正するには、「私の問題を修正」セクションに進んでください。自分がこの問題を解決するとはではなく場合、は、自分で自分で解決する」セクションに移動します。

Fix it で解決する

この問題を自動的に修正する] をクリックします
この問題を解決する] リンク。次に、
を実行します
ファイルのダウンロード] ダイアログ ボックス、および、このウィザードの手順に従います。





このウィザードは、英語版しかない可能性があります。ただし、この自動修正プログラムは、他言語バージョンの Windows でも動作します。

注: いない場合に、問題があるコンピューターで、問題のあるコンピューターで実行することができますように、フラッシュ ドライブまたは CD に自動修正を保存できます。


「この問題は解決しましたか?」セクションに進んでください。

自分で解決する

TCP Chimney 機能を無効に、レジストリを変更することによって、以下の手順を実行します。
  1. [スタート] ボタン、[実行] をクリックして、 Regeditと入力し、[ OK] をクリックします。
  2. 次のレジストリ サブキーを見つけます。
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
  3. EnableTCPChimneyレジストリ エントリをダブルクリックします。
  4. DWORD 値の編集] ダイアログ ボックスで、[値データ] ボックスに0を入力し、し、[ OK] をクリックします。
  5. EnableRSSレジストリ エントリをダブルクリックします。
  6. DWORD 値の編集] ダイアログ ボックスで、[値データ] ボックスに0を入力し、し、[ OK] をクリックします。
  7. EnableTCPAレジストリ エントリをダブルクリックします。
  8. DWORD 値の編集] ダイアログ ボックスで、[値データ] ボックスに0を入力し、し、[ OK] をクリックします。
  9. コンピューターを再起動します。

問題は解決しましたか?

問題が解決したかどうかを確認してください。問題を修正すると場合に、この資料でが完了したら。問題が解決しない場合は、サポートに問い合わせてください。

状況


マイクロソフトは、この問題を「対象製品」セクションに記載されているマイクロソフト製品の問題として認識しています。

詳細情報


詳細については、次の文書番号をクリックして、マイクロソフト サポート技術情報の資料をご参照ください。

824684マイクロソフトのソフトウェア更新プログラムを記述するために使用される一般的な用語説明

X64 ベース バージョンの Microsoft Windows のテクニカル サポート

ハードウェアが既にインストールされている、Microsoft Windows x64 エディションに付属している場合、ハードウェアの製造元は、テクニカル サポート、および Windows x64 エディションのサポートを提供します。この例では、ハードウェアの製造元は、Windows x64 エディションがハードウェアに搭載されているために、サポートを提供します。ハードウェアの製造元が、独自のコンポーネントを使用して Windows x64 エディションのインストールをカスタマイズしている可能性があります。独自のコンポーネントは、固有のデバイス ドライバーを含めることがあります。 またはハードウェアのパフォーマンスを最大化するためのオプションの設定を含めることがあります。Windows x64 エディションのテクニカル ヘルプが必要な場合、マイクロソフトは妥当な範囲のサポートを提供します。ただし、製造元に直接連絡する必要があります。製造元は、製造元がハードウェアにインストールするソフトウェアをサポートするために最も適しています。など、Windows Server 2003 の x64 エディションの Windows x64 エディションを別々 に購入した場合は、テクニカル サポートはマイクロソフトに問い合わせてください。

Windows XP Professional x64 Edition の製品については、次のマイクロソフト Web サイトを参照してください。X64 ベース バージョンの Windows Server 2003 の製品については、次のマイクロソフト Web サイトを参照してください。