失敗した SQL Server 2008 へのアップグレードのトラブルシューティング方法

現象

Microsoft SQL Server 2000 または Microsoft SQL Server 2005 を Microsoft SQL Server 2008 にアップグレードしようとすると、アップグレード操作が失敗します。 また、次のエラー メッセージが表示されることがあります。
このアクセス制御リストは標準の形式ではないため、変更できません。
アップグレードを再試行すると、[機能の選択] ページのすべてのオプションが使用できなくなります。 さらに、ステータス バーに以下のエラー メッセージが表示されます。
アップグレードする機能が選択されていません。

原因

この問題は、以前に SQL Server 2000 のインスタンスのアップグレードに失敗しており、アップグレード プロセスを再度実行しようとした場合に発生します。

解決方法

この問題を解決するには、概要ログ ファイルを調べ、Final result エントリに示されている対応を実行する必要があります。 これを行うには、以下の手順を実行します。
  1. 失敗したアップグレードの概要ログ ファイルを見つけます。 通常、概要ログ ファイルは次のフォルダにあります。
    %ProgramFiles%\Microsoft SQL Server\100\Setup Bootstrap\LOG\
    概要ログ ファイル名は次のような名前になります。
    Summary_Server_Name-Node1_Date_Time.txt
  2. 概要ログ ファイルを開き、Final result エントリを見つけます。 このエントリには、アップグレードを完了するために実行する必要がある対応が示されています。 たとえば、次のようなエントリが記録されることがあります。
    SQL Server のアップグレードに失敗しました。 続行するには、失敗の理由を調べて問題を修正し、次のコマンド ラインを使用して SQL Server をアンインストールしてから、SQL Server セットアップに戻ります。 アンインストールのコマンド ライン:

    setup /q /action=uninstall /instanceid=CLUSTER1 /features=SQLEngine,Replication,FullText
  3. 失敗の原因となった問題を調べて、解決します。 その後、残りの手順を実行します。
  4. コマンド プロンプトで、次のフォルダに移動します。
    %Program Files%\Microsoft SQL Server\100\Setup Bootstrap
  5. コマンド プロンプトで、手順 2. で Final result エントリにおいて特定したコマンドを入力し、Enter キーを押します。 たとえば、Final result エントリが手順 2. の例のようなエントリである場合、次のコマンドを入力して、Enter キーを押します。
    setup /q /action=uninstall /instanceid=CLUSTER1 /features=SQLEngine,Replication,FullText
  6. アンインストールの完了後、SQL Server 2008 へのアップグレードを再開します。

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

関連情報

SQL Server 2008 のログ ファイルの詳細については、次の MSDN (Microsoft Developer Network) Web サイトを参照してください。SQL Server 2008 の詳細については、次のマイクロソフト Web サイトを参照してください。
プロパティ

文書番号:955399 - 最終更新日: 2009/06/24 - リビジョン: 1

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