ボリューム シャドウ コピー サービス復元操作を実行するときにエラー メッセージ:"0x80042409"

現象

ボリューム シャドウ コピー サービス (VSS) バックアップまたは VSS 復元操作を実行するとします。バックアップまたは復元操作中に次のようなイベントがアプリケーション ログに書き込まれます。

原因

このエラーは、VSS ライターでバックアップまたはリストアのセッション状態が正しくクリーンアップされないために発生します。VSS ライターのインフラストラクチャでは、VSS ライターが参加しているバックアップと復元セッションごとにセッション状態オブジェクトを作成します。通常の状況では、ライターのセッション状態オブジェクト クリーンアップされます、使用されていないとき。通常セッション状態のクリーンアップは、次の状況で発生します。
  • バックアップ ・ アプリケーションでは、 BackupComplete応答を送信しのGatherWriterStatusを送信することにより、ライターのステータスをチェックします。
  • バックアップ ・ アプリケーションでは、 PostRestore応答を送信し、 GatherWriterStatusクエリを送信することにより、ライターのステータスをチェックします。
  • ライターは、セッションの OnAbort イベントのコールバックを受信します。 OnAbort イベントのコールバックは、バックアップ アプリケーション、ライターまたは、VSS インフラストラクチャによって、バックアップ ・ セッションが明示的に失敗したときに呼び出されます。
VSS ライターのインフラストラクチャでは、残りのセッション状態の定期的なガベージ コレクションを実行します。Infrustructure は、2 日を経過したセッション状態オブジェクトごとに、前のイベント ログを記録します。イベント ログは、可能性があるバックアップ アプリケーション、ライターで破棄されたセッションを識別するものです。一連の不完全なバックアップが存在したことを示すまたはリストア ・ セッションを複数のライターからの連続のようないくつかのイベントを表示できます。この現象は、テスト環境で最も頻繁に発生します。

回避策

このエラーの断続的な発生を無視します。バックアップによって開始された操作または復元操作のガベージ コレクション アクティビティへの応答に関連するイベントが記録されます。ただし、これらのエラーは、アクティブなバックアップに関連付けられていないか、セッションを復元します。エラーが一貫して再現可能な場合は、バックアップ アプリケーション ベンダーは、すべての VSS バックアップ セッション クリーンアップ ガイドライン次のことを確認します。
プロパティ

文書番号:978773 - 最終更新日: 2017/02/18 - リビジョン: 2

フィードバック