リモート アクセス セッションの作成時にコンピュータが応答を停止する

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現象
スクリプト (Compuserve PAL95 プログラムなど) を使用するリモート アクセス接続を作成するときに、Windows 95 または Windows 98 ベースのコンピュータが応答を停止 (ハング) することがあります。この現象は、コンピュータで NeoMagic ビデオ アダプタを使用している場合に発生することが報告されています。これらのアダプタは、アダプタで使用しているメモリの検査を許可していません。
原因
この問題は、リモート アクセス コンポーネントによりローカル変数が適切に初期化されなかった場合に発生する可能性があります。これにより、コンピュータがディスプレイ メモリ領域を含むメモリの大部分を読み取り、コンピュータがハングすることがあります。

状況
マイクロソフトでは、この問題をこの資料の冒頭に記載した製品の問題として認識しています。

この問題は Microsoft Windows 98 Second Edition で解決されています。
詳細
この問題は、ディスプレイ メモリの検査を許可しない NeoMagic ビデオ アダプタを使用するコンピュータで発生することが確認されています。

このエラーは、アプリケーションで RASENTRY 構造体に szScript を設定して、RasSetEntryProperties を呼び出す場合に発生します。

Windows 98 および Windows 98 Second Edition の修正プログラムの関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
206071 General Information About Windows 98 and Windows 98 Second Edition Hotfixes


Windows 95 の修正プログラムの関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
161020 Implementing Windows 95 Updates
161020 Windows 95 アップデートの実装
関連情報
この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。明示または黙示にかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。
関連情報
この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 194178 (最終更新日 2003-05-12) を基に作成したものです。

なお、この資料は英語版の翻訳であり、日本語環境での確認は行っておりません。
98 95 2.10 2.00 2.50
プロパティ

文書番号:194178 - 最終更新日: 01/07/2015 07:26:54 - リビジョン: 2.3

  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
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