現在オフラインです。再接続するためにインターネットの接続を待っています

Outlook のオートコンプリートの一覧についての情報

Office 2003 のサポートは終了しました

マイクロソフトでは、2014 年 4 月 8 日に Office 2003 のサポートを終了しました。この変更は、ソフトウェアの更新プログラムおよびセキュリティ オプションに影響しています。 この変更の意味および保護された状態を維持する方法について説明します。

重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。

英語版 KB:2199226
概要
この資料には、Microsoft Outlook のオートコンプリートの一覧 (Outlook のオートコンプリート リストとも呼ばれます) の概要が含まれています。機能を記述するだけでなくこの資料には、詳細と手順の一覧を管理する高度なユーザーが含まれています。
詳細
Outlook では、オートコンプリートの候補一覧を保持します。リストは、自動名前チェック機能と自動補完機能の両方で使用されます。Outlook から電子メール メッセージを送信するとき、オートコンプリートの一覧、ニックネームのキャッシュとも呼ばれますが自動的に生成します。一覧には、SMTP アドレス、LegacyExchangeDN エントリ、および人の相手が前に送信したメールの表示名が含まれています。

注: <b>Outlook のオートコンプリートの一覧を Outlook、Outlook Web App (OWA) では共有されていません。OWA では、独自のオートコンプリートの一覧を保持します。

次のセクションでは、オートコンプリート機能に関する情報を提供します。

エントリの数を制限します。

Outlook では、オートコンプリートの候補一覧に保存できるエントリの数を制限します。この制限に達すると、リストから削除するのには最適な名前を決定するのに内部アルゴリズムが使用されます。これは、使用法の重み付けに基づきます。したがって、いくつかの名前、ニックネームのキャッシュから予期せず削除される場合もあります。このような状況を避けるために使用できる 2 つの一般的な方法があります。
  1. 事前に不要になったオートコンプリート リストのエントリを削除できます。これは、推奨されるアプローチです。これを行う方法の詳細については、「オートコンプリート リスト エントリを 1 つを一度に削除する方法。」というタイトルのセクションを参照してください。
  2. ニックネームのキャッシュの最大数を増やすことができます。この構成はテスト済みなのでお勧めしません。ニックネーム キャッシュが大きい場合もできなくなりより多くのキャッシュされたエントリの破損が発生したため、ニックネームのキャッシュが使用できなくなった場合。制限値を大きく方法の詳細については、「オートコンプリートの候補一覧制限を変更する方法。」というタイトル セクションを参照してください。
制限は次のとおりです。
  • Outlook 2016: 1,000 のエントリ
  • Outlook 2013: 1,000 のエントリ
  • Outlook 2010: 1,000 のエントリ
  • Outlook 2007: 2,000 エントリ
  • Outlook 2003: 1,000 のエントリ

オートコンプリート機能を有効にする方法

このセクションでは、有効またはオートコンプリート機能を無効にする方法について説明します。
Outlook 2010、Outlook 2013、および Outlook 2016
オートコンプリートの設定にアクセスするには、次の手順を実行します。
  1. [ファイル] メニューの [オプション] をクリックします。
  2. [メール] タブを選択します。
  3. 約半分まで表示されるまでスクロールメッセージを送信するを参照してください。提案明細行を [宛先]、[cc]、および [bcc] に入力時に名前の自動補完リストを使用] ボックスがオンになっていることを確認します。

Outlook 2003 および Outlook 2007
オートコンプリートの設定にアクセスするには、次の手順を実行します。
  1. ツール] をクリックし、[オプション] をクリックします。
  2. クリックして、オプションを電子メールで送信 ボタン。
  3. メールの詳細オプション] ボタンをクリックします。
  4. 確認、を入力する、[cc]、および [bcc] の中に名前を提案するフィールドチェック ボックスをオンします。(スクリーン ショットのこの手順に従います。)画面は、この手順に進みます。

.Nk2 ファイルを Outlook 2010、Outlook 2013 年および 2016 を Outlook にインポートする方法

Microsoft Office Outlook 2007年と以前のバージョンは、ディスク上のニックネーム (.nk2) ファイルに、[オートコンプリート] ボックスの一覧を格納します。Outlook 2010、Outlook 2013、および Outlook 2016 は、プライマリ メッセージ ストア内の非表示のメッセージとして、[オートコンプリート] ボックスの一覧を格納します。Outlook 2010、Outlook 2013、および Outlook 2016 .nk2 ファイルをインポートできます。

Outlook 2010 では .nk2 ファイルをインポートする方法の詳細については、次のマイクロソフト web サイトを参照してください。
Outlook 2013 で Outlook 2016 .nk2 ファイルをインポートする方法については、マイクロソフト サポート技術情報の記事を表示するのには次の資料番号をクリックします。
2806550.Nk2 ファイルを Outlook 2013 または 2016 を Outlook にインポートする方法

TheAutoComplete のリストをコピーする方法

エクスポートし、[オートコンプリート] ボックスの一覧をインポートする手順は、使用している Outlook のバージョンによって異なります。
Outlook 2010、Outlook 2013、および Outlook 2016
Outlook 2010、Outlook 2013 年および 2016 の Outlook で、[オートコンプリート] ボックスの一覧をコピーするには、次の手順を実行します。

手順1

オートコンプリートのメールボックスのメッセージをエクスポートするのには以下の手順を実行します。
  1. Outlook を終了し、Outlook Web Access、または自分のメールボックスに接続されているすべてのワークステーションに Outlook Web App (OWA) を閉じます。
  2. ダウンロードし、インストールから MFCMAPI http://mfcmapi.codeplex.com.
  3. Mfcmapi.exe を実行します。
  4. [セッション] メニューの [ログオン] をクリックします。
  5. プロファイルのメッセージが表示されたら、目的のプロファイル名を選択]をクリックします。
  6. 上部のペインで自分のメールボックスに対応する行を見つけて、それをダブルクリックします。
  7. 左側のナビゲーション ウィンドウで、ルート コンテナーを展開し、インフォメーション ストアの最上部またはIPM_SUBTREEを展開します。
  8. 受信トレイ] フォルダーを右クリックし、関連付けられているコンテンツ テーブルを開く] をクリックします。このアクションでは、さまざまなプロパティが含まれる新しい MFCMAPI ウィンドウが開きます。
  9. [件名] 列では、件名IPM を持っている項目を右クリックします。Configuration.Autocomplete、し、メッセージのエクスポート] をクリックします。このアクションは、メッセージをファイルに保存] ウィンドウを開きます。
  10. ボックスの一覧でMSG ファイル (UNICODE)] を選択し、し、[ OK] をクリックします。
  11. メッセージを保存するフォルダーの場所を選択し、[保存] をクリックします。この場所に注意してください。
手順 2

オートコンプリートのメールボックスのメッセージをインポートするのには以下の手順を実行します。
  1. Outlook を終了し、Outlook Web Access、または自分のメールボックスに接続されているすべてのワークステーションに Outlook Web App (OWA) を閉じます。
  2. ダウンロードし、インストールから MFCMAPI http://mfcmapi.codeplex.com
  3. Mfcmapi.exe を実行します。
  4. [セッション] メニューの [ログオン] をクリックします。
  5. プロファイルのメッセージが表示されたら、目的のプロファイル名を選択]をクリックします。
  6. 上部のペインで自分のメールボックスに対応する行を見つけて、それをダブルクリックします。
  7. 左側のナビゲーション ウィンドウでは、ルート - メールボックスを展開し、展開上のインフォメーション ストアまたはIPM_SUBTREE
  8. 受信トレイ] フォルダーを右クリックし、関連付けられているコンテンツ テーブルを開く] をクリックします。このアクションでは、さまざまなプロパティが含まれる新しい MFCMAPI ウィンドウが開きます。
  9. 重複を避けるためには、オートコンプリート機能の既存のメッセージを削除する必要があります。

    注: <b>IPM のを削除する前にします。Configuration.Autocompleteメッセージでは、「オートコンプリートのキャッシュをエクスポートする方法」セクションの手順を使用してメッセージをエクスポートする必要があります。

    オートコンプリートの既存のメッセージを削除するには、以下の手順を実行します。

    1. [件名] 列で、件名の IPM のを持っている項目を探します。Configuration.Autocomplete
    2. アイテムを右クリックし、をクリックしてください メッセージを削除します。.アイテムの削除] ウィンドウが開きます。
    3. ボックスの一覧では、完全に削除 (サポートされている場合、削除済みアイテムの保存を削除)を選択し、し、[ OK] をクリックします。
  10. [フォルダー ] メニューで、インポート] をクリックしのメッセージ] をクリックします。
  11. 」方法に、オートコンプリートの一覧のエクスポート」のセクションの手順 11 で作成した .msg ファイルを見つけて、[ OK] をクリックします。
  12. ロード メッセージウィンドウが表示されたら、負荷のスタイル] ボックスの一覧で現在のフォルダーにメッセージの読み込みを選択し、[ OK] をクリックします。
オートコンプリートの情報は、メールボックスの IPM からインポートされます。Configuration.Autocomplete_<hexadecimal code=""></hexadecimal>.msg、場所、プレース ホルダー<hexadecimal code=""></hexadecimal>の数字と文字の長い文字列を表します。
Outlook 2003 および Outlook 2007
Outlook 2003 および Outlook 2007 で、[オートコンプリート] ボックスの一覧にコピーする手順は、異なります。これは、Outlook 2003 および Outlook 2007 は、.nk2 ファイルで、[オートコンプリート] ボックスの一覧を格納するためです。

Outlook 2003 で、[オートコンプリート] ボックスの一覧をコピーするには、次のマイクロソフト web サイトに移動します。
Outlook 2007 で、[オートコンプリート] ボックスの一覧をコピーするには、次のマイクロソフト web サイトに移動します。

オートコンプリート リスト エントリを 1 つを一度に削除する方法

オートコンプリート キャッシュの 1 つのエントリからエントリを削除するには、以下の手順をします。
  1. 新しい電子メール メッセージを開きます。
  2. 削除するオートコンプリート エントリの最初の数文字を入力します。
  3. ハイライトされますまでに、名の上にマウス ポインターを移動、名前をお勧めの一覧にエントリが表示されるときは、名前をクリックしてしません。
  4. 強調表示されている名前の横に"X"アイコンが表示されたら、一覧から名前を削除するのにはXをクリックするかキーボードのDelキーを押します。

オートコンプリート リスト全体を消去する方法

このセクションでは、オートコンプリートの候補一覧を削除する方法について説明します。
Outlook 2010、Outlook 2013、および Outlook 2016
Outlook 2010、Outlook 2013 年および 2016 の Outlook のオートコンプリートの一覧を削除するのにには、次の 2 つの方法のいずれかを使用します。

方法 1
  1. Outlook を開きます。
  2. [ファイル] タブの [オプション] をクリックします。
  3. [メール] タブをクリックします。
  4. [メッセージの送信空の自動補完リストをクリックします。


  5. [はい] をクリックします。

方法 2

/CleanAutoCompleteCache スイッチを使用して Outlook を起動します。これを行うには、次の手順を実行します。
  1. [スタート] をクリックし、[ファイル名を指定して実行] をクリックします。
  2. Outlook.exe の/CleanAutoCompleteCacheをタイプします。

    注: <b>Outlook が既定の場所にインストールされていない場合は、Outlook.exe のパスをポイントする必要があります。
Outlook 2003 および Outlook 2007
オートコンプリートの一覧で、Outlook 2003 および Outlook 2007 を削除するには、.nk2 ファイルを手動で削除する必要があります。.Nk2 ファイルを削除するには、次の手順を実行します。
  1. Outlook を終了します。
  2. 開始] をクリックし、[コンピューター] をクリックします。
  3. [整理] をクリックし、[フォルダーと検索のオプション] をクリックします。
  4. [表示] タブで、隠しファイル、フォルダー、およびドライブを表示する] をクリックします。
  5. [Ok]をクリックします。
  6. [スタート] ボタン、[すべてのプログラム] をクリックして、[アクセサリ]、[実行] をクリックします。
  7. 実行] ダイアログ ボックスで (引用符を含む)、次のコマンドを入力し、し、[OK] をクリックします。

    "C:\Users\ユーザー名\AppData\Roaming\Microsoft\Outlook」


    注: <b>このパスにユーザー名が現在ログインしているの名前を Windows ユーザーにします。
  8. を右クリックします。NK2 ファイルをリセットして、[名前の変更] をクリックするプロファイルの名前を持ちます。
  9. Profilename プロパティ.bakでは、ファイルの名前を変更し、Enter キーを押します。
  10. Outlook を開始します。

オートコンプリートのキャッシュに関する問題

このセクションでは、オートコンプリートのキャッシュを使用して発生する可能性がある既知の問題について説明します。オートコンプリート キャッシュは破損することが時間の経過と、新しいエントリを保存しない場合があります。このような場合は、ボックスの一覧から個々 のエントリを削除しようとすることができます。これを行うには、「オートコンプリート リスト エントリを 1 つを一度に削除する方法。」というタイトルのセクションを参照してください。、問題が解決しない場合は、オートコンプリート リスト全体をリセットできます。これを行うには、「オートコンプリート リスト全体を消去する方法。」というタイトルのセクションを参照してください。

オートコンプリート リストの制限を変更する方法

この構成はテスト済みなのでお勧めしません。大規模なオートコンプリート リストがあればもできなくなりより多くのキャッシュされたエントリの破損が発生したため、オートコンプリートのキャッシュが使用できなくなった場合。この免責事項を指定するには、Outlook の theAutoComplete リストの制限値を大きくには次のレジストリ データを使用できます。

重要: このセクション、方法、タスクには、レジストリを変更する方法の手順が含まれています。ただし、レジストリが正しく変更されないと、深刻な問題が発生することがあります。そのため、次の手順に慎重に従ってください。また、念のため、レジストリを変更する前に、レジストリをバックアップしておいてください。そうすることで、問題が発生した場合にレジストリを復元できます。レジストリをバックアップおよび復元する方法についての詳細は、次の文書番号をクリックして、マイクロソフト サポート技術資料を参照してください。

322756 Windows でレジストリをバックアップおよび復元する方法
  1. Outlook を終了します。
  2. レジストリ エディターを起動します。
    • Windows 8.x、プレス、Windows キー、 regeditと入力し、 Enterキーを押します。
    • Windows 7 および Windows Vista の場合は、[開始] をクリックしますタイプ regedit検索の開始] ボックスで、 Enterキーを押します。
  3. 次のレジストリ サブキーを見つけて選択します。

    HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\AutoNameCheck

    注: <b>プレース ホルダー x.0 このレジストリ サブキーは、Microsoft Office のバージョンを表します。次の一覧から適切な値を使用します。

    Outlook 2016 = 16.0
    Outlook 2013 = 15.0
    Outlook 2010 = 14.0
    Outlook 2007 = 12.0
    Outlook 2003 = 11.0
  4. [編集] メニューで、新規作成] をポイントし、[ DWORD 値] をクリックします。
  5. タイプ MaxNickNames、し、 Enterキーを押します。
  6. [編集] メニューの [修正] をクリックします。
  7. 制限の新しい値を入力し、し、[ OK] をクリックします。

    注:
    • Decimal フォームで番号を入力することを確認します。番号を入力するための正しいフォームです。
    • 新しい制限をテストするのには最低限の量だけで、制限値を増やしてみてください。たとえば、Outlook 2013 での制限] では、20% の増加を作成するには指定しました。1200 MaxNickNames の値です。
  8. レジストリ エディタを終了します。
  9. Outlook を起動します。
注: <b>MaxNickNames レジストリ値は、既定以外の制限を指定するだけです。そのため、ニックネームのキャッシュの上限を下げるにはこの値を使用することもできます。

警告: この記事は自動翻訳されています

プロパティ

文書番号:2199226 - 最終更新日: 09/23/2015 04:42:00 - リビジョン: 5.0

Outlook 2016, Microsoft Outlook 2013, Microsoft Office Outlook 2003, Microsoft Office Outlook 2007, Microsoft Outlook 2010

  • kbmt KB2199226 KbMtja
フィードバック
/html>