既に解放済みの画面バッファーを解放しようとするいると CSRSS で stop 0XC000021A します。

この記事は、以前は次の ID で公開されていました: JP234658
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。

英語版 KB:234658
この資料は、アーカイブされました。これは "現状のまま" で提供され、更新されることはありません。
現象
常に作成し、コンソールを閉じるサービスとしてプログラムを実行すると、コンピューターからログオフするとき次のブルー スクリーンのエラー メッセージが表示可能性があります。
STOP: c000021a {致命的なシステム エラー}
Windows サブシステムのシステム プロセスは予期せず終了しました。
0xc0000005 の状態で (0x77f7d40f 0x187fd70)。
システムはシャット ダウンされました。
パラメーター 0xC0000005 の状態によって異なります。
原因
この問題は CSRSS が所有、画面バッファーは、プロセスによって解放されるために発生します。解放のプロセスでは、スクリーン バッファーの参照カウントがインクリメントされます。スクリーン バッファーの参照カウント 0 に減少する、画面バッファーを解放しようです。画面バッファー (解放) 既に解放されているため、これを停止する 0xc00021a をもたらしますリード、アクセス違反が発生します。

解決方法

Windows NT サーバーまたはワークステーション 4.0

この問題を解決するには、Windows NT 4.0 または個別のソフトウェア更新プログラムの最新の service pack を入手します。最新の service pack の入手方法についてを参照してください。
個々 のソフトウェア更新プログラムを取得する方法については、マイクロソフト製品サポート サービスに連絡してください。Microsoft 製品サポート サービスの電話番号とサポート コストに関する情報の完全な一覧については、次のアドレスに、World Wide Web 上で参照してください。

Windows NT Server 4.0 は、ターミナル サーバーのエディション

この問題を解決するには、Windows NT Server 4.0、Terminal Server Edition の最新の service pack を入手します。詳細については、の記事を表示するには、次の資料番号をクリックして、マイクロソフト サポート技術情報:
152734 Windows NT 4.0 の最新の Service Pack を入手する方法

状況
マイクロソフトでは、この Windows NT 4.0 および Windows NT Server 4.0、Terminal Server Edition の問題として認識しています。

この問題はまず Windows NT Server 4.0 Service Pack 6 と Windows NT Server 4.0 は、ターミナル サーバーのエディションの Service Pack 6 で修正されました。
回避策
この問題を回避するには、ログオフするのではなく、サーバー、ワークステーションをロックします。ただし、この特定の状況で実用的な問題を回避することがあります。

警告: この記事は自動翻訳されています

プロパティ

文書番号:234658 - 最終更新日: 12/05/2015 14:53:27 - リビジョン: 2.0

  • kbnosurvey kbarchive kbbug kbfix kbqfe kbhotfixserver kbmt KB234658 KbMtja
フィードバック