現在オフラインです。再接続するためにインターネットの接続を待っています

Windows 7 で WSD デバイス用のアイコンが [デバイスとプリンター] で別のクラスとして誤って表示される場合がある

現象
Web Services for Devices (WSD) デバイスを、[デバイスとプリンター] で確認すると、正しくないアイコンが表示される場合があります。たとえば、WSD プリンターが [プリンターと FAX] の下にプリンター アイコンとして表示されるのではなく、 [デバイス] の下にサーバー アイコンを使用して表示される場合があります。
原因
この問題の原因は、2010 年 6 月 8 日から 6 月 22 日までの間に、マイクロソフトによりリリースされ提供されていた Device Stage パッケージです。
解決方法
この問題を解決するには、Device Stage Metadata Store を消去し、新しいパッケージをダウンロードします。この問題を解決するには、「Fix it で解決する」セクションに進んでください。自身でこの問題を解決するには、「自分で解決する」セクションに進んでください。

Fix it で解決する

この問題を自動的に解決するには、[この問題を解決する] リンクをクリックします。続いて [ファイルのダウンロード] ダイアログ ボックスで [実行] をクリックし、このウィザードの手順に従います。




: このウィザードは英語版のみである場合がありますが、しかし、自動的な解決は英語版以外の Windows でも機能します。

: 操作しているコンピューターに問題がない場合、自動的な解決をフラッシュ ドライブまたは CD に保存して、問題のあるコンピューターで実行することができます。

自分で解決する

この問題を自分で解決するには、次の手順を実行します。

1.       管理者特権を持つコマンド プロンプトを開きます。

2.       「del /s "%systemdrive%\users\%username%\AppData\Local\Microsoft\Device Metadata\*.*"」と入力し、Enter キーを押します。

3.       "Are you sure (Y/N)" というメッセージが表示されたら、Y キーを押し、Enter キーを押します。

4.       現在コンピューター上にある Device Stage パッケージの数に応じて、追加の複数の削除を確認するために、Y キーを押す必要がある場合があります (これらはすべて Windows により新規ダウンロードされます)。
 

上記の手順により、不適切なパッケージが含まれるキャッシュ コンテンツが削除され、Windows 7 では適切なデバイス メタデータが含まれる適切なパッケージがダウンロードされます。
fixit fix it
注意 : これは、マイクロソフトのサポート組織内で直接作成された "緊急公開" の資料です。 この資料には、確認中の問題に関する現状ベースの情報が記載されています。 情報提供のスピードを優先するため、資料には誤植が含まれる可能性があり、予告なしに随時改定される場合があります。 その他の考慮事項については、使用条件を参照してください。
プロパティ

文書番号:2403006 - 最終更新日: 04/13/2011 10:58:00 - リビジョン: 1.0

  • kbmsifixme kbfixme KB2403006
フィードバック
/html>