Outlook 2007 以降のバージョンでグローバル アドレス帳を参照すると、内容が表示されない

現象
Outlook 2007 以降のバージョンにおいて、オンライン モード (非キャッシュ モード) で Exchange サーバーのグローバル アドレス一覧やアドレス一覧を参照した場合、内容が正常に表示されず、空の状態となる場合があります。
原因
Windows 2008 以降では日本語のフリガナをサポートしており、Outlook 2007 以降のバージョンでグローバル アドレス一覧やアドレス一覧を参照する場合、フリガナのインデックスも使用されます。アドレス一覧のソートや、検索にもフリガナが利用されます。
クライアントからアドレス一覧を見た場合、[フリガナ] という列が表示されている場合には、フリガナのインデックスが使用される環境です。

しかし、日本語以外のグローバル カタログ サーバーを使用した場合、日本語のフリガナを使ったインデックスがサポートされておらず、日本語の Outlook からフリガナのインデックスを使うよう要求しても、サーバー側で正しい応答を返すことができないため、アドレス帳の内容を表示できないという現象が発生いたします。

この現象は、以下のすべての条件を満たす場合に発生します。
  • Windows 2008/Windows 2008 R2/Windows Server 2012/Windows Server 2012 R2 を Windows の言語設定が日本語以外の設定になっている状態でドメイン コントローラに昇格し、その後さらにグローバル カタログ サーバーにした場合
  • クライアントが、Outlook 2007 以降のバージョンである場合
    Outlook 2003 ではフリガナの機能がサポートされていないため、この現象は発生しません。
  • クライアントの Windows の言語設定が日本語である場合


回避策
以下のいずれかの方法で上記の問題を回避することが可能です。
  1. クライアント側の対処
    クライアントの Outlook 環境で以下の手順に従ってレジストリを作成し、フリガナの機能を無効にします。

    重要 : このセクション、方法、またはタスクには、レジストリの編集方法が記載されています。レジストリを誤って変更すると、深刻な問題が発生することがあります。レジストリを編集する際には十分に注意してください。万一に備えて、編集の前にレジストリをバックアップしておくと、問題が発生した場合にレジストリを復元することができます。バックアップおよび復元方法の詳細を参照するには、以下のサポート技術情報をクリックしてください。
    322756 Windows でレジストリをバックアップおよび復元する方法
    1. [スタート] メニューの [ファイル名を指定して実行] で regedit と入力します。
    2. 次のキーまで移動し、DisableGALPhonetic 値を Exchange Provider キー内に作成します。

      HKEY_CURRENT_USER\Software\Policies\Microsoft\Exchange\Exchange Provider
      あるいは、HKEY_CURRENT_USER\Software\Microsoft\Exchange\Exchange Provider

        値の名前: DisableGALPhonetic
        データタイプ: DWORD 値 (REG_DWORD)
        文字列: 1

      補足:
      フリガナは既定では有効であり、上記のレジストリで無効にすると、フリガナが利用できなくなります。
      (アドレス帳の [フリガナ] 列にデータが表示されなくなり、フリガナによる検索を行うことができなくなります。)
  2. サーバー側の対処
    以下のいずれかで対処可能です。
    1. 日本語を選択してインストールしたグローバル カタログ サーバーを追加し、Exchange サーバーが日本語のグローバル カタログ サーバーのみ使用するよう設定します。
      インストール時に日本語の選択が必要な項目は "Time and currency format" となります。
    2. グローバル カタログ サーバーを降格し、システム アカウントのロケールを日本語に変更後、再昇格します。
      この現象は、ディレクトリ サービスのロケールが日本語以外の環境で発生しますが、このロケールは、ドメイン コントローラへの昇格時にシステム アカウントのロケールとして設定されているものが使用されます。
      昇格後はロケールを変更することはできず、システム アカウントのロケールを変更して、再昇格する必要があります。

      Windows 2008/Windows 2008 R2 では以下の手順にて、システム アカウントのロケールの変更が可能です。
      1. [Control Panel]-[Regional and Language Options] を選択します。
      2. [Formats] プロパティ ページの [Current format] にて "Japanese (Japan)" を 選択します。
      3. [Apply] をクリックし、設定を適用します。
      4. [Administrative] タブをクリックし、[Copy to reserved accounts] をクリックし、System accounts を選択して [OK] をクリックします。
      5. 以上の手順で、システム アカウントのロケールが日本語となるため、上記の設定後、dcpromo によりドメイン コントローラーへ昇格後、再度グローバル カタログ サーバーにします。

      Windows Server 2012/Windows Server 2012 R2 では以下の手順にて、システム アカウントのロケールの変更が可能です。
      1. [Control Panel]- [Change date, time, or number formats] を選択します。
      2. [Formats] プロパティ ページの [Format] にて "Japanese (Japan)" を 選択します。
      3. [Apply] をクリックし、設定を適用します。
      4. [Administrative] タブをクリックし、[Copy settings...] をクリックします。
      5. [Welcome screen and new user accounts settings] にて [Welcome screen and system accounts] にチェックを入れて [OK] をクリックします。
      6. 以上の手順で、システム アカウントのロケールが日本語となるため、上記の設定後、dcpromo によりドメイン コントローラーへ昇格後、再度グローバル カタログ サーバーにします。

      一度、日本語のロケールでドメイン コントローラーに昇格させると、フリガナなどを含む日本語のインデックスが作成されます。
      このインデックスは、システム アカウントのロケールを英語に戻しても削除されることはありませんので、昇格後、システム ロケールを英語に戻すことが可能です。

状況
この動作は仕様です。
注意 : これは、マイクロソフトのサポート組織内で直接作成された "緊急公開" の資料です。 この資料には、確認中の問題に関する現状ベースの情報が記載されています。 情報提供のスピードを優先するため、資料には誤植が含まれる可能性があり、予告なしに随時改定される場合があります。 その他の考慮事項については、使用条件を参照してください。
プロパティ

文書番号:2532293 - 最終更新日: 09/12/2014 04:47:00 - リビジョン: 4.0

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  • KB2532293
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