Set-Mailbox や Set-CalendarProcessing 実行時に System Attendant サービスによるメールボックスのログイン処理が失敗します

現象
Exchange Server 2007 および 2010 の管理シェルにて Enable-Mailbox コマンド実行直後に Set-Mailbox や Set-CalendarProcessing 等のコマンドを連続で実行した場合に、以下のエラーが発生する場合があります。時間をあけて同じコマンドレットを実行した場合、エラーは発生しません。

メールボックス /o=<組織名>/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=<サーバー名>/cn=Microsoft System Attendant を開けません。
    + CategoryInfo      : NotSpecified: (0:Int32) [Set-CalendarProcessing]、MailboxUnavailableException
    + FullyQualifiedErrorId : 9ACAFECD,Microsoft.Exchange.Management.RecipientTasks.SetMailboxCalendarSettings

注 : 上記のエラーは一例であり、実行するコマンドレットによっては、発生するエラーが異なる場合があります。
原因
この現象は、Information Store サービスの DSAccess キャッシュの機能によって発生します。Exchange Server の Information Store サービスでは、ドメイン コントローラやネットワークが高負荷になることを抑制するために、実行した LDAP サーチのクエリとその結果を DSAcces というコンポーネントがキャッシュしています。このキャッシュには、LDAP サーチによって有効な結果 (例えば、条件に合致するユーザー オブジェクトなど) が得られた場合の他に、検索条件に合致するオブジェクトが無かった場合も、オブジェクトが見つからなかったことを示すキャッシュを生成します。

Set-Mailbox や Set-CalendarProcessing 等のコマンドレットでは、対象のメールボックスに System Attendant のアカウントを使用してログオンしますが、ログオンするメールボックスの情報を Active Directory から検索する際に、DSAccess のキャッシュから対象のユーザーが存在しなかったことを示すエントリーを検出すると、System Attendant がログオンに失敗し、コマンドレットもエラーになります。

DSAccess のキャッシュは、Information Store サービスの多くの処理で使用されるため、System Attendant がログオンする前に他の処理によって同一の LDAP サーチが実行され、その結果として見つからなかったことを示すキャッシュが生成されている場合、このエラーが発生します。
回避策
DSAccess のキャッシュの既定の有効期限である 5 分以上経過してから Set-Mailbox や Set-CalendarProcessing 等のコマンドを実行することにより現象を回避することが可能です。
注意 : これは、マイクロソフトのサポート組織内で直接作成された "緊急公開" の資料です。 この資料には、確認中の問題に関する現状ベースの情報が記載されています。 情報提供のスピードを優先するため、資料には誤植が含まれる可能性があり、予告なしに随時改定される場合があります。 その他の考慮事項については、使用条件を参照してください。
プロパティ

文書番号:2538994 - 最終更新日: 09/20/2016 09:32:00 - リビジョン: 3.0

Microsoft Exchange Server 2010 Standard, Microsoft Exchange Server 2010 Enterprise, Microsoft Exchange Server 2007 Enterprise Edition, Microsoft Exchange Server 2007 Standard Edition

  • kberrmsg KB2538994
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