エクスプローラで CAB ファイルを開くとエラーになる場合があります

現象
CAB ファイルに 0 バイトとなっているファイルしか含まれない場合、その CAB ファイルをエクスプローラで開く際に、以下のエラーが表示され、CAB ファイルが開けない場合があります。

「キャビネット ファイルを開けません」
原因
Windows Vista/Windows Server 2008/Windows 7/Windows Server 2008 R2 では、以下のセキュリティ修正を適用しますと、この問題が発生します。
http://technet.microsoft.com/en-us/security/bulletin/MS10-019


上記のセキュリティ修正の cabview.dll モジュールに、CAB ファイルフォーマットのチェックが追加され、この追加されたフォーマットチェックによって、本エラーが発生しています。
解決方法
本現象に対する修正が提供される予定はありません。
回避策
Expand.exe などのユーティリティを使用して CAB ファイルを展開します。
状況
詳細
関連情報
注意 : これは、マイクロソフトのサポート組織内で直接作成された "緊急公開" の資料です。 この資料には、確認中の問題に関する現状ベースの情報が記載されています。 情報提供のスピードを優先するため、資料には誤植が含まれる可能性があり、予告なしに随時改定される場合があります。 その他の考慮事項については、使用条件を参照してください。
Właściwości

Identyfikator artykułu: 2780395 — ostatni przegląd: 09/29/2016 09:35:00 — zmiana: 4.0

Windows Server 2008 Datacenter, Windows Server 2008 Enterprise, Windows Server 2008 Standard, Windows Server 2008 R2 Datacenter, Windows Server 2008 R2 Enterprise, Windows Server 2008 R2 Standard, Windows Server 2012 Datacenter, Windows Server 2012 Standard, Windows 7 Enterprise, Windows 7 Ultimate, Windows 7 Professional, Windows 7 Home Premium, Windows Vista Ultimate, Windows Vista Enterprise, Windows Vista Business

  • KB2780395
Opinia