Windows 8 で対話型サービスのデスクトップ画面が黒くなる

現象
Windows 8 環境で対話型サービスから対話型メッセージが送信され、「対話型サービス ダイアログ ボックスの検出」 ダイアログにてセッション 0 の対話型デスクトップに切り替えた際、システム起動後の 1 回目の切り替えでは画面が真っ暗な状態となります。一旦ユーザーセッションに戻った後、2 回目以降の切り替えでは正常に表示されます。
原因
Session 0 のデスクトップ表示の際、初回のリフレッシュのタイミングの問題で発生します。
解決方法
回避策
対話型サービスのデスクトップ画面で Enter キーを押して [今すぐ戻る(R)] にてユーザー セッションに戻った後、もう一度表示してください。
状況
詳細
Windows Vista 及び Windows Server 2008 以降の OS では、セキュリティ リスクを軽減するために対話型サービスはサポート対象から外れています。サービス プログラムの開発者は、デスクトップ上で動作している UI を持つプロセスを経由して UI を表示してください。
関連情報
対話型サービスがサポート対象から外れた点については以下も参照してください。


サービス プログラムのセッション 0 の分離の対応については、以下を参照してください。


注意 : これは、マイクロソフトのサポート組織内で直接作成された "緊急公開" の資料です。 この資料には、確認中の問題に関する現状ベースの情報が記載されています。 情報提供のスピードを優先するため、資料には誤植が含まれる可能性があり、予告なしに随時改定される場合があります。 その他の考慮事項については、使用条件を参照してください。
プロパティ

文書番号:2821853 - 最終更新日: 09/29/2016 09:56:00 - リビジョン: 3.0

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