現在オフラインです。再接続するためにインターネットの接続を待っています

[ACC2003] Access 2002 または Access 2003 でファイルをインポート、エクスポート、またはリンクするときに、一部のファイル形式が表示されないか、エラー メッセージ "インストール可能な ISAM ドライバが見つかりませんでした" が表示される

Office 2003 のサポートは終了しました

マイクロソフトでは、2014 年 4 月 8 日に Office 2003 のサポートを終了しました。この変更は、ソフトウェアの更新プログラムおよびセキュリティ オプションに影響しています。 この変更の意味および保護された状態を維持する方法について説明します。

この記事は、以前は次の ID で公開されていました: JP283881
重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、システムの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986 Microsoft Windows レジストリの説明
難易度 : 中。基本的なマクロ、コーディング、相互運用性に関する知識が必要です。

この資料は Microsoft Access データベース (.mdb)、および Microsoft Access プロジェクト (.adp) について記述したものです。

Microsoft Access 2000 については、次の資料を参照してください。209805
Microsoft Access 97 については、次の資料を参照してください。90111
現象
Access で、ファイルをインポート、エクスポート、またはリンクするときに、[インポート]、[エクスポート]、または [リンク] ダイアログ ボックスの [ファイルの種類] ボックスの一覧に一部のファイル形式が表示されません。ISAM (Indexed Sequential Access Method) ドライバを使用して、ファイルをインポート、エクスポート、またはリンクするとき、Microsoft Access で ISAM ドライバが見つからないと、エラー メッセージが表示されることがあります。
原因
ISAM ドライバは、Access 以外のファイル形式を Access で更新する際に使用されます。Windows レジストリに設定されている ISAM ドライバのパスが正しくない場合、または ISAM ドライバが存在しない場合、次のいずれかのエラー メッセージが表示されることがあります。

エラー メッセージ 1
インストール可能な ISAM ドライバが見つかりませんでした。
エラー メッセージ 2
ファイル '<pathname>' の情報にアクセスできません。ファイルが存在し、形式が正しいことを確認してください。
解決方法
警告 : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリ エディタの誤用により発生した問題に関しては、一切責任を負わないものとします。レジストリ エディタは、自己の責任においてご使用ください。

この問題を解決するには、レジストリ内にあるパス名の誤りを修正し、問題のファイルをインストールするか置き換える必要があります。

最初のエラー メッセージの場合は、試行した操作に直接関連しているファイルが、対象のファイルです。

2 番目のエラー メッセージの場合は、ファイル名がメッセージの文中に示されています。
  1. 次の表の中から、関連するファイルを見つけます。
    ファイル名インポートまたはエクスポートに使用する ISAMWindows レジストリ
    Msexcl40.dllMicrosoft ExcelHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Excel
    Msexch40.dllMicrosoft ExchangeHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Exchange
    Msrd2x40.dllMicrosoft Jet 2.xHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Jet 2.x
    Msrd3x40.dllMicrosoft Jet 3.xHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Jet 3.x
    Msltus40.dllLotus 1-2-3HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Lotus
    Mspbde40.dllImprise ParadoxHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox
    Mstext40.dllテキストHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Text
    Msxbde40.dlldBaseHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase
  2. エクスプローラを使用して、そのファイルを検索します。
  3. ファイルが見つかったら、そのパス名をメモします。見つからない場合は、手順 9. に進みます。
  4. レジストリ エディタを起動します。
  5. 上の表に記載されているレジストリのサブキーを参照し、実際に設定されているパス名と比較します。
  6. パスが間違っている場合は修正します。正しい場合は、次の手順に進みます。
  7. レジストリ エディタを終了します。パス名を変更した場合は、最初にエラーが発生した手順をもう一度実行します。
  8. 再びエラーが発生する場合や、手順 6. でパス名が正しかった場合は、ファイルの名前を変更します。
  9. [アプリケーションの追加と削除] (または [プログラムの追加と削除]) ツールを起動します。
  10. [現在インストールされているプログラム] ボックスの一覧で、Microsoft Office の項目をクリックし、[変更] をクリックして、Office のセットアップ プログラムを起動します。次に [Office の修復] (または [再インストール/修復]) をクリックします。
関連情報
レジストリの編集の詳細については、Office アシスタントにレジストリと入力し、[検索] をクリックして該当する項目を参照してください。
関連情報
この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 283881 (最終更新日 2004-06-16) を基に作成したものです。
prb 1 2 3 123 can't can t cannot not could couldn find installable ISAM ACC2002 ACC2003
プロパティ

文書番号:283881 - 最終更新日: 11/18/2004 08:14:58 - リビジョン: 5.1

  • Microsoft Office Access 2003
  • Microsoft Access 2002 Standard Edition
  • kbupdateissue kberrmsg kbprb KB283881
フィードバック