現在オフラインです。再接続するためにインターネットの接続を待っています

Visio で作成したカスタム線をシェイプとして保存し、拡大した図面に配置すると、ズーム率が即時反映されない

Office 2003 のサポートは終了しました

マイクロソフトでは、2014 年 4 月 8 日に Office 2003 のサポートを終了しました。この変更は、ソフトウェアの更新プログラムおよびセキュリティ オプションに影響しています。 この変更の意味および保護された状態を維持する方法について説明します。

現象
Visio でカスタム線を作成し、作成したカスタム線をシェイプとして保存した後、拡大した図面に配置するとズーム率が反映されずに表示されます。
原因
解決方法
回避策
この現象を回避するためには、以下のいずれかの方法で回避します。
  1. 後から配置したシェイプを移動する
  2. 後から配置したシェイプの頂点を移動する
  3. ズーム率を変更する

状況
マイクロソフトでは、この問題について現在調査中です。詳細については、わかりしだいこの資料に掲載する予定です。
詳細
問題の再現手順

Visio 2007 の場合
  1. Visio 2007 を起動し、[ファイル] – [新規作成] – [新しい図面] をクリックします。
  2. [表示] – [ツールバー] – [ドローイング エクスプローラー ウィンドウ] をクリックします。
  3. "ドローイングエクスプローラー" ウィンドウにある [線の種類] を右クリックし、表示されたメニューから、[新しいパターン] をクリックします。
  4. "新しいパターン" ダイアログが表示されたら、任意の名前を付けて [OK] をクリックします。
  5. 手順 4 で作成したパターンを右クリックし、表示されたメニューから、[パターン図形の編集] をクリックします。
  6. [表示] – [ツールバー] – [描画] にチェックを入れます。
  7. パターン図形の編集画面に直線ツールで直線を作図し、線の太さを 17 に設定します。
  8. パターン図形の編集画面を閉じ、手順 7 で作成した線の更新を確認する画面が表示されたら [はい] をクリックして閉じます。
  9. [表示] – [ツールバー] – [ステンシル] にチェックを入れます。
  10. ステンシル ツールバー メニュー内にある [新しいステンシル] をクリックします。
  11. 手順 10 で作成したステンシル名の下に空白を右クリックし、表示されたメニューから、「新しいマスタシェイプ」をクリックします。
  12. "新しいマスタシェイプ" ダイアログが表示されたら、任意の名前を付けて、[OK] をクリックします。
  13. 手順 12 で作成したマスター シェイプを右クリックし、表示されたメニューから、[マスタ シェイプの編集] – [マスタ シェイプの編集] をクリックします。
  14. マスター シェイプの編集画面に直線ツールで直線を作図し、作成した直線を右クリックし、表示されたメニューから [書式] – [線] をクリックします。
  15. "線" の設定画面が表示されたら、[パターン] のリストから手順 8 で作成したパターンを選択し [OK] をクリックします。
  16. マスターシェイプの編集画面を閉じ、マスター シェイプの更新を確認する画面が表示されたら [はい] をクリックします。
  17. ステンシルから手順 16 で作成したシェイプを図面に配置します。
  18. ズームで拡大します。
  19. ステンシルから再度、手順 16 で作成したシェイプを図面に配置します。

結果 : 手順 19 で配置したシェイプが、手順17 で配置したシェイプと比較して細く表示されます。


Visio 2010 の場合
  1. Visio 2010 を起動して、空白の図面を作成する。
  2. [ファイル] – [オプション] で Visio のオプションを開き、[詳細設定] の全般にある [開発モードで実行する] にチェックを入れます。
  3. Visio のオプションを [OK] をクリックして閉じます。
  4. 左ペインに表示されているステンシル メニューの [その他の図形] – [新しいステンシル (メートル法)] をクリックします。
  5. 手順 4 で作成したステンシルのタイトルを右クリックし、表示されたメニューから、[ドローイング エクスプローラー ウィンドウ] をクリックします。
  6.  "ドローイングエクスプローラー" ウィンドウにある [線の種類] を右クリックし、表示されたメニューから、[新しいパターン] をクリックします。
  7.  "新しいパターン" ダイアログが表示されたら、任意の名前を付けて [OK] をクリックします。
  8. 手順 7 で作成したパターンを右クリックし、表示されたメニューから、[パターン図形の編集] をクリックします。
  9. パターン図形の編集画面に直線ツールで直線を作図し、線の太さを 6pt に設定します。
  10. パターン図形の編集画面を閉じ、手順 9 で作成した線の更新を確認する画面が表示されたら [はい] をクリックして閉じます。
  11. 手順 4 で作成したステンシルの下にある [ここにクイック図形をドロップします] という領域を右クリックし、表示されたメニューから、「新しいマスターシェイプ」をクリックします。
  12. "新しいマスターシェイプ" ダイアログが表示されたら、任意の名前を付けて、[OK] をクリックします。
  13. 手順 12 で作成したマスター シェイプを右クリックし、表示されたメニューから、[マスター シェイプの編集] – [マスター シェイプの編集] をクリックします。
  14. マスター シェイプの編集画面に直線ツールで直線を作図し、作成した直線を右クリックし、表示されたメニューから [書式] – [線] をクリックします。
  15. "線" の設定画面が表示されたら、[線の種類] のリストから手順 10 で作成したパターンを選択し [OK] をクリックします。
  16. マスターシェイプの編集画面を閉じ、マスター シェイプの更新を確認する画面が表示されたら [はい] をクリックします。
  17. ステンシルから手順 16 で作成したシェイプを図面に配置します。
  18. ズームで拡大します。
  19. ステンシルから再度、手順 16 で作成したシェイプを図面に配置します。

結果 : 手順 19 で配置したシェイプが、手順17 で配置したシェイプと比較して細く表示されます。


Visio 2013 の場合

  1. Visio 2013 を起動して、空白の図面を作成する。
  2. [ファイル] – [オプション] で Visio のオプションを開き、[詳細設定] の全般にある [開発モードで実行する] にチェックを入れます。
  3. Visio のオプションを [OK] をクリックして閉じます。
  4. 左ペインに表示されているステンシル メニューの [その他の図形] – [新しいステンシル (メートル法)] をクリックします。
  5. 手順 4 で作成したステンシルのタイトルを右クリックし、表示されたメニューから、[ドローイング エクスプローラー ウィンドウ] をクリックします。
  6. "ドローイングエクスプローラー" ウィンドウにある [線の種類] を右クリックし、表示されたメニューから、[新しいパターン] をクリックします。
  7. "新しいパターン" ダイアログが表示されたら、任意の名前を付けて [OK] をクリックします。
  8. 手順 7 で作成したパターンを右クリックし、表示されたメニューから、[パターン図形の編集] をクリックします。
  9. パターン図形の編集画面に直線ツールで直線を作図し、線の太さを 6pt に設定します。
  10. パターン図形の編集画面を閉じ、手順 9 で作成した線の更新を確認する画面が表示されたら [はい] をクリックして閉じます。
  11. 手順 4 で作成したステンシルの下にある [ここにクイック図形をドロップします] という領域を右クリックし、表示されたメニューから、「新しいマスターシェイプ」をクリックします。
  12.  "新しいマスターシェイプ" ダイアログが表示されたら、任意の名前を付けて、[OK] をクリックします。
  13. 手順 12 で作成したマスター シェイプを右クリックし、表示されたメニューから、[マスター シェイプの編集] – [マスター シェイプの編集] をクリックします。
  14. マスター シェイプの編集画面に直線ツールで直線を作図し、作成した直線を右クリックし、表示されたメニューから [図形の書式設定] をクリックします。
  15. "図形の書式設定" ウィンドウが表示されたら "線" を展開して、[実線/点線] のリストから手順 10 で作成したパターンを選択します。
  16. マスターシェイプの編集画面を閉じ、マスター シェイプの更新を確認する画面が表示されたら [はい] をクリックします。
  17. ステンシルから手順 16 で作成したシェイプを図面に配置します。
  18. ズームで拡大します。
  19. ステンシルから再度、手順 16 で作成したシェイプを図面に配置します。

結果 : 手順 19 で配置したシェイプが、手順17 で配置したシェイプと比較して細く表示されます。
関連情報
注意 : これは、マイクロソフトのサポート組織内で直接作成された "緊急公開" の資料です。 この資料には、確認中の問題に関する現状ベースの情報が記載されています。 情報提供のスピードを優先するため、資料には誤植が含まれる可能性があり、予告なしに随時改定される場合があります。 その他の考慮事項については、使用条件を参照してください。
プロパティ

文書番号:2848043 - 最終更新日: 09/20/2016 12:06:00 - リビジョン: 3.0

Microsoft Office Visio Standard 2003, Microsoft Office Visio Professional 2003, Microsoft Office Visio Standard 2007, Microsoft Office Visio Professional 2007, Microsoft Visio Standard 2010, Microsoft Visio Professional 2010, Microsoft Visio Standard 2013, Microsoft Visio Professional 2013

  • kbbug kbtshoot kbexpertiseinter KB2848043
フィードバック