Spreadsheet Compare 2013 で 2 バイト文字セット (DBCS) 言語を使用したマクロが含まれるファイルを比較するとマクロの比較結果が文字化けする

現象
Microsoft Office 2013 付属の Spreadsheet Compare 2013 を使用し、2 バイト文字セット (DBCS) 言語を使用したマクロが含まれるファイルを比較するとマクロの比較結果が文字化けします。
原因
SpreadSheet Compare 2013 ツールの比較処理では、英語版のツールとして提供されており、VBA の情報については ASCII でエンコードしてから比較処理を行います。
VBA のコードは Unicode ではなく、ANSI のコードページで保存されるため、VBA を記述した環境の OS の言語設定に依存します。
日本語版で作成した場合、マクロの文字コードは S-JIS であるため、ツールの比較処理では正しく処理することができません。
この動作は、現行の SpreadSheet Compare 2013 製品実装に基づく制限です。
関連情報
問題の再現手順 :

  1. 日本語 OS に、Office 2013 日本語版をインストールします。
  2. Excel 2013 を起動します。
  3. [開発]-[挿入]-[フォーム コントロール]-[ボタン (フォーム コントロール)] をクリックし、Sheet1 上にドラッグします。
  4. [マクロの登録] ダイアログが表示されたら、[新規作成] ボタンをクリックします。
  5. Module1 に以下のコードを貼り付けます。

    Sub ボタン1_Click()    MsgBox "変更前"End Sub

  6. [ファイル]-[終了して Microsoft Excel へ戻る] をクリックします。
  7. F12 キーを押下します。[名前を付けて保存] ダイアログが表示されたら、ファイル名に任意の名前を指定し、ファイルの種類では Excel マクロ有効ブック (*.xlsm) を選択し [保存] を行います。
    ここでは、例として c:\temp フォルダ下に Test1.xlsm として保存します。
  8. [ファイル]-[閉じる] をクリックします。
  9. Ctrl + N をクリックします。新規ブックが開きます。
  10. [開発]-[挿入]-[フォーム コントロール]-[ボタン (フォーム コントロール)] をクリックし、Sheet1 上にドラッグします。
  11. [マクロの登録] ダイアログが表示されたら、[新規作成] ボタンをクリックします。
  12. Module1 に以下のコードを貼り付けます。

    Sub ボタン1_Click()    MsgBox "修正後"End Sub

  13. [ファイル]-[終了して Microsoft Excel へ戻る] をクリックします。
  14. F12 キーを押下します。[名前を付けて保存] ダイアログが表示されたら、ファイル名に任意の名前を指定し、ファイルの種類では Excel マクロ有効ブック (*.xlsm) を選択し [保存] を行います。
    ここでは、例として c:\temp フォルダ下に Test2.xlsm として保存します。
  15. [Microsoft Office 2013]-[Office 2013 ツール]-[Spreadsheet Compare 2013] をクリックします。
  16. [Compare Files] ボタンをクリックします。
  17. 手順 7. と 手順 14. で保存したファイルを以下のように設定します。

    Compare: C:\temp\Test1.xlsm
    To: C:\temp\Test2.xlsm
  18. [OK] ボタンをクリックします。

結果 : 

以下のようにマクロ内に含まれる日本語の比較結果が文字化けします。

文字化け
注意 : これは、マイクロソフトのサポート組織内で直接作成された "緊急公開" の資料です。 この資料には、確認中の問題に関する現状ベースの情報が記載されています。 情報提供のスピードを優先するため、資料には誤植が含まれる可能性があり、予告なしに随時改定される場合があります。 その他の考慮事項については、使用条件を参照してください。
プロパティ

文書番号:2862969 - 最終更新日: 09/29/2016 10:32:00 - リビジョン: 3.0

Microsoft Excel 2013, Microsoft Office Professional Plus 2013, Microsoft Office Professional 2013, Microsoft Office Home and Business 2013, Microsoft Office Standard 2013, Microsoft Office Personal 2013

  • kbdeployment kbsetup kbhowto KB2862969
フィードバック