Azure Active Directory 同期ツールによる同期処理が停止する、または同期が 24 時間以上実行されていないという内容のメッセージを受け取る

現象
以下いずれかの現象が発生します。
  • Microsoft Azure Active Directory 同期ツールによる同期処理が停止する。
  • Active Directory が 24 時間以上同期を実行していないため、ディレクトリ同期サーバーで問題を確認するよう注意を促す内容の通知メールを受け取る。
  • MIISClient.exe ツールで、"停止 - サーバーが停止しました" メッセージが表示される。
  • 1 つ以上のディレクトリ同期サービスを開始できない。
  • ディレクトリ同期トラブルシューティングを実行すると、1 つ以上のディレクトリ同期サービスを起動できない旨の問題が発生していると表示される。
: 既定では、ディレクトリ同期は 3 時間おきに実行されます。
原因
この問題は、以下いずれかの条件に該当すると発生する場合があります。
  • ディレクトリ同期のセットアップ用構成ウィザードで使用した職場または学校アカウントに問題が発生している
    • アカウントが削除された
    • アカウントが無効化された
    • アカウントのパスワード有効期限が切れた
  • 1 つ以上のディレクトリ同期サービスにおいてログオン アカウントに問題が発生している
    • アカウントが削除された
    • アカウントが無効化された
    • アカウントのパスワード有効期限が切れた
    : ディレクトリ同期サービスに対するログオン アカウントは自動的に構成されるため、変更しないようにしてください。
  • ディレクトリ同期に使用する管理者アカウントを変更した
  • ネットワークに接続問題が発生している
  • ディレクトリ同期サービスが停止している
解決方法
:ディレクトリ同期のトラブルシューティング」を実行した結果、いずれか 1 つのサービスにおいてログオン アカウントの問題が発生していると表示された場合は、手順 2 に進んでください。

手順 1: 「ディレクトリ同期のトラブルシューティング」を実行する

Azure Active Directory 同期製品がインストールされているサーバー上で「ディレクトリ同期のトラブルシューティング」を実行することで、この問題に関するトラブルシューティングが可能です。Azure Active Directory 同期製品とは以下のいずれかとなります。

  • Azure Active Directory Connect
  • Azure Active Directory 同期ツール


手順 2: サービスが開始されており、管理者アカウントでサインインできることを手動で確認する

  1. [スタート]、[ファイル名を指定して実行] を順にクリックし、「Services.msc」と入力して [OK] をクリックします。
  2. Azure Active Directory 同期ツール サービスが開始されているかどうかを確認します。サービスが開始されていない場合は、右クリックして [開始] をクリックします。
    • Azure Active Directory 同期ツールを使用している場合は、Azure Active Directory 同期サービスを検索してください。
    • Microsoft Azure Active Directory Connect を使用している場合は、Microsoft Azure AD Sync を検索してください。
  3. ディレクトリ同期に使用している管理者アカウントが存在すること、およびこのアカウントにサインインできることを確認します。アカウントが存在する場合は、パスワードを再設定した後でサインインできることを確認します。ダイアログが表示される場合は、パスワードを変更します。

    ディレクトリ同期の構成に使用した全体管理者アカウントが不明な場合は、ディレクトリ同期製品をインストールしているサーバーで以下の手順を実施します。
    1. %ProgramFiles%\Microsoft Azure AD Sync\UIShell\ を開き、“Miisclient.exe” を実行します。

      注: Azure Active Directory Connect または Azure Active Directory 同期サービスを使用している場合は、[開始] をクリックし、“Synchronization Service” を検索して実行してください。
    2. [Connectors] をクリックし、[Azure Active Directory connector] をダブルクリックしてください。
    3. [Connectivity] をクリックします。
    4. UserName をメモしてください。これがディレクトリ同期の構成に使用した全体管理者のアカウントです。
  4. ディレクトリ同期サーバーで Azure Active Directory 同期製品の構成ウィザードを実行します。この管理者アカウントの新たなパスワードを入力し、ウィザード内の残りの手順を継続します。
  5. ウィザードの最終ページで、[ディレクトリ同期の強制実行] をオンにします。

手順 3: ディレクトリ同期サービスにおいてログオン アカウントに発生している問題を解決する


  1. [スタート]、[ファイル名を指定して実行] を順にクリックし、「Services.msc」と入力して [OK] をクリックします。
  2. Azure Active Directory 同期ツール サービスで右クリックし、[プロパティ] を選択します。[ログオン] タブをクリックし、表示されているアカウント名をメモします。
    • Azure Active Directory 同期ツールを使用している場合は、Azure Active Directory Sync Service を検索してください。
    • Azure Active Directory Connect を使用している場合は、Microsoft Azure AD Sync を検索してください。
    サービスで右クリックし、[プロパティ] をクリックします。[ログオン] タブに表示されているアカウント名をメモします。

    : ローカル システム アカウントはサポートされておらず、問題が生じる可能性があるため、ログオンできるようにディレクトリ同期サービスを再構成します。
  3. ドメイン コントローラーまたはドメイン管理ツールをインストールしているコンピューターから “Dsa.msc” を実行します。ドメイン名を右クリックし、[Find] (検索) を選択します。手順 2 でメモをとったアカウント名を入力し、[Find now] (今すぐ検索) ボタンをクリックします。
    • アカウント名が見つかった場合は、手順 4 へ進みます。
    • アカウント名が見つからない場合、削除されている可能性があります。「Azure Directory のごみ箱の手順ガイド」を参照して、アカウントを回復できるか確認してください。アカウントを回復できなかった場合、ディレクトリ同期クライアントをインストールし直す必要があります。
  4. 同アカウント上で右クリックし、[プロパティ] をクリックします。"Account options" (アカウント オプション) の [Account] (アカウント) タブで以下の操作を実行します。
    1. [Password never expires] (パスワードを無期限にする) チェック ボックスがオンになっていることを確認してください。 
    2. [Account is disabled] (アカウントを無効にする) チェック ボックスがオフになっていることを確認してください。以下のいずれかの操作を実行します。
      • [Account is disabled] (アカウントを無効にする) チェック ボックスがオンになっている場合、オフにしてアカウントを有効にします。 その後、Azure Active Directory 同期製品サービスを再起動します。[スタート]、[ファイル名を指定して実行] を順にクリックし、「Services.msc」と入力して [OK] をクリックします。 同サービス名で右クリックして、[Restart] (再起動) をクリックします。 
        • Azure Active Directory 同期ツールを使用している場合は、Azure Active Directory Sync Service を検索してください。
        • Azure Active Directory Connect を使用している場合は、Microsoft Azure AD Sync を検索してください。
      • [Account is disabled] (アカウントを無効にする) チェック ボックスがオフになっている場合、手順 5 へ進みます。
  5. [Account is disabled] (アカウントを無効にする) チェック ボックスがオフになっている場合、アカウントのパスワードが手動で変更されている可能性もあります。新しくパスワードを設定する場合は、同じように “Dsa.msc” を実行し、同アカウント上で右クリックし、[Reset Password] (パスワードの再設定) をクリックしてパスワードを再設定してください。ここで設定したパスワードは、次の手順でも再度使用するため、メモをとっておくようにしてください。
  6. 以下の手順に従って、ディレクトリ同期サービスのログオン アカウントにパスワードを設定します。 
    1. [スタート]、[ファイル名を指定して実行] を順にクリックし、「Services.msc」と入力して [OK] をクリックします。 
    2. クライアントに応じて以下のサービスで、パスワードを設定します。該当するサービスで右クリックし、[プロパティ]、[ログオン] タブを順にクリックし、パスワードを入力します。
      Azure Active Directory 同期クライアントAzure Active Directory Connect
      • Forefront Identity Manager Synchronization Service
      • SQL Server (MOSONLINE) (ある場合)
      • Azure Active Directory 同期サービス
      • Azure AD Sync
    3. 新しくパスワードを設定したサービスを起動します。
    4. ディレクトリ同期が開始されるまで 3 時間待ってから、ディレクトリ同期トラブルシューティングを実行します。 

手順 4: Microsoft Online Services サインインアシスタントの最新版をインストールする


イベント ビューアーのアプリケーション ログにおいて以下のイベント ID のエラーが表示される場合、古いバージョンの Microsoft Online Services サインイン アシスタントを利用しているか、Microsoft Online Services サインイン アシスタントのインストールが破損している可能性があります。

“Event ID: 109
Log Name: Application
Level: Error
Source: Directory Synchroniozation
Description:
Failure while importing entries from Windows Azure Active Directory. Exception:
Microsoft.Online.Coexistence.Security.DynamicPInvokeException: Failed to get address
for method: CreateIdentityHandle2 from library: C:\Program Files\Common Files\Microsoft
Shared\Microsoft Online Services\msoidcli.dll. GetLastError code: 127”

(Event ID: 109
Log Name: アプリケーション
Level: エラー
Source: ディレクトリ同期
Description:
Windows Azure Active Directory からエントリをインポートする際にエラーが発生しました。例外:
Microsoft.Online.Coexistence.Security.DynamicPInvokeException: メソッドでアドレスを取得
できませんでした。: CreateIdentityHandle2 from library: C:\Program Files\Common Files\Microsoft
Shared\Microsoft Online Services\msoidcli.dll. GetLastError code: 127”)


この問題を解決するには、Microsoft Online Services サインイン アシスタントの最新版をインストールしてください。インストールの手順については、以下の Microsoft Knowledge Base 資料の「解決方法」セクションを参照してください。
3037953: Azure Active Directory 同期ツールの構成ウィザードを実行すると "CreateIdentityHandle2 メソッドでアドレスを取得できませんでした" というエラー メッセージが表示される

追加情報
その他トピックは Office 365 コミュニティ Web サイト、または Azure Active Directory フォーラム Web サイトを参照してください。
プロパティ

文書番号:2882421 - 最終更新日: 04/04/2016 07:52:00 - リビジョン: 10.0

Microsoft Azure Active Directory, Microsoft Office 365, Microsoft Intune, CRM Online via Office 365 E Plans, Microsoft Azure Recovery Services, Office 365 Identity Management

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