RemoteApp で公開したInternet Explorer にて再描画が行われないことがある

現象
Internet Explorer 9 または 10 を RemoteApp アプリケーションとして公開している環境で、モーダル ダイアログを表示した際に画面の再描画が行われないことがあります。
原因
Internet Explorer 9 以降、実装されたハング回復機能の影響を受け、RemoteApp として公開された Internet Explorer でモーダルダイアログを表示した際に再描画が行われないことがあります。

ハング回復機能とは Internet Explorer 9から新しく実装された機能であり、タブ内にハングが発生しますと、それを自動的に検出して、ユーザーにハング回復通知を表示します。

ハング回復が選択されますと、ハングしたタブ内に表示するコンテンツを別タグに回復させることができます。これにより、IE9 の信頼性を高めています。詳しい情報は以下のページをご覧ください。


IE9 のハング処理機能

http://blogs.msdn.com/b/ie_jp/archive/2011/08/10/10194401.aspx
解決方法
RemoteApp サーバーにおいて以下のレジストリを設定し、ハング回復機能を無効に設定します。



1. RemoteApp サーバーにて管理者権限でログオンし、レジストリエディタを起動します。

2. 以下のレジストリを作成します。



Key : HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main

Type: REG_DWORD

Name: HangRecovery

Value: 0



Key : HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\Internet Explorer\Main

Type: REG_DWORD

Name: HangRecovery

Value: 0



3. Internet Explorer を再起動し、設定を反映させます。
回避策
状況
詳細
関連情報
注意 : これは、マイクロソフトのサポート組織内で直接作成された "緊急公開" の資料です。 この資料には、確認中の問題に関する現状ベースの情報が記載されています。 情報提供のスピードを優先するため、資料には誤植が含まれる可能性があり、予告なしに随時改定される場合があります。 その他の考慮事項については、使用条件を参照してください。
プロパティ

文書番号:2897215 - 最終更新日: 09/29/2016 10:54:00 - リビジョン: 3.0

Windows Server 2008 R2 Datacenter, Windows Server 2008 R2 Enterprise, Windows Server 2008 R2 Standard

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