ハイブリッド展開のユーザーにクラウドのアーカイブ メール フロー問題およびメール アクセス問題が発生する

: Microsoft Exchange Server 2010 の Exchange 管理コンソールにバンドルされていた従来のハイブリッド構成ウィザードのサポートは終了したため、今後は Office 365 ハイブリッド構成ウィザードを使用してください。Office 365 ハイブリッド構成ウィザードは、こちらからインストールできます。詳細については、以下の資料を参照してください。

現象
オンプレミス Exchange Server と Office 365 Exchange Online のハイブリッド展開において、以下の現象が発生します。
  • オンプレミス ユーザーからクラウド アーカイブ メール ユーザー宛てにメールを送信しようとすると、以下のようなメッセージを含む配信不能レポート (NDR) が届きます。
    “554 5.2.0 STOREDRV.Deliver.Exception:UserWithoutFederatedProxyAddressException;

    Failed to process message due to a permanent exception with message User doesn't have any SMTP proxy address from a domain that is federated.

    UserWithoutFederatedProxyAddressException: User doesn't have any SMTP proxy address from a domain that is federated. ##”(554 5.2.0 STOREDRV.Deliver.Exception:UserWithoutFederatedProxyAddressException;
    恒久的な例外があるため、メッセージを処理できません。ユーザーには、フェデレーションされたドメインから取得した SMTP プロキシ アドレスがありません。
    UserWithoutFederatedProxyAddressException: ユーザーには、フェデレーションされたドメインから取得した SMTP プロキシ アドレスがありません。##)
  • クラウドのアーカイブ ユーザーは Outlook または Outlook on the Web (旧名 Outlook Web App [OWA]) のメールにアクセスできません。ユーザーには Outlook on the Web に以下のようなエラー メッセージが表示されます。A
    “Url: https://mail.contoso.com:443/owa/auth.owaOWA version: 14.3.146.0

    ExceptionException type: System.NullReferenceException Exception message: オブジェクト参照がオブジェクト インスタンスに設定されていません。 "
原因
この問題は、電子メール アドレス ポリシーを設定しているドメインが既定ドメインであり、フェデレーション ドメインではない場合に発生します。このため、ドメインを使用するフェデレーション調停メールボックスに設定されている既定 SMTP アドレスが委託トークンを取得できません。
解決方法
  1. 以下の手順に従い、この問題が発生しているかどうかを検証します。
    1. オンプレミス Exchange 2013 Server または Exchange 2010 Server で Exchange 管理シェルを開きます。
    2. 以下のコマンドレットを実行します。
      Get-Mailbox –arbitration |fl PrimarySMTPAddress
    3. 実行結果から FederatedEmail メールボックスに指定されている SMTP ドメインを検索し、その値をメモに取ります。

      以下は実行結果例です。

      A screen shot showing an example of the output that shows the SMTP domain that's specified for the FederatedEmail mailbox
    4. 以下のコマンドレットを実行します。
      get-FederatedOrganizationIdentifier |fl Domains
    5. 手順 1C でメモに取ったドメインが表示されているかどうかを確認します。ドメインが表示される場合は、この問題が発生していることになります。手順 2 に進んでください。
  2. この問題を解決するには、以下いずれかを実行します。
    • 調停メールボックスに関連付く SMTP ドメインをフェデレーションする

      調停メールボックスに関連付く SMTP ドメインをフェデレーションするには、Exchange 管理センターまたは Exchange 管理コンソールを使用して、既存のフェデレーション信頼にこのドメイン名を追加します。

      手順の詳細については、「フェデレーション信頼の管理」を参照してください。
    • 調停メールボックスの SMTP アドレスおよび Active Directory のトランスポート設定コンテナーを変更する

      フェデレーション ドメインを使用するようにフェデレーション済み調停メールボックスの電子メール アドレスを変更し、このフェデレーション済み調停メールボックの電子メール アドレスと一致するように、トストランスポート設定コンテナーの電子メール アドレスも変更します。

      警告: この手順には Active Directory Service Interfaces Editor (ADSI エディター) が必要です。ADSI エディターを使用すると、オペレーティング システムの再インストールを必要とする深刻な問題が発生する可能性があります。マイクロソフトは、ADSI エディターの誤使用による問題については補償しません。ADSI エディターを使用する際は、ユーザー自身の責任のもと行うようにしてください。

      手順:
      1. ADSI エディターを開き、ドメインの名前付けコンテキスト コンテナーに接続します。
      2. [既定の名前付けコンテキスト] の [ユーザー] コンテナーからフェデレーション済み調停メールボックスのプロパティを開きます。
      3. プライマリ SMTP アドレス (SMTP が大文字で指定されたアドレス) がフェデレーション ドメインを使用するように proxyAddress 属性値を変更します。
      4. [構成] コンテナーに接続し、以下のパスからトランスポート設定を特定します。
        Configuration\Services\Microsoft Exchange\<Organization Name>
      5. トランスポート設定コンテナーのプロパティを開き、MSExchOrgFederatedMailbox 属性値を、手順 3 で指定した SMTP アドレスの値に変更します。
プロパティ

文書番号:2901386 - 最終更新日: 05/23/2016 08:41:00 - リビジョン: 5.0

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