現在オフラインです。再接続するためにインターネットの接続を待っています

サポート技術情報の Office XP プログラム用のサンプル コードを実行する方法

この記事は、以前は次の ID で公開されていました: JP290140
この資料は、アーカイブされました。これは "現状のまま" で提供され、更新されることはありません。
Microsoft Office 2000 については、次の資料を参照してください。212536
Microsoft Office 97 については、次の資料を参照してください。173707
Microsoft Office 2001 for Mac については、次の資料を参照してください。274703
Microsoft Office 98 Macintosh Edition については、次の資料を参照してください。181058
概要
「サポート技術情報」 (Microsoft Knowledge Base) には、Visual Basic for Applications マクロのサンプル コードが記載されている資料がいくつかあります。これらのマクロの多くでは、さまざまな Office XP プログラムで Visual Basic を使用してプログラムを作成する場合の基本的な概念について説明しています。この資料では、サンプル コードを使用して新しいマクロを作成する方法、およびそのマクロを実行する方法について説明します。
詳細
マイクロソフトは、この情報をプログラミング言語の使用方法の一例として提供するだけであり、市場性および特定目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。この資料は、例示されているプログラミング言語やプロシージャの作成およびデバッグに使用するツールについて理解されているユーザーを対象としています。Microsoft Support 担当者は、特定のプロシージャの機能についての問い合わせにはお答えできますが、ユーザー固有の目的に合わせた機能の追加、プロシージャの作成などの内容変更は行っておりません。「サポート技術情報」 (Microsoft Knowledge Base) の資料のサンプル コードを使用するには、新しい Visual Basic マクロを追加する (または既存のマクロを選択する) 必要があります。そのマクロにサンプル コードをコピーして貼り付けるか、入力するには、以下のいずれかの方法を使用します。

新しいマクロを作成する方法

  1. 使用している Office プログラムでテンプレートを開くか、作成します。
  2. [ツール] メニューの [マクロ] をポイントし、[マクロ] をクリックします。
  3. [マクロの保存先] ボックスの一覧で、マクロを保存する Word テンプレートまたは文書を選択します。
  4. [マクロ名] ボックスにマクロの名前を入力します。
  5. [作成] をクリックし、Visual Basic Editor を起動します。
  6. 以下のいずれかの手順を実行します。
    • Sub Macroname() と End Sub の行の間にあるマクロ コードを入力します。
      Sub macroname()    Type your macro code hereEnd Sub							
      または
    • 次の手順を実行して、サンプル コードをコピーし、マクロに貼り付けます。
      Sub macroname() End Sub						
      1. 「サポート技術情報」の資料の参照に使用しているアプリケーション (Microsoft Internet Explorer など) に切り替えます。
      2. Ctrl キーを押したままサンプル コードをクリックして、コードを選択します。
      3. [編集] メニューの [コピー] をクリックします。
      4. Visual Basic Editor に切り替えます。
      5. Visual Basic Editor で、マクロの Sub Macroname() から End Sub までのコード テキストを選択します。
      6. [編集] メニューの [貼り付け] をクリックします。

        : サンプル コードを貼り付けると、既存のコード テキストが「サポート技術情報」の資料からコピーしたコードに置き換えられます。
  7. マクロのコードを入力するか貼り付けた後、[ファイル] メニューの [終了して Microsoft program に戻る] をクリックします。program は使用している Microsoft Office XP プログラムです。


: テキストにインデントを付けるには、Tab キーを使用します。アポストロフィ (') で始まる行はコメントで、マクロの実行に必要ではありません。しかし、コメントを入力して、マクロのしくみをわかりやすくすることができます。

サンプル コードをモジュールに追加する方法

コードをモジュールに追加する際に既存のモジュールがない場合は、新しいモジュールを作成する必要があります。これを行うには、次の手順を実行します。
  1. 使用している Office プログラムでテンプレートを開くか、作成します。
  2. [ツール] メニューの [マクロ] をポイントし、[Visual Basic Editor] をクリックします。
  3. (デフォルトで左上に表示される) Visual Basic Editor のプロジェクト ウィンドウで、テンプレートまたは文書と同じ名前のプロジェクト アイコンをクリックします。テンプレートまたは文書を保存していない場合、プロジェクト名は Project (文書 1) または TemplateProject (テンプレート 1) などと表示されます。

    Word ユーザー向けの注 : デフォルトの全文書対象のテンプレートである Normal.dot にマクロを保存する場合は、[Normal] プロジェクトをダブルクリックします。
  4. クリックしたプロジェクトに Modules という名前のフォルダが含まれていない場合は、[挿入] メニューの [標準モジュール] をクリックします。
  5. 作成するモジュールのコード ウィンドウの任意の場所をクリックします。コード ウィンドウは、通常 Visual Basic Editor の右上隅にあります。
  6. 「サポート技術情報」に記載されたとおりに、Sub Macroname() から End Sub の行までのサンプル コードを入力するか、または貼り付けます。

    : マクロ コードの入力または貼り付けの詳細については、この資料の「新しいマクロを作成する方法」を参照してください。
マクロのコードを入力するか、貼り付けた後で、[ファイル] メニューの [終了して Microsoft program に戻る] をクリックします。

program は、使用している Microsoft Office XP プログラムです。

マクロを実行する方法

  1. [ツール] メニューの [マクロ] をポイントし、[マクロ] をクリックします。
  2. [マクロ名] ボックスの一覧からマクロの名前を選択し、[実行] をクリックします。
関連情報
それぞれの Office プログラムの Microsoft ヘルプには、マクロの使用に関する多くのトピックがあります。Visual Basic ヘルプには、独自のコード作成に関する幅広い情報が記載されています。
OfficeKBHowTo vba vbe visual basic inf OFFXP XP OFF
プロパティ

文書番号:290140 - 最終更新日: 12/06/2015 00:45:07 - リビジョン: 3.2

  • Microsoft Excel 2002 Standard Edition
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2002 Standard Edition
  • kbnosurvey kbarchive kbfaq kbhowto kbmacro kbprogramming KB290140
フィードバック