プリンターを登録していない環境で印刷プレビューからページ設定を開くと、Internet Explorer が応答を停止する

現象
以下の条件をすべて満たしている環境で、32 ビットの Internet Explorer 8 または Internet Explorer 9 を起動し、以下に示す手順を実行すると Internet Explorer が応答を停止する場合があります。

・ Windows Server 2008 R2 および Windows 7 の 64 ビット オペレーティング システムを利用している
・プリンターをインストールしていない、もしくは、通常使うプリンターとして設定されたプリンターが存在しない状態


- 再現手順
1. Internet Explorer を起動します。
2. [ファイル] - [印刷プレビュー] をクリックし、印刷プレビュー画面を開きます。
3. [ページ設定] をクリックすると、以下の [印刷エラー] が表示されます。このダイアログで [はい] をクリックします。

印刷に関連した作業 (ページ設定やドキュメントの印刷など) を実行する前に、プリンターをインストールする必要があります。 
今すぐプリンターをインストールしますか?  


4. [はい] を選択すると、[プリンターの追加] ダイアログが開きます。
5. [次へ] でウィザードを進め、[完了] をクリックするか、 [キャンセル] をクリックし、ウィザードを終了します。


原因
この問題は、32 ビットの Internet Explorer から 64 ビット スプーラー サービスの起動処理の解釈に問題があり、プリンター追加処理が終了した状態と判断されず、結果として Internet Explorer がスプーラー サービスからの応答を待ち続けてしまうために発生します。
回避策
この問題を解決するには、以下のいずれかの方法を実行します。

方法 1: あらかじめプリンターを登録する

事前に [コントロールパネル] から プリンターを登録することにより解決できます。プリンターを登録するには、以下の手順を実行します。

1. [スタート] ボタン をクリックし、[コントロール パネル] を開きます。
2. [ハードウェアとサウンド]、[プリンタ] の順にクリックします。
3. [プリンターの追加] をクリックします。
4. [プリンターの追加ウィザード] で [ローカル プリンターの追加] を選択します。
5. [プリンター ポートの選択] ページで [既存のポートを使用する] オプション ボタンおよび推奨されたプリンター ポートが選択されていることを確認し、[次へ] をクリックします。
6. [プリンター ドライバーのインストール] ページで、プリンターの製造元およびモデルを選択し、[次へ] をクリックします。
7. ウィザードの追加の手順を完了し、[完了] をクリックします。

方法 2: [ファイル] メニューの [ページ設定] を利用する

Internet Explorer の [ファイル] メニューからページ設定ダイアログを開くことにより解決できます。[ファイル] メニューからページ設定ダイアログを開くには以下の手順を実行します。

1. Internet Explorer を起動します。
2. [ファイル] - [ページ設定] をクリックします。

方法 3: 64ビットの Internet Explorer を利用する

64 ビットの Internet Explorer を利用することで解決できます。Internet Explorer 9 までをご利用の場合、64ビット オペレーティング システムでは、32ビットの Internet Explorer と、64 ビットの Internet Explorer がインストールされており、いずれのアプリケーションもご利用いただけます。64 ビットの Internet Explorer を利用するには以下の手順を実行します。

1. [スタート] ボタン をクリックし、[すべてのプログラム] をクリックします。
2. [Internet Explorer (64 ビット)] をクリックします。

状況
マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。
注意 : これは、マイクロソフトのサポート組織内で直接作成された "緊急公開" の資料です。 この資料には、確認中の問題に関する現状ベースの情報が記載されています。 情報提供のスピードを優先するため、資料には誤植が含まれる可能性があり、予告なしに随時改定される場合があります。 その他の考慮事項については、使用条件を参照してください。
プロパティ

文書番号:2904510 - 最終更新日: 09/29/2016 15:24:00 - リビジョン: 3.0

Windows Internet Explorer 8, Windows Internet Explorer 9

  • KB2904510
フィードバック