現在オフラインです。再接続するためにインターネットの接続を待っています

For Mac Word があるマクロ ウイルスに感染した場合の対処方法

重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。

英語版 KB:291824
概要
この資料は、マクロ ウイルスとはどのようなコンピューターがあります、Word マクロ ウイルスと思われる場合に実行する、こと文書になるに感染していないマクロ ウイルスに感染することを確認する方法について説明します。
詳細
最初のマクロ ウイルスは、1995 年の夏に発見されました。それ以来、他のマクロ ウイルスが表示されます。

マクロ ウイルスは、Word などのプログラムのマクロ言語を使用して書き込まれる悪意のあるプログラムです。ウイルスは、データ ファイル間で増殖して、ファイルまたはコンピューターのオペレーティング システム損害を与えることができます。

Word マクロ ウイルスを経由しない自由に、インターネットまたはその他のメディア。ユーザーが開くと、文書またはテンプレートにマクロ ウイルスが含まれているのみ移動できます。

マクロ ウイルスは、影響を受けるドキュメントは、電子メール メッセージに埋め込まれているし、ドキュメントを開き、受信者しない限り、電子メールで転送できません。

マクロ ウイルスの症状

Word および Word に Word マクロ ウイルスの症状は、次のドキュメント。
  • 文書を保存しようとするときに、Word のみできます文書をテンプレートとして保存します。

    - または -
  • ファイルのアイコンは、ドキュメントではなく、テンプレートによって似ています。

    - または -
  • 文書を開く、番号 1 を表示するダイアログ ボックスが表示されます。

    - または -
  • マクロユーザー設定のコマンドが [ツール] メニューに表示されません。

    - または -
  • 新しいマクロは、マクロの一覧に表示されます。また、FileSaveAs AutoOpen マクロが表示されます。マクロでこれらの名前がある既に、する場合、コンテンツは、マクロ ウイルスによって変更できます。

    - または -
  • 異常なまたは予期しないメッセージは、Word 文書またはテンプレートを開いたときに表示されます。
注:
  • Word は、マクロ ウイルスを検索したり既存の文書とテンプレートからすべてのマクロ ウイルスを削除しません。だけ警告し、開いている文書にマクロが含まれてかどうか。作業中のマクロを含む文書を開くか開くと、マクロを無効にします。文書に有害なマクロ ウイルスが含まれていないことに確信がない限り、マクロをアクティブにして、ドキュメントを開くされません。
  • サード パーティ製のウイルス対策プログラムは常に有効、頻繁に更新しなければなりません。更新プログラムについては、ベンダーに問い合わせてください。

ウイルス対策プログラムをインストールします。

長期的な解決策をマクロ ウイルス、マクロ ウイルスの検出に特に設計されているウイルス対策ソフトウェアをインストールします。 詳細についてはソフトウェアを検出して、マクロ ウイルスを防止できるウイルス対策ソフトウェア ベンダーは、マイクロソフト サポート技術資料を参照する次の文書番号をクリックします。
49500 ウイルス対策ソフトウェア ベンダーの一覧
Microsoft は、適切なテクニカル サポートを見つけやすいようにサード・パーティの連絡先情報を提供しています。この連絡先情報は予告なく変更する可能性があります。マイクロソフトはこのサード パーティ連絡先情報の正確性を保証しません。

コンピューターと思われる場合、マクロ ウイルスがあります。

マクロ ウイルスがあります、コンピューターと思われる場合にのみ、一時的なソリューションとしては、次の方法を使用します。

方法 1: マクロを無効にして、新しい文書にテキストをコピーします。

この資料に記載されている現象は発生しません、マクロ ウイルスによる影響を受けるにしたくない場合は、マクロ ウイルスに感染する可能性があるファイルを開くときに SHIFT キーを押しを保持します。Shift キーを押しを防ぐ Word の自動マクロ実行します。マクロ ウイルスが存在する場合は、読み込まれません。

方法 2: マクロを削除して、文書を復元

、この資料の前半で説明した現象が発生した場合またはこの資料に記載されていないマクロ ウイルスであることが疑われる場合は、次の疑いのあるマクロを削除して影響を受ける文書を修正するための手順を実行します。

注: <b>これは一時的なソリューションだけです。新しいマクロを作成するための手順を実行可能性があります新しいマクロでは動作しません。
  1. ] メニューの [Word] をクリックし、[終了] をクリックします。通常、ファイルをデスクトップに移動します。これを行うにします。
    1. すべてのプログラムを終了します。
    2. [Finder] メニューの [ホーム移動をクリックします。
    3. ライブラリフォルダーを開きます。
    4. アプリケーションのサポートフォルダーを開きます。
    5. Microsoft フォルダーを開きます。
    6. Officeフォルダーを開きます。
    7. ユーザー テンプレートフォルダーを開きます。
    8. 通常のファイルを右クリックします。[編集] をクリックし、"Normal.dotm"のコピー] を選択します。

  2. Word を起動します。[ファイル] メニューの [開く] をクリックします。
  3. 影響を受けるファイルを含むフォルダーに移動します。
  4. 影響を受けるファイルを選択] をクリックします。すぐにキーを押します。 SHIFT キーを押しし、し、[開く] をクリックします。影響を受けるファイルが Word で開くまで、SHIFT キーを押し続けます。

    注: <b>ファイルを開くときに SHIFT キーを押し、Word の自動マクロが実行されないようにします。
  5. 疑いのあるマクロを削除するには、次の手順に使用します。
    1. [ツール] メニューで、マクロ] をポイントし、[マクロ] をクリックします。
    2. マクロの保存先ポップアップ メニューで、すべてのアクティブなテンプレートやドキュメントを選択します。
    3. 疑いのあるマクロを選択し、[削除] をクリックします。[はい]が表示されたら、マクロを削除するかどうかをクリックします。
    4. すべての疑いのあるマクロを手順 c. を繰り返します。
    5. マクロのダイアログ ボックスを閉じますキャンセルをクリックします。
  6. ウイルスに感染したドキュメントのテキストを回復するには、以下の手順を実行します。
    1. コマンド キーを押しながら A キーを押すか [編集] メニュー [すべて選択] をクリックして、文書全体を選択します。
    2. SHIFT + ← キーを押して、選択範囲から文書の最後の段落記号を削除します。
    3. [編集] メニューの [コピー] をクリックします。
    4. [ファイル] メニューの [新規を] をクリックします。テンプレートを使用するを選択し、[ OK] をクリックします。
    5. [編集] メニューの [貼り付け] をクリックします。
    6. ウイルスを含むマクロがレプリケートされていないことを確認するには、手順 7 を繰り返します。
    7. 文書を保存します。
  7. すべてのドキュメントにマクロ ウイルスが含まれていると思われる、次の手順を繰り返します。
注: <b>方法 2 は機能しない場合は、方法 3 を実行してください。

方法 3: マクロ ウイルスを一時的にクリーンアップする構成内容変更を使用します。

マクロ ウイルスをクリーンアップする構成内容変更を使用します。感染したファイルを開いた後に他のファイルを開く場合は、これらのファイル可能性がありますが感染しているにも注意してください。

標準テンプレートからウイルスを削除する、以下の手順を実行します。
  1. すべてのドキュメントを閉じます。感染した文書を開いている場合、簡単に再感染する場合が、標準テンプレートです。
  2. [ツール] メニューテンプレートとアドイン] をクリックし、構成内容変更] をクリックします。
  3. マクロ プロジェクト項目] タブをクリックし、名前の変更または以下のマクロをすべて削除します。
    • NewMacros
    • AutoClose
    • AutoExec
    • AutoOpen
    • FileExit
    • FileNew
    • FileOpen
    • FileSaveAs
    • マクロ
    • ToolsMacro
  4. [閉じる] をクリックします。
  5. Shift キーを押しながら、テンプレートを保存するには、[ファイル] メニューの [すべてを保存] をクリックします。
感染した文書からマクロ ウイルスを削除します。

ファイルが感染している場合、1 ~ 5 の手順と同じ方法を使用するが、マクロを標準テンプレートと、感染した文書 (テンプレート) で、開催者から削除します。完了したらとキーを押して SHIFT キーを押しながら、[ファイル] メニューで、[すべてを保存] をクリックして、次のファイルに移動します。感染したファイルを開くたびに感染して、標準テンプレート標準テンプレートから繰り返しマクロを削除する必要がありますので注意してください。

方法 4: ウイルスに感染したファイルを新しい文書に挿入します。

このメソッドは、 [ツール] メニューからマクロユーザー設定が削除され、「キャップ」のマクロ ウイルスで特に便利です。

注: <b>このような場合テンプレートとアドインツールメニューが機能しません。
  1. ] メニューの [Word] をクリックし、[終了] をクリックします。標準テンプレートをデスクトップに移動します。これを行うにします。
    1. すべてのプログラムを終了します。
    2. [Finder] メニューの [ホーム移動をクリックします。
    3. ライブラリフォルダーを開きます。
    4. アプリケーションのサポートフォルダーを開きます。
    5. Microsoft フォルダーを開きます。
    6. Officeフォルダーを開きます。
    7. ユーザー テンプレートフォルダーを開きます。
    8. 右 clickNormal ファイル。[編集] をクリックし、"Normal.dotm"のコピー] を選択します。

  2. Word を起動し、確認し、そのマクロをカスタマイズします。[ツール] メニューに表示されます。
  3. 新しい文書を開きます。[挿入] メニューの [ファイル] をクリックします。
  4. 影響を受けるファイルを含むフォルダーに移動します。
  5. 影響を受けるファイルを選択] をクリックします。
  6. SHIFT キーを押し押しし、[開く] をクリックします。影響を受けるファイルが Word で開くまで、SHIFT キーを保持し続けます。
    注: <b>ファイルを開くときに SHIFT キーを押し、Word の自動マクロが実行されないようにします。
  7. ([なし] が表示されます)、新しいドキュメントにマクロが存在するかどうかを確認するには、[ツール] メニューの [マクロ] をポイントし、[マクロ] をクリックします。マクロのポップアップ一覧で、すべてのアクティブなテンプレートやドキュメントをクリックします。[マクロ名] マクロは表示されません。[キャンセル] をクリックします。
  8. 別のファイル名でファイルを保存します。
  9. 感染したファイルを削除します。

方法 5: RTF 回避策を使用します。

A. 通常の (グローバル テンプレート) ファイルを削除します。

これは、標準テンプレートに保存されているマクロの問題です。

次の手順は、標準テンプレートを削除します。標準テンプレートの特殊な書式設定セットは削除され、そのテンプレートは、既定の設定にリセットされますに注意してください。
  1. すべてのプログラムを終了します。
  2. [Finder] メニューの [ホーム移動をクリックします。
  3. ライブラリフォルダーを開きます。
  4. アプリケーションのサポートフォルダーを開きます。
  5. Microsoft フォルダーを開きます。
  6. Officeフォルダーを開きます。
  7. ユーザー テンプレートフォルダーを開きます。
  8. という名前のファイルを検索する標準ファイルをクリックし、[ごみ箱に移動] をクリックします。

B. は、マクロを無効にします。

ウイルスのファイルを開くし、マクロ警告を受信すると、ファイルごとに、マクロを無効にします。警告が表示されない場合は、マクロについての警告を有効にする必要があります。これを行うには、次の手順を実行します。
  1. Wordのメニューをクリック設定します
  2. ナビゲーション ウィンドウで、セキュリティ]をクリックし、マクロを含むファイルを開く前に警告する] チェック ボックスをオンします。

C. は、既存のファイルを保存します。

  1. [ファイル] メニューの [名前を付けて保存] をクリックします。
  2. [形式] の一覧で、[リッチ テキスト形式 (RTF)をクリックします。
  3. [保存] をクリックします。

RTF ファイルとしてファイルを保存した後に word 文書 (.doc) 形式で文書を再度保存が、マクロ ウイルスのファイルを上書きまたはを新しいファイルとして文書を保存して、ウイルスを含む古いファイルを削除し。.Doc 形式で新しいファイルを保存した後は、rtf 形式のファイルを削除できます。いくつかの書式設定要素が word 文書 (.doc) 形式から RTF への変換では保持されませんに注意してください。


OFF2004 WD2004 マクロ ウイルスがある場合は、ブートが警告 VBA エディターを起動を起動 mac macword テンプレートが不明なマクロを visual basic のリカバリ構成内容変更をクリーンアップするウイルスに感染したカスタマイズ ツールのアイコンが正しくありませんのエラー メッセージを保存開いて CAP 正しくない autoexec の新しい実行方法

警告: この記事は自動翻訳されています

プロパティ

文書番号:291824 - 最終更新日: 03/22/2015 09:27:00 - リビジョン: 6.0

Microsoft Word 2011 for Mac, Microsoft Word 2004 for Mac

  • dftsdahomeportal kbinfo kbmt KB291824 KbMtja
フィードバック