現在オフラインです。再接続するためにインターネットの接続を待っています

Outlook でタスクの依頼を送信する際、ItemSend 内で添付ファイル付与ができない

現象
Outlook でタスクの依頼アイテムを送信する際の ItemSend イベントにおいて、TaskRequestItem の Attachments.Add を実行しても、受信者に添付ファイルが届かない現象が発生します。
原因
タスクを他者に依頼する場合、タスク依頼アイテム (TaskRequestItem) として送信されますが、受信者がタスク依頼アイテムを [承諾] したタイミングで「タスク」フォルダーに保存されるタスク アイテム (TaskItem) はタスク依頼アイテムに添付されているアイテムになります。そのため、受信者がタスクに紐づけられた添付ファイルを開くためには、タスク依頼アイテムに添付されているタスク アイテム (TaskItem) に添付ファイルを付与する必要がありますが、Outlook Object Model で、タスク依頼アイテムに添付された TaskItem に添付ファイルを付与する方法はありません。
解決方法
回避策
状況
この動作は仕様です。
詳細
関連情報
注意 : これは、マイクロソフトのサポート組織内で直接作成された "緊急公開" の資料です。 この資料には、確認中の問題に関する現状ベースの情報が記載されています。 情報提供のスピードを優先するため、資料には誤植が含まれる可能性があり、予告なしに随時改定される場合があります。 その他の考慮事項については、使用条件を参照してください。
プロパティ

文書番号:2956296 - 最終更新日: 09/20/2016 13:24:00 - リビジョン: 2.0

  • KB2956296
フィードバック
y>