フロントエンド サーバー 2 台構成の Lync Server 2013 Enterprise Edition が抱える問題

現象
Lync Server 2013  Enterprise Edition を、2 台のフロントエンド サーバーと ミラー構成をしたバックエンドサーバでプールを構成した場合のリスクについてご案内いたします。

ひとつのプールに対して、2 台のフロントエンド サーバーを構成し、バックエンド サーバーをミラーリングしている環境において、バックエンド サーバーの障害により、バックエンド データベースをミラーのデータベースにフェイルオーバーすると仮定します。
RTCSHARED db がミラーにフェイルオーバーすると、Lync Server 2013 のベーステクノロジで利用している Windows Fabric のテーブルが更新されず、結果として、1 台のフロントエンド サーバーがダウンすると、5 分ほどでもう 1 台のフロントエンド サーバーもダウンすることとなり、両系ダウンとなります。
原因
2 台のフロントエンド サーバーのうち 1 台が停止すると Quorum を失い サービスが終了してしまうため。
解決方法
フロントエンド サーバーが 2 台しかないフロントエンド プールを展開することは推奨しておらず、回避策はありません。
そのようなプールを展開する必要がある場合は、次のガイドラインに従ってください。

• 2 台のフロントエンド サーバーのうち 1 台が停止した場合、故障したサーバーをできるだけ早く復旧する必要があります。
 同様に、2 台のサーバーのうち 1 台をアップグレードする必要がある場合は、アップグレードが終わり次第、オンラインにします。
• 何らかの理由で両方のサーバーを同時に停止する必要がある場合は、プールのダウンタイムが終わったら次のことをします。

-ベスト プラクティスは、両方のフロント エンド サーバーを同時に再起動することです。
-2 台のサーバーを同時に再起動できない場合は、停止した順序とは逆の順序で復旧する必要があります。
-その順序で起動できない場合は、プールを復旧する前に、次のコマンドレットを使用してください。

Reset-CsPoolRegistrarState -ResetType QuorumLossRecovery -PoolFQDN <FQDN>
注意 : これは、マイクロソフトのサポート組織内で直接作成された "緊急公開" の資料です。 この資料には、確認中の問題に関する現状ベースの情報が記載されています。 情報提供のスピードを優先するため、資料には誤植が含まれる可能性があり、予告なしに随時改定される場合があります。 その他の考慮事項については、使用条件を参照してください。
プロパティ

文書番号:2963359 - 最終更新日: 09/29/2016 11:38:00 - リビジョン: 3.0

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