[XADM] セットアップで Exoledb.dll ファイルを登録できない

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現象
Exchange 2000 のセットアップまたはアップグレード処理中に、セットアップが停止し、Exoledb.dll の登録に関するエラーが表示されることがあります。Exchange 2000 のセットアップ ログには、次のエラー メッセージのいずれかが記録される場合があります。
The command
regsvr32 /s exoledb.dll
failed, returning error code 5 (Access is denied).
または
Setup failed with 0xc103798a registering the base dav protocol.
原因
この現象は、Exoledb.dll ファイルが依存している .dll ファイルが登録されていない場合に発生する可能性があります。
回避策
このエラーを回避するには、次のコマンドをコマンド プロンプトから入力することにより、依存している .dll ファイル (Msdaurl.dll、Msdaipp.dll、および Oledb32.dll) を手動で登録します。ここで、名前.dll には、登録する .dll ファイルの名前が入ります。
regsvr32名前.dll
たとえば、Msdaurl.dll ファイルを登録するには、コマンド プロンプトで次のコマンドを入力します。
regsvr32 msdaurl.dll
通常、Msdaurl.dll、Msdaipp.dll、および Oledb32.dll の各ファイルは、%SystemRoot%\Program Files\Common Files\System\Ole DB フォルダにあります。regsvr32 コマンドは、.dll ファイルが存在するディレクトリで実行する必要があります。

これらのファイルの登録後、[セットアップ] ダイアログ ボックスの [再試行] をクリックすると、Exchange セットアップによって Exoledb.dll が登録され、セットアップを継続することができます。
詳細
Regsvr32 ツールの使用方法を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
249873Explanation of Regsvr32 Usage and Error Messages
関連情報
この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 296436 (最終更新日 2001-06-27) をもとに作成したものです。

プロパティ

文書番号:296436 - 最終更新日: 01/30/2014 07:25:24 - リビジョン: 1.0

Microsoft Exchange 2000 Server Standard Edition

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