インターネット ファイアウォールは、閲覧とファイル共有を妨げる可能性があります

ファイアウォールをオンにすると、ホーム ネットワーク上の他のコンピューターとファイルを検索または共有できなくなる可能性があります。

適用対象: Windows 10 - すべてのエディション、Windows Server 2012 R2
元の KB 番号: 298804

現象

インターネット ファイアウォールを有効にした後は、自宅またはオフィス ネットワーク上の他のコンピューターを検索または参照できない場合があります。 また、自宅やオフィスネットワーク上の他のコンピュータとファイルを共有できない場合があります。 たとえば、Windows XP でインターネット接続ファイアウォール (ICF) 機能を有効にすると、マイ ネットワーク Placesを使用してネットワークを参照できないことがわかります。 また、 コマンドを net view \\computername 使用して、自宅またはオフィス ネットワーク上のコンピューター上の共有を表示すると、次のエラー メッセージが表示される場合があります。

システム エラー 6118 が発生しました。 このワークグループのサーバーの一覧は現在使用できません。

原因

この動作は、自宅またはオフィスネットワークに使用するネットワーク接続でファイアウォールを有効にした場合に発生する可能性があります。 既定では、ファイアウォールは、ファイルと印刷の共有に使用されるポートを閉じます。 目的は、インターネット コンピューターがコンピューター上のファイル共有と印刷共有に接続できないようにすることです。

解決方法

この動作を解決するには、インターネットに直接接続するために使用するネットワーク接続にのみファイアウォールを使用します。 たとえば、ケーブル モデム、DSL モデム、またはダイヤルアップ モデムを介してインターネットに直接接続されている 1 台のコンピューターでファイアウォールを使用します。 同じネットワーク接続を使用してインターネットと家庭またはオフィスの両方のネットワークに接続する場合は、インターネット コンピューターがホーム コンピューターまたはオフィス コンピューター上の共有リソースに接続できないようにするルーターまたはファイアウォールを使用します。

自宅またはオフィスネットワーク専用のポートを開くようにファイアウォールを構成できる場合を除き、自宅またはオフィスネットワークへの接続に使用するネットワーク接続ではファイアウォールを使用しないでください。 自宅またはオフィスネットワークを使用してインターネットに接続する場合、ファイアウォールは、インターネットへの接続を提供するコンピューターまたはルーターなどの他のデバイスでのみ使用できます。 たとえば、管理しているネットワークを介してインターネットに接続し、そのネットワークが接続共有を使用して複数のコンピューターにインターネット アクセスを提供する場合、共有インターネット接続でのみファイアウォールをインストールまたは有効にすることができます。 管理していないネットワークを介してインターネットに接続する場合は、ネットワーク管理者がファイアウォールを使用していることを確認します。

状態

この動作は仕様です。

詳細

ファイアウォールは、コンピューター間の保護バリアを作成し、インターネット上のコンテンツを破損させる可能性のあるソフトウェアまたはハードウェアです。 これは、悪意のあるユーザーから、多くのコンピュータウイルスやワームに対してコンピュータを保護するのに役立ちます.

重要

インターネットに接続されているコンピューター ポートを保護するためにファイアウォールを設定した場合、インターネット上の他のコンピューターに公開される可能性があるため、これらのポートを開かないようにお勧めします。 さらに、特定のコンピューターに開いているポートへのアクセスを許可することはできません。

次のポートは、ファイル共有とサーバー メッセージ ブロック (SMB) 通信に関連付けられています。

  • Microsoft ファイル共有 SMB: 135 から 139 までのユーザー データグラム プロトコル (UDP) ポートと 135 から 139 までの伝送制御プロトコル (TCP) ポート。
  • ネットワーク基本入出力システム (NetBIOS): ポート 445 (TCP および UDP) を使用しないダイレクト ホステッド SMB トラフィック。

Windows x64 エディションのテクニカル サポート

ハードウェアの製造元は、Microsoft Windows x64 エディションのテクニカル サポートとサポートを提供します。 ハードウェアの製造元は、Windows x64 エディションがハードウェアに含まれていたため、サポートを提供します。 ハードウェアの製造元が、一意のコンポーネントを使用して Windows x64 エディションのインストールをカスタマイズしている可能性があります。 独自のコンポーネントとして特定のデバイス ドライバーが組み込まれていることや、ハードウェアのパフォーマンスを最大限に発揮させるためのオプション設定が組み込まれていることがあります。 Windows x64 エディションに関する技術的なヘルプが必要な場合は、Microsoft が合理的な労力のサポートを提供します。 しかし、製造元がハードウェアにインストールして提供するソフトウェアについては製造元によるサポートが最適であるため、 ハードウェアの製造元に直接お問い合わせいただくことが必要な場合があります。

詳細については、「PC を ウイルスから保護する」を参照してください。