[HOWTO] Access 2002 で選択クエリを作成する方法

この資料は、アーカイブされました。これは "現状のまま" で提供され、更新されることはありません。
難易度 : 低。シングル ユーザー コンピュータのユーザー インターフェイスに関する知識が必要です。

この資料は Microsoft Access データベース (.mdb) についてのみ記述したものです。

Microsoft Access 2000 については、次の資料を参照してください。304361

この資料の内容

概要
Microsoft Access では、クエリを作成して 1 つまたは複数のテーブルからデータを取り出すことができます。作成したクエリは、フォーム、レポート、データ アクセス ページのもとになるデータとして使用することができます。この資料では、Microsoft Access でシンプルなクエリを作成する方法と、クエリに並べ替えや抽出条件を指定する方法を説明します。この資料の内容は次のとおりです。
  • 選択クエリとは
  • ウィザードを使って選択クエリを作成する方法
  • デザイン ビューで選択クエリを作成する方法
  • クエリに抽出条件を指定する方法
  • レコードをグループ化して、合計などの集計を行う方法
  • クエリでレコードを並べ替える方法
先頭に戻る

選択クエリとは

選択クエリは、最もよく利用されるクエリです。選択クエリには次のような使い方があります。
  • 抽出条件を指定して 1 つまたは複数のテーブルからデータを取り出し、並べ替えを指定した順序でデータを表示します。
  • 選択クエリをデータシート ビューで開き、レコードを編集して更新します (いくつかの制約があります)。
  • レコードをグループ化して、合計、カウント、平均などの集計を行います。
先頭に戻る

ウィザードを使って選択クエリを作成する方法

Microsoft Access 2002 のノースウィンド サンプル データベースを使って、得意先や受注に関するデータを取り出すクエリを作成する方法を説明します。

: ノースウィンド サンプル データベースは、[ヘルプ] メニューの [サンプルデータベース] をクリックし、[ノースウィンド サンプル データベース] をクリックして、開くことができます。既定のフォルダにインストールした場合は、以下の場所に保存されています。
C:\Program Files\Microsoft Office\Office10\Samples\Northwind.mdb
以下の手順を行うと、ノースウィンド サンプル データベースが変更されます。Northwind.mdb のコピーを作成し、そのコピーに対して作業を行うことをおすすめします。
  1. Microsoft Access 2002 を起動します。
  2. [ヘルプ] メニューの [サンプル データベース] をクリックして、[ノースウィンド サンプル データベース] をクリックします。[メイン スイッチボード] フォームが表示されたら、閉じます。
  3. 左に表示されている [オブジェクト] バーにある [クエリ] をクリックします。
  4. [新規作成 (N) ] をクリックします。(または [挿入] メニューの [クエリ] をクリックします)
  5. [新しいクエリ] ダイアログ ボックスで、[選択クエリ ウィザード] をクリックして、[OK] をクリックします。
  6. [選択クエリ ウィザード] ダイアログ ボックスの [テーブル/クエリ] 一覧で、[テーブル: 得意先] をクリックします。[得意先コード] をダブルクリックして [選択したフィールド] ボックスに追加します。同じように [得意先名]、[担当者名]、[部署] フィールドをダブルクリックして追加します。
  7. 選択クエリ ウィザードの同じページで [テーブル/クエリ] 一覧の [テーブル: 受注] をクリックします。[>>] をクリックして、受注テーブルのすべてのフィールドを [選択したフィールド] ボックスに追加します。
  8. [完了] をクリックします。選択クエリ ウィザードでクエリが作成され、結果がデータシート ビューで表示されます。
先頭に戻る

デザイン ビューで選択クエリを作成する方法

  1. Microsoft Access 2002 を起動します。
  2. [ヘルプ] メニューの [サンプル データベース] をクリックして、[ノースウィンド サンプル データベース] をクリックします。[メイン スイッチボード] フォームが表示されたら、閉じます。
  3. 左に表示されている [オブジェクト] バーにある [クエリ] をクリックします。
  4. データベース ウィンドウで、[デザイン ビューでクエリを作成する] をダブルクリックします。
  5. [テーブルの表示] ダイアログ ボックスで、[得意先] をクリックして [追加] をクリックします。
  6. 同じように、[受注] をクリックして [追加] をクリックします。
  7. [閉じる] をクリックして [テーブルの表示] ダイアログ ボックスを閉じます。
  8. クエリのデザイン画面の上半分にある [得意先] テーブルのフィールド リストの [得意先コード]、[得意先名]、[担当者名]、[部署] フィールドをそれぞれダブルクリックして追加します。
  9. クエリの デザイン画面の上半分にある [受注] テーブルのフィールド リストの [*] をダブルクリックします。[*] を追加すると、すべてのフィールドが追加したことになります。
  10. [ファイル] メニューの [上書き保存] をクリックします。[クエリ名] に Q得意先受注 と入力します。
  11. [クエリ] メニューの [実行] をクリックして、クエリの結果を表示します。
先頭に戻る

クエリに抽出条件を指定する方法

次の手順を行うと、上記の「デザイン ビューで選択クエリを作成する方法」で作成したクエリが変更されます。
  1. Microsoft Access 2002 を起動します。
  2. [ヘルプ] メニューの [サンプル データベース] をクリックして、[ノースウィンド サンプル データベース] をクリックします。[メイン スイッチボード] フォームが表示されたら、閉じます。
  3. 左に表示されている [オブジェクト] バーにある [クエリ] をクリックします。
  4. 上記で作成した [Q得意先受注] クエリをクリックし、[デザイン] をクリックしてクエリをデザイン ビューで開きます。
  5. クエリのデザイン画面の上半分にある [受注] テーブルのフィールド リストの [出荷先都道府県] フィールドをダブルクリックしてデザイン グリッドに追加します。
  6. デザイン グリッドの [出荷先都道府県] 列で、[表示] チェック ボックスをオフにします。

    : このクエリには 受注テーブルから [出荷先都道府県] フィールドと [*] が選択されているため、[出荷先都道府県] フィールドが 2 つ含まれています。このチェック ボックスをオフにすると、[出荷先都道府県] フィールドが 1 つだけ表示されます。
  7. [出荷先都道府県] フィールドの [抽出条件] 行に、たとえば 佐賀県 と入力します。
  8. [ファイル] メニューの [名前を付けて保存] をクリックします。[クエリ名] に Q佐賀県受注 と入力して [OK] をクリックします。
  9. [クエリ] メニューの [実行] をクリックしてクエリの結果を表示します。佐賀県に出荷された受注が表示されることを確認します。
先頭に戻る

レコードをグループ化して、合計などの集計を行う方法

ノースウィンド サンプル データベースを使って、受注の集計を行う集計クエリを作成する方法を説明します。
  1. Microsoft Access 2002 を起動します。
  2. [ヘルプ] メニューの [サンプル データベース] をクリックして、[ノースウィンド サンプル データベース] をクリックします。[メイン スイッチボード] フォームが表示されたら、閉じます。
  3. 左に表示されている [オブジェクト] バーにある [クエリ] をクリックします。
  4. データベース ウィンドウで、[デザイン ビューでクエリを作成する] をダブルクリックします。
  5. [テーブルの表示] ダイアログ ボックスで、[受注] をクリックして、[追加] をクリックします。
  6. [閉じる] をクリックして [テーブルの表示] ダイアログ ボックスを閉じます。
  7. クエリのデザイン画面の上半分にある [得意先] テーブルのフィールドリストの [出荷先都道府県]、[運送料] フィールドをそれぞれダブルクリックして追加します。
  8. [表示] メニューの [集計] をクリックします。[集計] という行がデザイン グリッドに追加されたことを確認します。
  9. [運送料] 列の [集計] 行のセルをクリックし、下向き矢印が表示されたらクリックして [合計] をクリックします。
  10. [ファイル] メニューの [上書き保存] をクリックします。[クエリ名] に Q都道府県ごとの運送料 と入力します。
  11. [クエリ] メニューの [実行] をクリックしてクエリの結果を表示します。都道府県ごとに運送料の合計が表示されることを確認します。
先頭に戻る

クエリでレコードを並べ替える方法

  1. 「レコードをグループ化して、合計などの集計を行う方法」で作成した [Q都道府県ごとの運送料] クエリをデザイン ビューで開きます。
  2. [運送料] 列の [並べ替え] 行のセルをクリックし、下向き矢印が表示されたらクリックして [降順] をクリックします。
  3. [ファイル] メニューの [名前を付けて保存] をクリックします。[クエリ名] に Q都道府県ごとに降順の運送料 と入力します。
  4. [クエリ] メニューの [実行] をクリックして、クエリの結果を表示します。都道府県ごとの運送料の合計が、降順に並べ替えられて表示されることを確認します。
先頭に戻る
関連情報
クエリ作成の詳細については、[ヘルプ] メニューの [Microsoft Access ヘルプ] をクリックします。次に、Office アシスタントまたはアンサー ウィザードに選択クエリまたはクロス集計クエリを作成すると入力し、[検索] をクリックして表示されるトピックを参照します。

パラメータ クエリの作成の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
304352 [HOWTO] Access 2002 でパラメータクエリを作成する方法

先頭に戻る
関連情報
この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 304325 (最終更新日 2003-05-09) を基に作成したものです。
OfficeKBHowTo inf
プロパティ

文書番号:304325 - 最終更新日: 12/06/2015 04:17:52 - リビジョン: 1.0

Microsoft Access 2002 Standard Edition

  • kbnosurvey kbarchive kbhowto kbhowtomaster KB304325
フィードバック