Windows Updateハングし、再起動後に新しい更新プログラムがアンインストールされます
この記事では、システムの再起動後にWindows Updateがハングし、新しくインストールされた更新プログラムがアンインストールされる問題の回避策について説明します。
適用対象: Windows 10 - すべてのエディション、Windows Server 2012 R2
元の KB 番号: 3064434
現象
次のような状況で問題が発生します。
- Windows を実行しているコンピューターがあります。
- Windows Updateから更新プログラムをインストールします。
- これを行うメッセージが表示されたら、Windows を再起動します。
このシナリオでは、再起動プロセス中に次のメッセージが表示されます。
更新プログラムの操作
13% 完了
コンピューターの電源を切らない
これは予期されるメッセージです。 ただし、システムは約 15 分間応答を停止 (ハング) しているように見えます。 この時間が経過すると、システムは再起動します。 ただし、インストールした更新プログラムはアンインストールされるようになりました。
さらに、%SystemRoot%\Logs\CBS の下のCBS.log ファイルに、次のようなエントリが記録される場合があります。
Shtd: シャットダウン処理が完了するまで待機しているタイムアウト - 過去 900000 ミリ秒で進行状況が検出されない
原因
この問題は、信頼されたインストーラー サービスが既定のタイムアウト期間 15 分以内にインストール プロセスを完了しなかったために発生します。
回避策
この問題を回避するには、レジストリでタイムアウト値を大きな値に設定し、修正プログラムを再適用します。 これを行うには、次の手順を実行します。
レジストリ エディターを起動します。
次のサブキーを見つけます。
HKLM\System\CurrentControlSet\Services\TrustedInstaller
TrustedInstaller キーを右クリックし、[アクセス許可] をクリックします。
Administrators グループにフル コントロール ユーザー権限を付与します。
BlockTimeIncrement 値を 2a30 (16 進数) に変更します。
注:
この変更により、タイムアウト値が 3 時間に設定されます。 これは、ほとんどの状況で十分です。 ただし、環境内で大きな値を試す必要がある場合があります。
サーバーを再起動し、修正プログラムをもう一度適用します。
状態
マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。
データ収集
Microsoft サポートの支援が必要な場合は、「展開関連の問題について TSS を使用して情報を収集する」に記載している手順に従って情報を収集することをお勧めします。
フィードバック
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