エラー メッセージ : エラーが発生したため、Spoolsv.exe を終了します

この資料は、アーカイブされました。これは "現状のまま" で提供され、更新されることはありません。
重要 : この資料には、レジストリの編集に関する情報が含まれています。レジストリを編集する前に、問題が発生した場合に備えて、レジストリをバックアップし、復元方法を理解しておいてください。レジストリのバックアップ、復元、および編集方法の詳細については、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986 Description of the Microsoft Windows Registry
256986 Microsoft Windows レジストリの説明
現象
プリンタ ウィンドウを開いた場合、または任意のプログラムから印刷しようとした場合、次のエラー メッセージのいずれかが表示されることがあります。
エラーが発生したため、Spoolsv.exe を終了します。
または
リソース不足のため、プリンタの操作を続行できません。
または
印刷サブシステムを利用できません。
原因
この問題は、コンピュータにインストールされているプリンタ ドライバが破損している場合に発生することがあります。
解決方法
警告 : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリ エディタの誤用により発生した問題に関しては、一切責任を負わないものとします。レジストリ エディタは、自己の責任においてご使用ください。

この問題を解決するには、プリンタとプリンタ ドライバを削除し、次にレジストリの特定のキーの下にあるエントリを削除します。次の手順に従います。
  1. 可能な場合、プリンタ ウィンドウに表示されるプリンタをすべて削除します。

    プリンタを削除するには、プリンタ ウィンドウでプリンタを右クリックし、[削除] をクリックした後、[はい] をクリックして削除を確認します。
  2. プリンタ ウィンドウで [ファイル] メニューの [サーバーのプロパティ] をクリックします。
  3. [ドライバ] タブで、インストールされたプリンタ ドライバをすべて削除します。

    プリンタ ドライバを削除するには [削除] をクリックした後、 [はい] をクリックして確認します。
  4. レジストリ エディタ (Regedit.exe) を起動します。
  5. 次のレジストリ キーをエクスポートします。
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print
  6. 次のキーの下の一覧にある項目をすべて削除します (キー自体は削除しません)。
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers\Version-2
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers\Version-3
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print\Environments\Windows NT x86\Drivers\Version-2
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print\Environments\Windows NT x86\Drivers\Version-3
  7. 次のキーの下にあるデフォルト以外の項目をすべて削除します。
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print\Monitors
    一覧に含まれるデフォルトのモニタは次のとおりです。

    • AppleTalk Printing Devices (Services for Macintosh がインストールされている場合)
    • BJ Language Monitor
    • Local Port
    • PJL Language Monitor
    • Standard TCP/IP Port
    • USB Monitor
    • Windows NT Fax Monitor (Fax モデムがインストールされている場合)

    どの項目がデフォルトでないかの関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
    260142 How to Troubleshoot Windows Printing Problems
    260142 Windows の印刷に関する問題のトラブルシューティング
  8. 次のキーの下の一覧項目をすべて削除します。
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print\Printers
  9. レジストリ エディタを終了します。
  10. コンピュータを再起動し、必要なプリンタを再インストールします。
関連情報
この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 312052 (最終更新日 2003-09-18) を基に作成したものです。
プロパティ

文書番号:312052 - 最終更新日: 12/07/2015 08:08:13 - リビジョン: 1.0

Microsoft Windows 2000 Professional Edition

  • kbnosurvey kbarchive kberrmsg kbprint kbenv kbprb KB312052
フィードバック