Windows 9x から Windows XP へアップグレードを行った場合にデータが失われる

Windows XP のサポートは終了しました

マイクロソフトでは、2014 年 4 月 8 日に Windows XP のサポートを終了しました。この変更は、ソフトウェアの更新プログラムおよびセキュリティ オプションに影響しています。 この変更の意味および保護された状態を維持する方法について説明します。

この記事は、以前は次の ID で公開されていました: JP312942
この資料は、アーカイブされました。これは "現状のまま" で提供され、更新されることはありません。
現象
この問題は Windows 98 , Windows 98 Second Edition , Windows Millennium Edition (以下 Windows 9x) のいずれかから Windows XP へアップグレードを行った場合、以下の二つの現象のうち、どちらかに遭遇する場合があります。

  • Windows 9x において、ユーザ名の最後にピリオド( . )を利用している場合、Windows XP へアップグレードする過程で以下のメッセージが表示されます。

    xxx のアカウントを作成しているときにエラーが発生しました。(xxx はユーザ名になります)

    このユーザの設定は失われます。


  • Windows XP アップグレード後、スタートメニューのショートカットやスタートアップ グループのアイテム、共有ドキュメントの中に含まれる文書や、画像、音楽ファイルなどが失われる可能性があります。

原因
本現象が発生する場合は、以下のいずれかの条件に当てはまる場合です。

  • Windows 9x において、ユーザ名の最後にピリオド( . )を利用している場合
  • Windows XP にアップグレード後に、フルパスで半角 256 文字を超えるディレクトリ構造内にファイルがある場合
解決方法
Windows XP がインストールされるドライブに user~tmp.@01\common Profiles\user_name フォルダが作成され Windows 9x で使用していたユーザ情報が格納されます。その格納されている情報(ファイルやフォルダ)を Windows XP で使用するユーザプロファイル (Documents and Settings\user_name ) にコピーしてください。注意) user_name はユーザ名になります。





状況
マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフトの製品の問題として認識しています。
関連情報
この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 312942 (最終更新日 2001-11-26) をもとに作成したものです。

プロパティ

文書番号:312942 - 最終更新日: 01/12/2015 19:20:06 - リビジョン: 1.1

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • kbnosurvey kbarchive kbhotfixserver kbprb KB312942
フィードバック