ファイルを開いたり保存したりしようとすると、Microsoft Office が応答を停止する
現象
この記事の最後に記載されている Microsoft Office プログラムのいずれかで次のいずれかの手順を実行すると、プログラムが長い間応答を停止 (ハング) することがあります。
- [名前を 付けて保存 ] ダイアログ ボックスの [ 名前を付けて保存 ] ボックスの一覧をクリックします。
- [開く] ダイアログ ボックスの [検索先] リストをクリックします。
[キャンセル] をクリックするか、ダイアログ ボックスを閉じようとしても、プログラムは応答しません。
原因
この問題は、次のいずれかの条件に該当する場合に発生する可能性があります。
- コンピューターが、存在しない、または現在オフラインになっている 1 つ以上のマップされたネットワーク共有に接続されている場合。
- 1 つ以上のマップされたドライブが永続的であり、ドライブが信頼されていないドメイン内にある場合。
- マップされたドライブが低速またはダウンレベルのコンピューターにある場合。 下位レベルのコンピューターとは、コンピューターのオペレーティング システムに、使用しているコンピューターよりも以前のバージョンの Microsoft Windows がある場合です)。
- マップされたドライブがワイド エリア ネットワーク (WAN) を介して接続されている場合。
- ドライブがアクセスできないリムーバブル ドライブである場合。
解決方法
この問題を解決するには、「原因」セクションに記載されているいずれかの条件を持つすべてのネットワーク ドライブを切断する必要があります。 それには、以下の手順を実行します。
メモ Microsoft Windows には複数のバージョンがあるため、お使いのコンピューターでは次の手順が異なる場合があります。 該当する場合は、製品ドキュメントを参照して、これらの手順を完了してください。
- [マイ コンピューター] を右クリックし、[ ネットワーク ドライブの切断] をクリックします。
- [ ネットワーク ドライブの切断 ] ダイアログ ボックスで、切断するドライブの文字をクリックし、[OK] をクリックします。
- すべてのオフライン ネットワーク ドライブが切断されるまで、手順 1 と手順 2 を繰り返します。 特定のドライブがわからない場合は、次の手順に従います。
[スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。
[開く] ボックスに次のように入力し、Enter\computer name\share name キーを押します
ここで、コンピューター名はリソースを共有しているサーバーの名前で、共有名は使用する共有リソースの名前です。
リソースが使用できない場合は、次のようなエラー メッセージが表示されます。
ネットワーク名が見つかりません。
または、Windows エクスプローラーでドライブの内容を表示することもできます。
回避策
この動作を回避するには、次のいずれかの方法を使用します。
方法 1: 永続的な接続を使用しない
マップされたドライブを接続する場合は、クリックして [ログオン時に再接続] チェックボックスをオフにします。 このチェックボックスをオフにすると、次回コンピューターにログオンするときに、マップされたドライブは接続されません。 ネットワーク ドライブをマップする方法の詳細については、「詳細情報」セクションを参照してください。
方法 2: ユーザー ログオン スクリプトを使用する
可能な場合は、ログオン スクリプトを使用して、ユーザーがログオンするたびにユーザーを適切なサーバーに接続します。 スクリプトによってドライブが非永続的な状態でマップされていることを確認します。 ログオン スクリプトの実行中にドライブが使用できない場合、ドライブはマップされません。 この動作により、問題が回避されます。
方法 3: サーバー ミラーリングを使用する
接続がワイド エリア ネットワーク (WAN) 経由の場合は、サーバー ミラーリングの実装を検討してください。 サーバー ミラーリングは、遠隔サーバーをローカルで複製します。 次に、ドライブをローカルの重複するサーバーにマップします。 これを行うと、ローカル サーバーに接続することで待機時間を短縮できます。
方法 4: ネットワークの場所へのショートカットを使用する
Microsoft Windows デスクトップまたはマイ ネットワーク Placesのショートカットを使用して、目的のネットワークの場所に接続します。
詳細情報
リスト内の各場所がチェックされ、Microsoft Office プログラムで次の両方の手順を実行するときに、その場所が使用可能であり、アクセス許可があることを確認します。
- または を開いてファイルを保存しようとするとします。
- [検索] または [保存] リストにアクセスします。
マップされたドライブが「原因」セクションに記載されている状態にある場合、Office プログラムによって条件が検出されて解決されるまでに時間がかかります。 この動作を回避するには、そのマップされたドライブを切断する必要があります。 Windows エクスプローラーでは、いつでもドライブの可用性を確認できます。 ドライブが使用可能な場合は、後でもう一度ネットワーク ドライブをマップします。
ドライブをオンラインのリソースに再度マップするには、次の手順に従います。
[マイ コンピューター] を右クリックし、[ ネットワーク ドライブのマップ] をクリックします。
[ドライブ] ボックスで、ネットワーク ドライブに使用するドライブ文字をクリックします。
[フォルダー] ボックスに、次の \computer name\share 名を入力します
ここで、コンピューター名はリソースを共有しているサーバーの名前で、共有名は使用する共有リソースの名前です。
マップされたドライブを永続的に解除するには、[ログオン時に再接続する] ボックスをクリックしてオフチェック。
[完了] をクリックします。
他のネットワーク上のリソースに接続しようとしている場合は、ネットワーク管理者に問い合わせてください。 存在しなくなったネットワーク ドライブ、共有されていないドライブ、またはアクセスできないリムーバブル ドライブは、Office 製品のパフォーマンスに影響を与えないように完全に切断する必要があります。
フィードバック
https://aka.ms/ContentUserFeedback」を参照してください。
以下は間もなく提供いたします。2024 年を通じて、コンテンツのフィードバック メカニズムとして GitHub の issue を段階的に廃止し、新しいフィードバック システムに置き換えます。 詳細については、「フィードバックの送信と表示