現在オフラインです。再接続するためにインターネットの接続を待っています

お使いのブラウザーはサポートされていません

このサイトを利用するには、ブラウザーを更新する必要があります。

Internet Explorer を最新バージョンに更新する

Visual Basic のアップグレード ウィザードを使用する方法

重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。

英語版 KB:317885
概要
このステップ バイ ステップの資料で単純なを作成する方法について説明します。Visual Basic 6.0 のアプリケーションと、アップグレードが Visual Basic.NET 2005 Visual Studio .net の 2005 年の Visual Studio Visual Basic のアップグレード ウィザードを使用しての Visual Basic。

Visual には Visual Basic .net のアップグレード ウィザードが含まれていますStudio .net Professional。

Visual Basic 2005年アップグレード ウィザードは、Visual Basic の以前のバージョンから拡張されています。 back to the top

要件

以下に、推奨されるハードウェア、ソフトウェアを説明する、ネットワーク インフラストラクチャ、スキル、知識、および service pack は必要があります。
  • Microsoft Windows 2000 Professional (またはサーバー)、またはMicrosoft Windows XP Professional (またはサーバー) と.NET Frameworkインストールされています。
  • Microsoft Visual Basic 6.0
  • Northwind の Microsoft SQL Server 7.0 またはそれ以降データベースは、適切なアクセス許可とユーザー Id とパスワードの値
必要な予備知識:
  • 使用してアプリケーションを作成する方法の一般的な知識Visual Basic 6.0
back to the top

Visual Basic のアップグレード ウィザードを使用します。

次の手順は、単純な Visual Basic を作成する方法を示します6.0 のアプリケーションと、アップグレードを使用してアプリケーションを .net の Visual Basic または Visual Basic 2005Visual Basic アップグレード ウィザード Visual Studio .net の 2005 年の Visual Studio。
  1. [スタート] ボタン、[プログラム] をポイントし、 Microsoft Visual Studio 6.0] をポイントおよび、 Microsoft Visual Basic 6.0] をクリックします。
  2. [新しいプロジェクト] ダイアログ ボックスで、標準 EXEをクリックし、[開く] をクリックします。
  3. このアプリケーションで最初のフォームで ADO を使用して取得するために、レコード セット、および、Microsoft 階層フレキシブル グリッド コントロールのレコード セットを表示コントロールです。Form1 のプロパティ] ダイアログ ボックスの [名前] フィールドに、frmADO.
  4. ツールボックスが表示されていない場合は、[表示] メニューのツールボックスをクリックします。
  5. フォームの大部分に収まるように、ツールボックスから、フレキシブルフォームに配置します。十分な空き領域のままにボタンを配置するのには、フォームの下部にあります。

    注記:フレキシブルアイコンがツールボックスに表示されない場合は、それをツールボックスに追加します。右クリックし、ツールボックスで、し、[コンポーネント] をクリックします。コンポーネントダイアログ ボックスで、 Microsoft 階層フレキシブル グリッド コントロール 6.0 (OLEDB)を利用可能なコンポーネントの一覧から選択する] をクリックし、[ OK] をクリックします。
  6. [ツールボックス] から、フレキシブル、下のフォームにはコマンド ボタンを配置します。プロパティ] ダイアログ ボックスの [キャプション] フィールドに、入力します。 ].
  7. MADOを右クリックし、[コードの表示] をクリックします。データベース接続を作成、次のコードを追加し、ノースウィンド データベースの [商品] テーブルからのデータを含むレコード セットを返します。

    : 次のサンプル コードで、変更する必要があります ユーザー id =<username></username>パスワード =<strong password=""></strong> 正しい値にします。確認ユーザー IDこの操作は、データベースを実行するには、適切なアクセス許可があります。
    Private Sub Command1_Click()    Unload MeEnd SubPrivate Sub Form_Load()    Dim cn As Connection    Set cn = New Connection    cn.ConnectionString = "Provider=sqloledb;Data Source=localhost;database=northwind;user id=<username>;password=<strong password>"    cn.Open        Dim rs As Recordset    Set rs = New Recordset    rs.CursorLocation = adUseClient    rs.Open "select * from products", cn        Set MSHFlexGrid1.DataSource = rsEnd Sub					
  8. フォームを保存するには ctrl キーを押しながら S キーを押します。ファイル] メニューの [名前を付けて保存をクリックします。[名前を付けて保存] ダイアログ ボックスで、[保存] をクリックします。
  9. プロジェクト エクスプ ローラーで、 Project1を右クリックし、 [追加] をクリックし、[フォーム] をクリックします。ファイルを開く] をクリックします。
  10. プロパティ] ダイアログ ボックスの [名前] フィールドに、 frmClipboard.
  11. ツールボックスから、フォームにテキスト ボックスを配置します。テキストフィールドに、入力します。 クイック茶色 fox 遅延の上にジャンプ犬.
  12. テキスト ボックスの下のコマンド ボタンを配置します。プロパティ] ダイアログ ボックスの [キャプション] フィールドに、入力します。 コピー.
  13. 2 番目のコマンド ボタンをフォームに配置します。プロパティ] ダイアログ ボックスの [キャプション] フィールドに、入力します。 貼り付け.
  14. FrmClipboardを右クリックし、[コードの表示] をクリックします。貼り付け、次のコードをコマンド ボタンのイベントをクリックします。このコードで使用して、クリップボードに GET オブジェクトし、テキストを貼り付けます。
    Private Sub Command1_Click()    Clipboard.SetText Text1.SelTextEnd SubPrivate Sub Command2_Click()    Text1.SelText = Clipboard.GetTextEnd Sub					
  15. フォームを保存するには ctrl キーを押しながら S キーを押します。
  16. 最後のフォームがアプリケーションのメイン フォームです。プロジェクト エクスプ ローラーで、 Project1を右クリックし、 [追加] をクリックして、フォームをクリックし、[開く] をクリックして。
  17. プロパティ] ダイアログ ボックスの [名前] フィールドに、 frmmain という名前.
  18. [ツールボックス] から、frmmain という名前のフォーム上のコマンド ボタンを配置します。プロパティ] ダイアログ ボックスの [キャプション] フィールドに、入力します。 ADO.
  19. 2 番目のコマンド ボタンをフォームに配置します。プロパティ] ダイアログ ボックスの [キャプション] フィールドに、入力します。 クリップボード.
  20. Frmmain という名前を右クリックし、[コードの表示] をクリックします。貼り付け、次のコードをコマンド ボタンのイベントをクリックするには他の 2 つのフォームを示してください。
    Private Sub Command1_Click()    frmADO.ShowEnd SubPrivate Sub Command2_Click()    frmClipboard.ShowEnd Sub					
  21. フォームを保存するには ctrl キーを押しながら S キーを押します。
  22. ソリューション エクスプ ローラーで、 Project1を右クリックし、[ Project1 のプロパティ] をクリックします。[スタートアップ オブジェクト] フィールドで、 frmmain という名前のをクリックし、[ OK] をクリックします。
  23. [プロジェクト] メニューで、ADO コンポーネントへの参照を追加するには、参照をクリックします。(2.0 またはそれ以降のすべてのバージョンの操作を行いますが) 、ActiveX データ オブジェクト ライブラリを選択するには、参照可能なライブラリの一覧をクリックします。[Ok]をクリックします。
  24. [ファイル] メニューで、プロジェクトをコンパイルするのには[Project1.exe の作成をクリックします。プロジェクトの作成] ダイアログ ボックスで、 [ok]をクリックします (既定のファイル名をそのまま使用)。
  25. F5 キーを押してデバッグ モードでアプリケーションを実行します。

    : いることを確認する必要がない従来の Visual Basicアップグレードの前に、問題なくアプリケーションを実行します。
  26. Visual Basic の開発環境を終了します。で、メッセージを表示するプロジェクトに変更を保存する[はい] をクリックします。デフォルト名を使用して、プロジェクトを保存します。
  27. [スタート] ボタン、[プログラム] をポイントし、 Microsoft Visual Studio .netには、しMicrosoft Visual Studio .net] をクリックします。
  28. [スタート] ページで、 [プロジェクトを開くをクリックします。Visual Basic 6.0 のプロジェクトを含むフォルダーを検索します。(通常は [ファイル名指定してビジュアル作成するファイルStudio\VB98)。Project1.vdp、] をクリックし、[開く] をクリックします。
  29. これは従来の視覚である Visual Studio の .net が検出されました。基本的なプロジェクトと Visual Basic のアップグレード ウィザードを開始します。ウィザードが表示されます、ステップごとに説明を続行するのには、次の手順をシーケンス:
    • 新しいプロジェクトを既存のプロジェクトを作成します。アップグレードされます。
    • フォーム ファイルとクラス ファイルは、新規にコピーします。プロジェクトです。
    • コンポーネントの一覧は、アップグレード レポートを提供します。正常にアップグレード プロジェクトとコンポーネントはアップグレードされませんでした。正常にします。

  30. アップグレード処理を開始するまでの手順の各をクリックします。、アップグレードは約 30 ~ 60 秒かかります。
  31. ソリューション エクスプ ローラーで、 _UpgradeReport.htmを] をダブルクリックします。アップグレードの結果を表示するレポート。注意してくださいすべてフォームは問題なくアップグレード frmClipboard を除く。
  32. 問題を表示するには、 frmClipboard.vbを展開します。Clipboard.SetTextGetTextが正しくアップグレードされませんでした。問題の解決方法を表示するのには、説明内のリンクをクリックします。
  33. ソリューション エクスプ ローラーで、すべてのフォームにすることに注意してください。元の名前が、ファイルの拡張子を変更してから、.frm。 vb.
  34. 参照を展開します。すべての必要なコンポーネントに参照に注意してください。Visual Basic と ADO の従来型のコンポーネントを使用して追加されました。自動的にします。
  35. フォームのいずれかを右クリックし、[コードの表示] をクリックします。アップグレードのサポート領域を展開します。Visual Studio .net または Visual Studio 2005年を構成する方法この領域が表示されます。さまざまなプロパティと、アップグレードしたコードをサポートするための変数。
  36. ソリューション エクスプ ローラーで、 frmClipboard.vbを右クリックし、[コードの表示] をクリックします。した行の前に記述されたコメントであることに注意してください。アップグレードではありません。
  37. Command1_ClickCommand2_Clickイベント、次のように変更します。
    Private Sub Command1_Click(ByVal eventSender As System.Object, _    ByVal eventArgs As System.EventArgs) Handles Command1.Click        Clipboard.SetDataObject(Text1.Text)    End Sub    Private Sub Command2_Click(ByVal eventSender As System.Object, _    ByVal eventArgs As System.EventArgs) Handles Command2.Click        Text1.SelectedText = _            Clipboard.GetDataObject().GetData(GetType(System.String))    End Sub					
back to the top

完全なコード リスト

完全なコード リスト (frmADO.frm)

Private Sub Command1_Click()    Unload MeEnd SubPrivate Sub Form_Load()    Dim cn As Connection    Set cn = New Connection    cn.ConnectionString = "Provider=sqloledb;Data Source=localhost;database=northwind;user id=<username>;password=<strong password>"    cn.Open        Dim rs As Recordset    Set rs = New Recordset    rs.CursorLocation = adUseClient    rs.Open "select * from products", cn        Set MSHFlexGrid1.DataSource = rsEnd Sub				
back to the top

完全なコード リスト (frmClipboard.frm)

Private Sub Command1_Click()    Clipboard.SetText Text1.SelTextEnd SubPrivate Sub Command2_Click()    Text1.SelText = Clipboard.GetTextEnd SubComplete Code Listing (frmMain.frm)Private Sub Command1_Click()    frmADO.ShowEnd SubPrivate Sub Command2_Click()    frmClipboard.ShowEnd Sub				
back to the top

アプリケーションが動作することを確認してください。

  1. アプリケーションを起動する F5 キーを押します。
  2. プロジェクトを保存するには、プロンプトで [ OKを] をクリックします。
  3. Form1 には、 ADOをクリックします。フォームは、グリッド内のデータが含まれていますが表示されます。これを閉じるフォームです。
  4. Form1 には、[クリップボード] をクリックします。
  5. コピーをクリックします。
  6. 先頭のテキスト ボックスにカーソルを置きますテキストをクリックし、[貼り付け] をクリックします。貼り付けたテキストを参照してくださいする必要があります。
back to the top

トラブルシューティング

Visual Basic .net の以前のバージョンから大きな変化のあります。Visual Basic。複数のプロジェクトでは、いくつかの広範な準備作業のことをお勧めアップグレードする前にします。次のドキュメントが情報を参照してください。容易にアップグレードすること。
back to the top

参照

詳細については、次のマイクロソフト開発者を参照してください。ネットワーク (MSDN) の記事。 back to the top

警告: この記事は自動翻訳されています

プロパティ

文書番号:317885 - 最終更新日: 07/02/2012 05:28:00 - リビジョン: 9.0

  • kbhowtomaster kbmigration kbvs2005applies kbvs2005swept kbmt KB317885 KbMtja
フィードバック
cript> t=">vascript" src="https://c.microsoft.com/ms.js">