PCI-PCI ブリッジ デバイスの割り込みリソースを取得できない

Windows XP のサポートは終了しました

マイクロソフトでは、2014 年 4 月 8 日に Windows XP のサポートを終了しました。この変更は、ソフトウェアの更新プログラムおよびセキュリティ オプションに影響しています。 この変更の意味および保護された状態を維持する方法について説明します。

この記事は、以前は次の ID で公開されていました: JP322302
この資料は、アーカイブされました。これは "現状のまま" で提供され、更新されることはありません。
現象
以下の状況で、PCI-PCI ブリッジ デバイスがそのブリッジによって報告される割り込みリソースを受け取らないことがあります。
  • Intel ベースのコンピュータを使用している場合
  • コンピュータが以下に示すハードウェア アブストラクション レイヤ (HAL) のいずれかを使用している場合
    • 標準 HAL
    • 非 ACPI (Advanced Configuration and Power Interface) のユニプロセッサ MPS 対応 HAL
    • 非 ACPI のマルチプロセッサ MPS 対応 HAL
原因
この現象は、以下の HAL に問題があるために発生することがあります。
  • Halapic.dll - "MPS Uniprocessor PC"
  • Halmps.dll - "MPS Multiprocessor PC"
  • Hal.dll - "Standard PC" (シングル プロセッサ HAL)
解決方法

Windows 2000

Service Pack の情報

この問題を解決するには、Microsoft Windows 2000 の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
260910 最新の Windows 2000 Service Pack の入手方法

修正プログラムの情報

マイクロソフトでは、現在この問題を修正する修正プログラムを提供中ですが、修正プログラムはこの資料に記載された問題のみを修正することを目的としており、障害があったコンピュータに対してのみ適用することを推奨します。この修正プログラムは、今後さらにテストを行う場合があります。この問題で深刻な影響を受けていない場合は、この修正プログラムが含まれる次の Windows 2000 Service Pack がリリースされるまで待つことを推奨します。

この問題を解決するには、Microsoft Product Support Services にお問い合わせのうえ、修正プログラムを入手してください。Microsoft Product Support Services の電話番号一覧およびサポート料金については、次のマイクロソフト Web ページを参照してください。 : Microsoft Support 担当者が、特定の更新プログラムを適用することにより問題が解決されると判断した場合、まれに通常サポート依頼にかかる料金が免除されることがあります。ただし、特定の更新プログラムの対象とならない追加の質問および問題については、通常のサポート料金が適用されます。


PC-AT 互換機
   日付           時刻    バージョン       サイズ    ファイル名   ------------------------------------------------------   2002/11/05  14:43  5.0.2195.6114  95,456  hal.dll        2002/11/05  14:43  5.0.2195.6114  92,160  halapic.dll    2002/11/05  14:43  5.0.2195.6114  93,600  halmps.dll  
NEC PC-9800 シリーズ
   日付           時刻    バージョン       サイズ    ファイル名   ------------------------------------------------------   2002/11/05  14:43  5.0.2195.6114  95,456  hal.dll        2002/11/05  14:43  5.0.2195.6114  92,160  halapic.dll    2002/11/05  14:43  5.0.2195.6114  93,600  halmps.dll  

Windows XP

この問題を解決するには、Windows XP の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
322389 最新の Windows XP Service Pack を入手する方法
状況

Windows 2000

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。この問題は、Microsoft Windows 2000 Service Pack 4 で最初に修正されました。

Windows XP

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。この問題は、Windows XP Service Pack 1 で最初に修正されました。
詳細
Windows 2000 Datacenter Server 用の修正プログラムを入手する方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
265173 Datacenter Program と Windows 2000 Datacenter Server
複数の修正プログラムのインストールを 1 回の再起動のみで行う方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
296861 複数の Windows 更新プログラムまたは修正プログラムを同時にインストールし、再起動を 1 回で済ませる方法
kbBaseOS irq
プロパティ

文書番号:322302 - 最終更新日: 02/27/2014 05:22:00 - リビジョン: 3.0

Microsoft Windows 2000 Service Pack 1, Microsoft Windows 2000 Service Pack 2, Microsoft Windows 2000 Service Pack 3, Microsoft Windows 2000 Advanced Server, Microsoft Windows 2000 Advanced Server, Microsoft Windows 2000 Advanced Server, Microsoft Windows 2000 Service Pack 1, Microsoft Windows 2000 Service Pack 2, Microsoft Windows 2000 Service Pack 3, Microsoft Windows XP Professional

  • kbnosurvey kbarchive kbbug kbfix kbwin2000presp4fix kbqfe kbenv kboswin2000fix kbwinxpsp1fix kbwin2ksp4fix kbhotfixserver KB322302
フィードバック