インターネット経由で Windows Server 2003 をアクティブ化しようとするとエラー: メッセージ番号 32777

この記事では、インターネット経由で Microsoft Windows Server 2003 をアクティブ化するときにエラーが発生する問題の回避策について説明します。

適用対象: Windows Server 2003
元の KB 番号: 816897

現象

インターネット経由で Windows Server 2003 をアクティブ化しようとすると、Windows 製品のライセンス認証が失敗し、次の問題が発生する可能性があります。

  • ユーザー名とパスワードの入力を求めるメッセージが表示されます。

  • 次のエラー メッセージが表示されます。

    アクティブ化サーバーとの接続を確立できません。 ネットワーク設定をチェックし、インターネットに接続できることを確認してから、もう一度やり直してください。 メッセージ番号 32777。

ユーザー名とパスワードを入力したかどうかにかかわらず、Windows 製品ライセンス認証は失敗します。

原因

この問題は、次の条件の両方が当てはまる場合に発生します。

  • Microsoft Internet エクスプローラーのセキュリティ強化構成がサーバーで有効になっています。
  • 基本認証が有効になっているプロキシ サーバーを介してインターネットに接続します。

インターネット エクスプローラーセキュリティ強化構成 (インターネット エクスプローラーセキュリティ強化とも呼ばれます) では、証明書失効が使用されます。 この証明書失効参照プロセスには、URL 取得操作が含まれます。 この場合、URL の取得はプロキシ サーバーを経由し、ログオン ユーザーの明示的なコンテキストの外部で発生します。 そのため、ユーザー アカウント名とパスワードの入力を求めるメッセージが Basic Authentication によって誤って表示されます。 ユーザーは通常、証明書が検証されていることに気付いておらず、一連の証明書の検証中に繰り返しメッセージが表示される場合があります。

この問題を回避するには、以下のいずれかの方法を使用します。

注:

次の方法は、最も好ましい順にリストされ、最も好ましい方法が最初に現れます。

回避策 1: 基本認証を使用しない

プロキシ サーバーで基本認証を使用しないでください。 基本認証を使用する必要がある場合は、証明書失効リスト (CRL) の URL を基本認証の要件から除外します。 これを行うには、プロキシ サーバーで認証されていない CRL の次の一覧を構成します。

  • http://crl.microsoft.com/pki/crl/productsMicrosoftProductSecureServer.crl
  • http://crl.microsoft.com/pki/crl/products/MicrosoftProductSecureCommunications.crl
  • http://crl.microsoft.com/pki/crl/products/MicrosoftRootAuthority.crl
  • http://www.microsoft.com/pki/crl/productsMicrosoftProductSecureServer.crl
  • http://www.microsoft.com/pki/crl/products/MicrosoftProductSecureCommunications.crl
  • http://www.microsoft.com/pki/crl/products/MicrosoftRootAuthority.crl

回避策 2: 電話を使用してアクティブ化する

Windows をアクティブ化しようとすると、この記事の 「現象 」セクションに記載されているエラー メッセージが表示される場合は、Windows のライセンス認証ウィザードの [ 電話 ] ボタンをクリックして、電話で Windows をアクティブ化します。

回避策 3: インターネット エクスプローラーで証明書失効を無効にする

Windows のライセンス認証を成功させるために、インターネット エクスプローラーで証明書失効を無効にします。 これを行うには、次の手順を実行します。

注:

Microsoft では、インターネット エクスプローラーで証明書失効を無効にしないことをお勧めします。

  1. Internet Explorer を起動します。

  2. [ツール] メニューの [インターネット オプション] をクリックします。

  3. [詳細設定] タブをクリックし、[設定] ボックスの一覧で次のチェックボックスをオフにします。

    • 発行元の証明書失効を確認する
    • サーバー証明書の失効を確認する (再起動が必要)
  4. [ダイヤル プラン (電話のコンテキスト)] ボックスで、[参照] をクリックして、ユーザーのダイヤル プランを見つけます。

  5. 終了し、インターネット エクスプローラーを再起動します。

  6. Windows のライセンス認証。

  7. [インターネット エクスプローラー] で、[ツール] メニューの [インターネット オプション] をクリックします。

  8. [詳細設定] タブをクリックし、[設定] ボックスの一覧で次のチェックボックスを選択します。

    • 発行元の証明書失効を確認する
    • サーバー証明書の失効を確認する (再起動が必要)
  9. [ダイヤル プラン (電話のコンテキスト)] ボックスで、[参照] をクリックして、ユーザーのダイヤル プランを見つけます。

  10. 終了し、インターネット エクスプローラーを再起動します。

詳細

その他の問題によってエラー メッセージ番号 32777 が生成される可能性があるため、Setuplog.txt ファイルを表示して、この記事で説明されている問題がこのエラーの原因であるかどうかを判断できます。 状態コード 407 は、通常、この記事で説明されている問題の発生を示します。 Setuplog.txt ファイルに表示される状態コード 407 の例を次に示します。

<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobmain\msobmain.cpp,4423,,DISPID_EXTERNAL_CONNECTEDTOINTERNETEx
<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobcomm\connmgr.cpp,1560,,,WPA HTTP サーバーへの接続が試行されます
<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobcomm\connmgr.cpp,2170,現在のログオン セッションで RAS Autodial を無効にしました
<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobcomm\connmgr.cpp,1480,WPA HTTP サーバーからの HTTP 状態コード 407
<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobcomm\connmgr.cpp,2184,,現在のログオン セッションの RAS Autodial の復元値
<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobcomm\connmgr.cpp,1657,,WPA HTTP サーバーに接続できます
<DateTime,OOBE> トレース,0,,GetPreferredConnection: null
<DateTime,OOBE> トレース,0,,UseModem: false
<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobmain\msobmain.cpp,3049,,DISPID_EXTERNAL_CONNECT
<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobmain\msobmain.cpp,3054,DISPID_EXTERNAL_RECONNECT
<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobmain\msobmain.cpp,4500,DISPID_EXTERNAL_ACTIVATE
<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobmain\msobmain.cpp,6979,,m_pLicenseAgent-AsyncProcessHandshakeRequest>() からの応答を待機中
<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobmain\msobmain.cpp,5724,,m_pLicenseAgent-AsyncProcessHandshakeRequest>() が失敗しました。 エラー = 32777
<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobmain\msobmain.cpp,311,Windows 製品ライセンス認証エラー。
<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobmain\msobmain.cpp,313,,ReturnActivationStatus: Status = 7, Detail = 32777
<DateTime>、OOBE トレース、0、、アクティブ化に失敗しました。 エラー = 7

データ収集

Microsoft サポートの支援が必要な場合は、「展開関連の問題について TSS を使用して情報を収集する」に記載している手順に従って情報を収集することをお勧めします。