現在オフラインです。再接続するためにインターネットの接続を待っています

Outlook 2002 で作成したルールが、Outlook 2003 では表示されず、OWA では表示される

Office 2003 のサポートは終了しました

マイクロソフトでは、2014 年 4 月 8 日に Office 2003 のサポートを終了しました。この変更は、ソフトウェアの更新プログラムおよびセキュリティ オプションに影響しています。 この変更の意味および保護された状態を維持する方法について説明します。

現象
Microsoft Office Outlook 2003 をインストールすると、Microsoft Office Outlook 2002 で作成した、成人向けのコンテンツや不快感を与えるコンテンツをチェックするカスタム ルールが、Outlook 2003 の自動仕訳ウィザードに表示されません。ただし、これらのルールは Microsoft Outlook Web Access (OWA) には依然として存在しています。
原因
この問題は、Outlook 2003 がルールを構成するときに、Microsoft Windows XP で作成されたルールがルールセットから削除されて保存されるために発生します。ただし、ルールセットには、ルール テーブルへの更新中にすべての古いルールを削除する必要があることを示すフラグが正しく付けられません。結果として、Exchange Server コンピュータのルール テーブルに、古いルールが残ります。このため、ルールセットとルール テーブルの両方が更新されるものの、互いに同期しないという現象が生じます。Outlook 2003 を起動すると、ルールセットとルール テーブルの両方に対してルールの確認が行われます。Outlook 2003 は、ルールセットとルール テーブルの内容に不一致があることを検出せず、ルール メッセージを読み込んでユーザー インターフェイスにルールを表示します。Outlook 2003 のユーザー インターフェイスに古いルールは表示されませんが、これらのルールはルール テーブルに依然として存在するため、遅延処理メッセージが生成されます。これらの遅延処理メッセージは Outlook 2003 では無視されますが、Outlook 2002 では処理されます。Outlook Web Access はルール テーブルからルールの一覧を取得するため、Outlook Web Access では、まだ削除されていない古いルールが常に表示されます。
回避策
この問題を回避するには、Outlook を使用してルールをエクスポートし、cleanrules スイッチを指定して Outlook を起動します。次に、Outlook にルールをインポートして戻します。この操作によって、古いルールがルール テーブルから削除されます。これを行うには、以下の手順を実行します。

ルールのエクスポート

  1. Outlook を起動します。
  2. [ツール] メニューの [仕訳ルールと通知] をクリックします。
  3. [オプション] をクリックし、[仕訳ルールをエクスポート] をクリックします。
  4. [保存先] ボックスの一覧で、[マイ ドキュメント] をクリックします。
  5. [ファイル名] ボックスに Outlook Rules と入力し、[保存] をクリックします。
  6. [オプション] を閉じ、[仕訳ルールと通知] を閉じて、Outlook を終了します。

Outlook.exe ファイルの位置の確認

Outlook.exe ファイルの位置を確認するには、以下の手順を実行します。
  1. [スタート] ボタンをクリックし、[検索] をクリックします。
  2. 左側のウィンドウで [ファイルとフォルダすべて] をクリックします。
  3. [ファイル名のすべてまたは一部] ボックスに Outlook.exe と入力します。
  4. [探す場所] ボックスの一覧で [ローカル ハード ドライブ] をクリックし、[検索] をクリックします。
  5. 後で参照できるように、Outlook.exe ファイルへの完全なパスをメモします。

    デフォルトの完全なパスは、C:\Program Files\Microsoft Office\Office11\Outlook.exe です。
  6. 検索結果の画面を閉じます。

Outlook の実行 (/Cleanrules スイッチを指定)

  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。
  2. 引用符を入力し、この資料の「Outlook.exe ファイルの位置の確認」の手順でメモした Outlook.exe ファイルのパスを入力します。続けて引用符とスペースを入力し、/cleanrules と入力します。

    Outlook.exe がデフォルトの位置にある場合、"c:\program files\microsoft office\office11\outlook.exe" /cleanrules などのコマンドを入力します。
  3. [OK] をクリックします。Outlook が起動し、ルールが [仕訳ルールと通知] からクリアされます。

ルールのインポート

  1. [ツール] メニューの [仕訳ルールと通知] をクリックします。
  2. [オプション] をクリックし、[仕訳ルールをインポート] をクリックします。
  3. [ファイルの場所] ボックスの一覧で [マイ ドキュメント] をクリックし、[Outlook Rules] をクリックして、[開く] をクリックします。
  4. [OK] を 2 回クリックします。
状況
マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。
詳細
コマンド ライン スイッチの詳細については、[ヘルプ] メニューの [Microsoft Office Outlook ヘルプ] をクリックし、[アシスタント] ウィンドウの [検索] ボックスにコマンド ライン スイッチと入力します。[検索の開始] アイコンをクリックして、表示されるトピックを参照してください。
ol2003 DAM
プロパティ

文書番号:826964 - 最終更新日: 12/15/2005 08:41:00 - リビジョン: 1.3

  • Microsoft Office Outlook 2003
  • kbprb KB826964
フィードバック